...
Anuta ATOM

L3 Service Automation

Table of Contents

Intended Audience

This document is intended for Network Administrators & Operators that are using ATOM to perform L3 Service Automation.

References

Please reach out to support@anutanetworks.com for more information on ATOM Documentation or Release Information.

L3 Service Provisioning

Anuta ATOM offers out-of-box support for L3 service provisioning. The model defines service configuration elements that can be used to maintain traffic separation across a layer 3 boundary.

The Layer 3 service model is architected to cater to different modes such as Layer 3 Subinterfaces, Layer 3 Interfaces, and Layer 3 VLAN Interfaces.

ATOM’s Layer 3 Service model offers lifecycle management through an abstracted interface to request, configure, and manage Layer 3 Service components. The configuration of network elements may be done using the CLI or other southbound interfaces such as NETCONF in conjunction with ATOM’s device models based on CLI, Native YANG, or OpenConfig.

ATOM Layer 3 Service Model Design

The Layer 3 service model is structured such that the user can configure multiple flavors from the user form. In the below section, different flavors of Layer 3 service provisioning is discussed.

The table below captures each of the Layer 3 service definitions supported by Anuta ATOM

Service Definition Name Service Attributes
Layer 3 Subinterface Layer 3 Subinterface for Cisco IOS-XE devices

802.1Q endpoint interface types

Gigabit & FastEthernet Interface Support

Virtual Routing Function

IPv4 & IPv6 Support

Layer 3 Interface Layer 3 Interface for Cisco IOS-XE devices

Gigabit & FastEthernet Interface Support

Virtual Routing Function

IPv4 & IPv6 Support

Layer 3 VLAN Interfaces Layer 3 Interface VLAN for Cisco-IOS-XE devices

Gigabit & FastEthernet Interface Support

Virtual Routing Function

IPv4 & IPv6 Support

The following sections show the configuration data on the Layer 3 switch when you use this service definition to create the service shown in <point to topology diagram>

Configuration on Layer 3 Switch

Layer 3 Subinterface

This module describes the configurations pushed to the devices to provision a Layer 3 Subinterface. The configurations include dot1q VLAN subinterface on a Layer3 interface, and VRF creation, and attachment to interface, and IPv4 & IPv6 assignment to the physical interface.

The following sections show the configuration data on a Layer 3 switch when you use this service definition to create the service shown

VRF Provisioning

vrf definition vrf66

address-family ipv4

Exit-address-family

Subinterface Provisioning

interface GigabitEthernet3.3321

vrf forwarding vrf66

encapsulation dot1q 3321

ip address 10.63.87.22 255.255.255.0

no shutdown

Layer 3 Interface

This module describes the configurations pushed to the devices to provision a Layer 3 Interface. The configurations include VRF creation and attachment to a physical interface, and IPv4 & IPv6 assignment to the physical interface.

The following sections show the configuration data on a Layer 3 switch when you use this service definition to create the service shown.

VRF Provisioning

vrf definition vrf1128

address-family ipv4

exit-address-family

Interface Provisioning

interface GigabitEthernet4

vrf forwarding vrf1128

ip address 10.63.87.77 255.255.255.0

Layer 3 VLAN Interface

This module describes the configurations pushed to the devices to provision a Layer 3 Interface. The configurations include VLAN interface creation, VRF creation and attachment to a VLAN interface, and IPv4 & IPv6 assignment to the VLAN interface.

The following sections show the configuration data on a Layer 3 switch when you use this service definition to create the service shown

VRF Provisioning

vrf definition vrf1567

address-family ipv4

exit-address-family

Interface Provisioning

interface Vlan1567

vrf forwarding vrf1567

ip address 192.168.11.97 255.255.255.0

no shutdown

Creating a Layer 3 Service Definition

Creating a Layer 3 Subinterface Definition

Use this procedure to create a Layer 3 Subinterface configuration on a Layer 3 switch.

Field Action
Name (Mandatory) Enter a name for Service Definition

Note: The field accepts only a string value.

Device ID (Mandatory) Select a device ID from the drop down list
Interface-Mode (Mandatory) To create a Layer 3 Subinterface, select Sub-Interface as the Interface-Mode.
Interface Select the physical interface on the device chosen in the Device ID field.
Description (Optional) Enter a brief description that should appear on the interface

Note: The field accepts only a string value.

Vrf (Optional) Enter a name for the Virtual Routing Function
Vlan-Id (Mandatory) Specify a VLAN Id to create a dot1q interface

Note: Range 1 through 4096

IP Address Enter a valid IP address
Netmask Enter the corresponding Netmask for the IP Address entered above
Ipv6-Address Enter a valid IPv6 address
Ipv6-Prefix-Length Enter a prefix length for the IPv6 address entered above

Note: Provide CIDR notation

Creating a Layer 3 Interface Definition

Use this procedure to create a Layer 3 Interface configuration on a Layer 3 switch.

Field Action
Name (Mandatory) Enter a name for Service Definition

Note: The field accepts only a string value.

Device ID (Mandatory) Select a device ID from the drop down list
Interface-Mode (Mandatory) To create a Layer 3 Interface, select L3-Interface as the Interface-Mode.
Interface Select the physical interface on the device chosen in the Device ID field.
Description (Optional) Enter a brief description that should appear on the interface

Note: The field accepts only a string value.

Vrf (Optional) Enter a name for the Virtual Routing Function
IP Address Enter a valid IP address
Netmask Enter the corresponding Netmask for the IP Address entered above
Ipv6-Address Enter a valid IPv6 address
Ipv6-Prefix-Length Enter a prefix length for the IPv6 address entered above

Note: Provide CIDR notation

Creating a Layer 3 VLAN Interface Definition

Use this procedure to create a Layer 3 Interface configuration on a Layer 3 switch.

Field Action
Name (Mandatory) Enter a name for Service Definition

Note: The field accepts only a string value.

Device ID (Mandatory) Select a device ID from the drop down list
Interface-Mode (Mandatory) To create a Layer 3 VLAN Interface, select Vlan as the Interface-Mode.
Interface Select the physical interface on the device chosen in the Device ID field.
Description (Optional) Enter a brief description that should appear on the interface

Note: The field accepts only a string value.

Vrf (Optional) Enter a name for the Virtual Routing Function
Vlan-Id (Mandatory) Specify a VLAN Id to create a dot1q interface

Note: Range 1 through 4096

IP Address Enter a valid IP address
Netmask Enter the corresponding Netmask for the IP Address entered above
Ipv6-Address Enter a valid IPv6 address
Ipv6-Prefix-Length Enter a prefix length for the IPv6 address entered above

Note: Provide CIDR notation

Deploying Layer 3 Service configurations to devices

Deploying Layer 3 Subinterface configurations to devices

To provision a Layer 3 Subinterface using Anuta ATOM perform the below actions:

  • On the ATOM instance navigate to Services > Catalog tab
  • Click on the L3-services to navigate to the L3-services instances
  • From the L3-services instances Click on the + to create a new L3 service
  • In the Create L3-service form perform the following actions:
    • Enter the Name for the Service definition
    • Select the device-id from the drop down list offered
Note: You can add only one device at a time
    • Select the Sub-Interface in the Interface-Mode field.
    • Select the corresponding physical Interface on the chosen device. The physical interface will be used to create the sub-interface.
    • Provide a Description for the sub-interface. The sub-interface will be updated with an interface description
    • Enter a Vrf name. A new VRF will be created on the device and will be attached to the sub-interface created. If the VRF already exists, the same will be utilized.
    • Enter a Vlan-Id. A corresponding sub-interface will be created using the physical interface in step d.
    • Enter a valid Ip-Address. The IP Address will be attached to the sub-interface created.
    • Enter the corresponding Netmask to capture the subnet mask.
    • Enter a valid Ipv6-Address. The IPv6 Address will be attached to the sub-interface created.
    • Enter the corresponding v6 prefix in Ipv6-Prefix-Length to complete the fields for provisioning
    • Click on the ✔️to start the device provisioning process.
    • In the Tasks pane, check for Create: l3-service, and navigate to Commands to view the configurations..

The screenshot below shows the fields populated to provision a Layer 3 Subinterface service.

The screenshot below shows the commands generated and pushed to the devices to provision a Layer 3 Subinterface.

Deploying Layer 3 Interface configurations to devices

To provision a Layer 3 Subinterface using Anuta ATOM perform the below actions:

  • On the ATOM instance navigate to Services > Catalog tab
  • Click on the L3-services to navigate to the L3-services instances
  • From the L3-services instances Click on the + to create a new L3 service
  • In the Create L3-service form perform the following actions:
    • Enter the Name for the Service definition
    • Select the device-id from the drop down list offered
Note: You can add only one device at a time
    • Select the L3-Interface in the Interface-Mode field.
    • Select the corresponding physical Interface on the chosen device.
    • Provide a Description for the sub-interface. The sub-interface will be updated with an interface description
    • Enter a Vrf name. A new VRF will be created on the device and will be attached to the sub-interface created. If the VRF already exists, the same will be utilized.
    • Enter a valid Ip-Address. The IP Address will be attached to the sub-interface created.
    • Enter the corresponding Netmask to capture the subnet mask.
    • Enter a valid Ipv6-Address. The IPv6 Address will be attached to the sub-interface created.
    • Enter the corresponding v6 prefix in Ipv6-Prefix-Length to complete the fields for provisioning
    • Click on the ✔️to start the device provisioning process.
    • In the Tasks pane, check for Create: l3-service, and navigate to Commands to view the configurations..

The screenshot below shows the fields populated to provision a Layer 3 Interface.

The screenshot below shows the commands generated and pushed to the devices to provision a Layer 3 Subinterface.

Deploying Layer 3 VLAN Interface configurations to devices

To provision a Layer 3 VLAN Interface using Anuta ATOM perform the below actions:

  • On the ATOM instance navigate to Services > Catalog tab
  • Click on the L3-services to navigate to the L3-services instances
  • From the L3-services instances Click on the + to create a new L3 service
  • In the Create L3-service form perform the following actions:
    • Enter the Name for the Service definition
    • Select the device-id from the drop down list offered
Note: You can add only one device at a time
    • Select Vlan in the Interface-Mode field.
    • Provide a Description for the sub-interface. The sub-interface will be updated with an interface description
    • Enter a Vrf name. A new VRF will be created on the device and will be attached to the sub-interface created. If the VRF already exists, the same will be utilized.
    • Enter a Vlan-Id. A corresponding VLAN interface will be created on the device.
    • Enter a valid Ip-Address. The IP Address will be attached to the new VLAN interface created.
    • Enter the corresponding Netmask to capture the subnet mask.
    • Enter a valid Ipv6-Address. The IPv6 Address will be attached to the VLAN interface created.
    • Enter the corresponding v6 prefix in Ipv6-Prefix-Length to complete the fields for provisioning
    • Click on the ✔️to start the device provisioning process.
    • In the Tasks pane, check for Create: l3-service, and navigate to Commands to view the configurations..

The screenshot below shows the fields populated to provision a Layer 3 VLAN Interface.

The screenshot below shows the commands generated and pushed to the devices to provision a Layer 3 VLAN interface.

Working with Layer 3 Service orders

Viewing Layer 3 Services

  • Once the Layer 3 services are created, the service instances can be seen under Services > Catalog > L3-services
  • Click on the Service instance to view the Service Details. An example for Layer 3 Subinterface is shown below.

Deleting Layer 3 Services

  • To delete the Layer 3 services created, navigate to Services > Catalog > L3-services
  • Check ✔️ on the Service instance to be deleted and choose the delete icon.
  • The Task pane will capture the deletion progress. An example for Layer 3 Subinterface is shown below

Additional Resources

For detailed information on Anuta ATOM and its rich set of features, please refer to the resources section on anutanetworks.com