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Getting Started with ATOM

Intended Audience
This document is intended for Network Administrators & Operators that are using ATOM to

perform Network management, configuration management, services automation, and MOPs.

References
1. ATOM Deployment Guide - All aspects of ATOM Deployment including sizing and

deployment process

2. ATOM User Guide - Master [This Document]

3. ATOM User Guide - Remote Agent Deployment Guide

4. ATOM User Guide - Performance Management & Alerting

5. ATOM User Guide - Network Configuration Compliance, Reporting & Remediation

6. ATOM API Guide - Discusses all external interfaces and integration flows

7. ATOM Platform Guide - Discusses Service model, Device model, and Workflow

development

ATOM Solution Overview
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The following sections provide a brief overview of ATOM Features.

Configuration Management

ATOM provides Configuration management capabilities for a wide variety of devices. This includes

configuration archival, scheduling, trigger-driven configuration sync, configuration diff, etc.

Topology

ATOM provides topology discovery through CDP & LLDP. Topology can be displayed hierarchically using

Resource Pools (Device Groups). Topology overlays Alarms and Performance information.

Collection & Reporting

ATOM supports the collection of network operations and performance data through various protocols

like SNMP, SNMP Trap, Syslog & Telemetry. Such information can be visualized in ATOM as reports or can

be rendered on Grafana as Charts. Admin guide discusses Report customization in further detail.

Network Automation

ATOM provides Model driven Network automation for stateful services. Stateful services involve a

Service model (YANG) and some business logic. Service model development is covered in the ATOM

Platform guide. Admin guide discusses how to deploy & operate a service.

Workflow & Low Code Automation
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ATOM provides an intuitive graphical designer to design, deploy and execute simple or complicated

network operations and procedures. It allows the administrator to configure pre-checks and post-checks,

and take approval. Workflow creation will be covered in the ATOM Platform Guide. Admin guide

discusses how to deploy & operate.

Telemetry & Network Analytics

In today’s economy, data is the new oil. Anuta’s ATOM helps organizations collect a massive amount of

network data from thousands of devices and generate detailed in-depth insights that will help them

deliver innovative applications and solutions to their customers. ATOM can collect network data from a

variety of sources including model-driven telemetry, SNMP, and Syslog. The diverse data format of each

source is normalized to provide a single consistent view to the administrator. Grafana is packaged as part

of ATOM to view historical data, observe patterns and predict future trends. Organizations can integrate

their Big Data and AI platform with ATOM to generate business insights from the network element

configuration and operational state.

Procedure to Create Native Telemetry Collection

● Create a new Telemetry Collection

○ Provide the name of collection

○ Choose Junos as platform

○ Select the transport as UDP which we will auto-select the encoding as compact GPB with

Dial Out Mode

● To configure resource filtering on the device, select the filtering tab and choose the sensor name

in dropdown & add regex pattern to configure

○ Select ALL option if we have same resource filter across sensors

● Once the telemetry collection is provisioned, users can’t edit the entry.

○ Subscription is not required in this case.

Closed Loop Automation

Anuta ATOM allows administrators to define a baseline behavior of their network and remediation

actions to be initiated on any violation of this behavior. ATOM collects a large amount of network data

from multi-vendor infrastructure using Google Protobufs and stores it in a time series database. ATOM

correlation engine constantly monitors and compares the collected data with the baseline behavior to

detect any deviations. On any violation, the pre-defined remediation action is triggered thereby always

maintaining network consistency.

The solution simplifies troubleshooting by providing the context of the entire network. Customers can

define KPI metrics and corrective actions to automate SLA compliance.

Multi-Vendor support

Anuta ATOM has the most comprehensive vendor support. It supports thousands of devices spanning

45+ vendors and automates all the use-cases including Data Center Automation, InterCloud,
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Micro-Segmentation, Security as a Service, LBaaS, Campus/Access, Branch/WAN, IP/MPLS Edge, Virtual

CPE, and NFV.

General Concepts

RBAC
Various ATOM Features and Levels of Access (Read, Create, Delete) are customized through
RBAC. This is described in further detail in User Management.

In case you are not able to access certain features or policies / Data please contact your System

Administrator.

Model Driven User Interface
Various ATOM Features is Model Driven or Driven by the Dynamic Pluggable Artifacts. Some of
the following fall into this category:

1. Device Packages
2. Service Packages
3. Workflow
4. Reports

In case you do not find certain functionality expected in ATOM, please contact
support@anutanetworks.com or your System Administrator.

Multi-Tenancy
ATOM supports Multi-Tenancy across organizations and Sub-Tenancy within an Organization.

This allows to vertically slice Any Data / Policies as per the business requirements of the

Customer. Multi-Tenancy including Sharing, Wild Card usage to share across multiple

Sub-tenants, Users within a Sub-Tenant, and more details are discussed in ATOM Multi Tenancy

& Sub-Tenancy

In case you are not able to access certain Features or Policy / Data please contact your System

Administrator.

Viewing the Dashboard
Dashboard provides a simple, integrated, comprehensive view of the data associated with the

resources managed by ATOM. Information about the devices, services, and service approvals

are available “at-a-glance” for the administrator.

Starting from the 7. x release, Dashboard, the landing page of ATOM, is organized into dashlets.

A dashlet is an individual component that can be added to or removed from a dashboard. Each

dashlet is a reusable unit of functionality, providing a summary of the feature or the function

supported by ATOM, and is rendered as a result of the custom queries written in DSL.

12
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You can customize the look of the Dashboard, by adding the dashlets of your choice, and

dragging and dropping (the extreme right corner of the dashlet) to the desired location on the

dashboard.

Each dashlet contains the summary or the overview of the feature or the functionality

supported by ATOM.

For example, the dashlet “Device” displays the summary of devices managed by ATOM.

Some of the statistics that can be of interest in this dashlet could be as follows:

● Total number of devices

● Number of online devices

● Number of offline devices

These statistics can be gathered by ATOM and displayed in the corresponding dashlet depending

on the DSL query written for each of them. You can save the layout containing the dashlets of

your choice and set them in a particular order.

Following table provides a quick summary of the activities that can be Resource Management

activities.

If you want to.. Navigate to ...

Credential Sets, Credential Maps, and Devices Resource Manager > Devices

Device Discovery Resource Manager > Devices > Discovery

Visualize Topology Resource Manager > Devices>Network >

Topology
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Create & Visualize Logical & Hierarchical Network

Device Groups/Resource Pools

Resource Manager > Devices>Network >

Resource Pools

Create physical locations Resource Manager > Devices>Locations

Device Management
Device Management involves onboarding of devices and working with Device inventory,

Configuration, Monitoring & Alerts. Devices can be added manually, through an API or

Automated Discovery using CDP/LLDP.

All Device Mgmt activities can be performed from Device Explorer & Grid View. Following are

the three main views for a Device.

● Grid View - Grid layout of all Devices & and action on a device(s)

● Tree View - Device Group-based tree view of devices that provides a much easier way to

toggle between devices and inspect various device characteristics.

● Topology View - Devices can be visualized in a Topology view

● Device Detail View - On Clicking a Device from Tree View or Grid View a detailed view of

the device is presented. This is the same as the view when a device is selected from the

Tree view

Grid, Tree view & Topology Views can be toggled using the view selector button available at the

bottom right-hand side corner of the page.
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Credential Management

ATOM provides multiple functions like Provisioning, Inventory Collection, etc. Function like

Provisioning can be various ways - Payload (CLI vs YANG or Other) over a Given Transport (SSH,

Telnet, HTTP(S), etc.,). For example, based on the use case ATOM Workflow Engine can use

various Payload + Transport mechanisms to perform Provisioning actions. ATOM helps

accomplish this using:

● Credential Sets - Define the Transport/Connectivity & Authentication to the devices

● Credential Profile - Maps Credential Sets to various functions in ATOM

This addresses various scenarios, some as follows:

● Reuse of same SNMP Credentials across the entire Network while retaining

Device/Vendor Specific Transport for Provisioning.

● Inventory Collection Via SNMP for a Given Vendor/Device vs Telemetry for another

Credential Sets

The following section provides guidance on how to configure device credentials in ATOM.

1. Navigate to Resource Manager > Tree View >Devices > credentials > Sets

2. Create/Edit a Credential Set

● Name: Enter a string that will be used to identify the Credential Set

● Description: Enter a description w.r.t the created Credential Set(Optional)
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SNMP Transport credentials:

Select Transport type as “SNMP” can view below option

● SNMP version: Select the version of SNMP that should be used for device

communication

● SNMP Read Community String: Enter the string that is used by the device to

authenticate ATOM before it can retrieve the configuration from the device

● SNMP Write Community String: Enter the string that is used by the device to

authenticate ATOM while writing configuration to the device

● Timeout: Enter the time taken for the response from the device in seconds.

● Number Of Retries: Enter the number of times the SNMP request is sent when a

timeout occurs.

CLI Device(SSH/TELNET) Transport Credentials:

Select Transport type as “SSH/TELNET”
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● User name: Enter a string that should be used to login to the device

● Password: Enter a string that used be a password for logging into the device

● Enable Password: Enter a password to enter into the privilege exec mode of the

device.

● Mgmt-VRF-Name: Enter the name of the management VRF configured on the

device. This will be used by ATOM to retrieve the audit logs from the device.

● Port Number: Enter the number of the port on the device that should be used for

communication with ATOM

● Command Execution Wait Time: Enter the number (in milliseconds) that ATOM

should wait for the consecutive commands to be executed on the device. Enter any

number between 10 to 30000.

● CLI Configure Command TimeOut: Enter the time (in seconds) that ATOM should

wait for the command line prompt on the device to appear. Enter any between 1 to

1200.

● Max Connections: Enter the number of max connections that can be opened for a

given device at any time.

API Device Transport Credential:

Select Transport type as “HTTP_HTTPS / GRPC”

● User name: Enter a string that should be used to login to the device

● Password: Enter a string that used to be a password for logging into the device
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● Port Number: Enter the number of the port on the device that should be used for

communication with ATOM.

● Max Connections: Enter the number of max connections that can be opened for a

given device at any time.

GRPC Transport credential:

Credential Profile

By default, ATOM has the following out-of-the-box functions:
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● Config Provisioning

● SNMP

● Telemetry

● HTTP provisioning

● NETCONF provisioning

Navigate to Resource Manager > Tree view->Devices > credentials > Profiles

1. Here, provide the name of the credential profile, and description, and add the transport

credentials by choosing the appropriate functions.

2. Below is the snapshot to attach the credential set with the function.
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Credential profile payload in XML:

Credential Maps

Credential Map allows users to map multiple Credentials Profiles to an IP-Address range. This

addresses the following use cases:

● Device Discovery - When ATOM needs to Perform Discovery using SNMP Sweep or

CDP/LLDP. Since devices are yet to be onboarded, explicit assignment is not available.

● Credential profile is mandatory when onboarding a device.

When ATOM needs credentials for a device and an explicit Device to Credential Profile is not

available, ATOM will cycle through the IP Address range and use the first credential profile that

works. The successful Credential Profile is mapped to the device. This process is repeated

whenever ATOM is unsuccessful in communicating with the device using the currently assigned

credential profile.

To create a Credential Map:

1. Navigate to Resource Manager > Tree View >Devices > credentials > Maps

2. Create/Edit Create Credential Map:

● Name: Enter a name for the Credential Map

● Start-IP-address: Enter an IP address in the range from which ATOM starts the sweep

for locating the devices.

● End-IP-address: Enter an IP address in the range beyond which ATOM will not

continue the sweep for locating the devices.

Note: The Start and the End IP address are the range of IP addresses of the devices.

● Credential Profile: Select one or more Credential Profiles shown.
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Device Onboarding

Devices can be onboarded into ATOM using an API, Manually through the User Interface of

Discovery using CDP/LLDP.

Discovering Devices:

Devices discovery is covered in the section - Device Discovery

Adding Device Manually:

We may have scenarios where device discovery is not viable. Some reasons below:

● Lack of support for Layer 2 discovery support on the device

● Operational/Administrative reason to not use LLDP/CDP

● SNMP Sweep discovery is not suitable - IP Address Range is not well defined, contiguous

or some other reasons

Before you begin, it’s mandatory to define Credential Sets & Credential Profiles.
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To Add/Edit a Device:

1. Navigate to Resource Manager > Devices (tree View)

2. Add - Select Add action

a. IP address: Enter the IP address of the device

b. Credential Profile: Select the Credential Profile of the device

c. Driver name: Driver can be selected for API devices.

d. Latitude & Longitude: is a measurement on a globe or map of location north or

south of the Equator on devices

3. Modify - Select Device & Select Edit action

4. Delete - Select one/more device(s) and Select Delete Action

Upon device addition, ATOM will perform the following:

Added Devices are shown in the Devices grid and Device status will be shown in Green if the

device is reachable via SNMP and ATOM is able to work with the device successfully.
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Device Views

ATOM has 3 views for the devices - Tree (Device Explorer), Topology, and Grid.

1. Tree View:
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2. Topology View

3. Grid View:

Device Explorer

Device explorer view will provide the devices, their associated config, and observability

elements in a logical hierarchy. This view contains the available device groups and their

associated devices. By default, all the devices are part of AllDevices Group.
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The device group will have all the corresponding device details Each group and node will have

the following sections:

1. Summary: It provides the device platform, version, serial number, current operating OS,

Device hardware health, Interface summary, Config compliance violations, and Active

alerts and recent activity.

2. Configuration: it provides the entire summary of config-related operations.

a. Config Archive: It shows each config retrieval, type, retrieval & parsing status.

b. Change log: provides the summary of changes in a configuration such as the

number of lines added, deleted, or modified and at what time & corresponding

changes.

c. Config Data: it will provide the entire config tree through YANG models parsing.

This is not applicable for any device group as they can have heterogeneous

models based on the grouping criteria & provisioning interface such as ATOM

abstract device models, OC, or Native models.

3. Monitoring: It contains all possible templates & charts through inheritance from its

group or node level. It will show the default template by default as its monitoring

summary. Refer Monitoring Guide for more details.

4. Alerts: It will show all active alerts and their history by default. Alert filter view is also

available to search & prioritize the alerts. Refer Alerting Guide for more details.

Each device-group view will have a Summary dashboard which can be customizable.

Device Actions

ATOM supports common actions on the Device. These actions can be performed from the

Device Grid view on one or more devices or from within the Device specific view and will be

discussed in the Device Summary section.

Jobs & Subscriptions

Various Collection & Diagnostics jobs can be invoked.

1. Navigate to Devices > select one or more devices

2. Click on the Jobs and select the job to run

a. Jobs action -> Run Device Inventory

b. Jobs action -> Run Extended Inventory

c. Jobs action -> Run Topology Inventory

d. Jobs action -> Retrieve Configs

25
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e. Jobs action -> Run Diagnostics

f. Jobs action -> Run Policy

g. Jobs action -> Run Profile

3. Click on the Subscriptions to configure Syslog Subscription on the Devices

a. This will result in ATOM being configured as a Syslog receiver and is a

configuration change on the device.

Exporting Device Information:

You can export the device information of the devices either in the XML or JSON format.

1. Navigate to Resource Manager > Devices > Tree View(Icon) > Devices

2. Select one or more devices

3. Click the View/Download button and select either the XML or JSON

VTY Sessions

This is used to view the active vty sessions.

1. Navigate to Resource Manager > Devices >

2. Select any device and click on three dotted lines

3. Click the VTY Sessions button
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Default Jobs

Below are the jobs that run during the device onboarding process in the mentioned order.
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1. Device Inventory:  It gathers the Platform, and OS Version through SNMP and gets the

Device ONLINE. If the platform is not found in ATOM then check the Platform guide on

2. Device Extended Inventory: It collects the Serial Number, Interface performance, health,

availability, etc.,

3. Device Diagnostics: ATOM will perform the reachability check through Ping, SNMP, and

Telnet/SSH if they are applicable.

4. Base Config Pull or Config Retrieval: It will retrieve the configuration and persist it in the

database. The configuration will be collected if the credential function is set to Config

SNAPSHOT or any of the PROVISIONING functions. Build data model flag is used to parse

the configuration into YANG entities from the specified config source snapshot.

Below is the example, to backup CLI and netconf XML config and parse the XML version.

Config Type column will show us the source of config retrieval.

All the above operations can be customized for any platform as required and scheduled similarly

to other collection jobs.
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Device Summary

Device summary view provides a quick snapshot of important device attributes including Alarm

summary, interface summary, recent configuration change history, and health.

Device Summary also provides access to the most popular device actions and quick links to

frequently used activities.

1. Navigate to Devices > select a device

2. Click on the Device > Summary> to view the details associated with each attribute.

Device  Tagging:

Dynamic groups can be created by using device tags. These dynamic groups can be used in

Topology, Provisioning, Compliance e.t.c

1. To view Device(s) Tagging then Navigate to Devices > select a device(s)

2. Click on the “Device > Details” Tab

3. Enter one or more tags in the lower right of the device details view
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Attach tag to Device from Device Create/Edit Form:

We can only attach existing tags to the device but won’t be able to create new ones from this

screen.

Create From:
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Edit Form:

Create Dynamic Group Using Tag:
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Use Dynamic Group in Compliance:
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Device Report:

Navigate to Resource Manager->Device Report

From this view we can download Online/Offline devices reports.

34



ATOM User Guide

Filter for online/offline devices:
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Save the filter and pinned to dashboard
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View the saved filter in dropdown

Export device report data
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Configuration Management

Configuration Archive

ATOM Collects Network or Server Configuration through API, NETCONF, or CLI over Telnet or
SSH. ATOM Provides the following Configuration Management relations functions:

1. Fetch, archive, and deploy device configurations
2. Build Stateful Configuration Model for:

a. Devices that support YANG Over NETCONF
b. Devices where Device YANG Model is mapped to Concrete API or CLI

3. Stateful Configuration - Support Create, Update, Delete
4. Stateful Configuration - Configuration Drift & Transactions
5. Compare Startup vs Running
6. Compare Running vs Latest Archived
7. Compare Two Versions of the Same Device
8. Compare Two Versions of Different Devices
9. Base Config vs Latest Version of Multiple Devices
10. Search and generate reports on archived data
11. Compare and label configurations, compare configurations with a baseline, and check

for compliance.
12. You can use the Baseline template to compare with other device configurations and

generate a report that lists all the devices that are non-compliant with the Baseline
template.

13. You can easily deploy the Baseline template to the same category of devices in the
network with dynamic inputs.

14. You can import or export a Baseline template/Config archives.
15. Set Up Event-Triggered Archiving
16. Synchronize Running and Startup Device Configurations
17. Deploy an External Configuration File to a Device
18. Roll Back a Device's Configuration To an Archived Version
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ATOM Collects Device configuration periodically as configured in Jobs->Configuration or upon a

config change event from the device. To trigger configuration collection through config change

notification, ATOM should be configured to receive config change notification through SNMP

Trap or Syslog.

1. To view Device(s) Configuration - Navigate to Devices > select a device(s)

2. Click on the “Configuration > Archive” Tab

3. Select an Entry in the Grid

4. In the Details view - CLI/XML Configuration is displayed

Config Restore

Users can restore a particular configuration from history under ‘Configuration -> Archive’ by

selecting the required row and clicking the ‘Restore Configuration’ option from the toolbar.

Prerequisites:

● Config Restore Package should be activated with the same tenant as the owner.

● Workflow should support the corresponding platform of the device. Supported

platforms are listed along with workflow in Catalog and Definition View and also in

‘Workflow-Definitions’.

Step by step description is shown with the help of images below.
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Configuration Diff:

Configuration differences across various revisions can be viewed by selecting two versions from

the Configuration archive grid.

1. To view Device(s) Configuration - Navigate to Devices > select a device(s)

2. Click on the “Configuration > Archive” Tab

3. Search configuration grid using tags or other attributes

4. Select two configuration revisions

5. Click on “Compare” to launch the configuration diff view
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Configuration Tagging:

The configuration version can be tagged using user-provided flags or tags. This can be used for

filtering and comparison of configuration revisions.

4. To view Device(s) Configuration - Navigate to Devices > select a device(s)

5. Click on the “Configuration > Archive” Tab

6. Select an entry from the configuration revision grid

7. Click on “Update Tags”

8. Enter one or more tags in the lower right of the configuration details view
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Configuration Change Log

Configuration archive provides a full comparison of device configuration changes across

revisions. ATOM provides another view to see config modifications only.

This can be enabled from Admin Settings.

1. Administrations > System> General settings> Admin settings

2. Edit “Admin Settings”

3. Set “generate-config-inventory-event” to true

Config change history for devices can be tracked as follows:

1. Navigate to Devices (Tree View) > select device(s)

2. Click on the “Configuration” Tab

3. Click on the “Change Log” Tab
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Configuration Change Management - Create/Update/Delete

Configuration archive discussed in the “Configuration Management” section provides a

Read-Only view of Device CLI configuration. Additionally, ATOM provides Model driven

configuration for creating, update & delete. This includes the following:

1. Discovery of Device configuration

2. Show a tree view of the configuration

3. Create/Edit/Delete of Device configuration

Configuration Editing can be done from the “Config Data” view:

1. To view Device Configuration - Navigate to Devices > select a device

2. Click on the Configuration> Config Data Tab
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3. From the Tree view select a node and possible operations are shown on the right-hand

side

Note: Create/Edit/Delete from here will send configuration instructions to the device.

ATOM should be set to interactive mode(dry-run:false) from the Administration page.

Device Inventory (SNMP)

All Device inventory collected through the SNMP Collection job is shown in the Entities view.

The following provides guidance on

1. To view Device Configuration - Navigate to Devices > select a device

2. Click on the “Monitoring” Tab

3. Collected data will be shown under MIB-name
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Adding Unmanaged devices

Some devices, with feature capabilities such as L2 only, L2 and L3 both, and L3 only can be

manually added to the Devices table. Such devices are not managed by ATOM and it neither

generate configurations nor pushes any configurations on them. Multiple unmanaged devices

can be on-boarded into the resource pool and each such device can be used during service

instantiation.

To add an Unmanaged device, do the following:

1. Navigate to Resources > Devices > Add Device

2. In the Create device screen, select the Unmanaged option

Enter values in the following fields:

● Host Name: Enter a name for the device

● Device Capability: Select one or more capabilities from the available list.

For example, if you want the device to behave as an L3 device, choose L3Router

from the list.

● Device Type: Select the category of the device that it belongs to. 3. Add network

connections between the null device and its peer device as follows:

● Source Interface: Select the interface, on the null device, from which the

network connection should originate.

● Peer Device: Select the device, managed by ATOM, as the peer device.

● Peer Interface: Select the interface on the peer device where the network

connection should terminate.

Adding Dummy devices

In some scenarios, you may have to create devices for which configurations are created as a

part of a service but are not pushed to any actual device. These logical entities are termed

Dummy Devices and they do not have any real-world counterparts with a pingable IP address.

Device Report
This report provides a consolidated view of all information relative to devices that are
on-boarded onto ATOM.

The report can be filtered based on Device Groups, Device Tags, Vendor, Device Type, etc., and
get a quick overview of device’s details such as Last Extended Inventory, Alerts Count, Number
of Compliance Issues, Last Compliance Run. The user can use the badges to quickly filter
between Offline and Online Devices.
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Applied filters can be saved and later used to quickly apply by selecting the filter from the Filter
dropdown.

Report data can be exported for external use.

Network Topology

Network Connections

Network connectivity is discovered between devices using Layer 2 discovery protocols - CDP &

LLDP. In cases where CDP/LLDP is not supported or enabled on the device, Network connections

can be added Manually using Network connections.

NOTE: Network connections should be added manually between the devices that have LACP

port channels configured on them.

To add a Network Connection, do the following:

1. Go to Resource Manager >Devices > Tree view >Network

2. Click Network Connections and click Add.

3. In the Create Network Connection screen, enter the values in the following fields:

● Unique ID: This is a system-generated ID for a network connection.

● Source Device: Select a Device (origin of the network connection)

● Source Interface: Enter a name for the interface on the source device

● Destination Device: Select a Device (the end of the network connection)

● Destination Interface: Enter a name for the interface on the destination device.

A Network Connection is established between the interfaces of the source and

the destination devices.
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Network Topology

All the devices for each of which network connections are available are displayed in the

topology view.
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Resource Pools
A resource pool is a logical abstraction for flexible management of resources managed by

ATOM. A resource pool can contain child resource pools and you can create a hierarchy of

shared resources. The resource pools at a higher level are called parent resource pools. Users

can create child resource pools of the parent resource pool or of any user-created child resource

pool. Each child resource pool owns some of the parent’s resources and can, in turn, have a

hierarchy of child resource pools to represent successively smaller units of resources.

Resource pools allow you to delegate control over the resources of a host and by creating

multiple resource pools as direct children of the host, you can delegate control of the resource

pools to tenants or users within the organizations.

Using resource pools can yield the following benefits to the administrator:

● Flexible hierarchical organization

● Isolation between pools, sharing within pools

● Access control and delegation

Creating a Resource Pool

1. Navigate to Resource Manager > Network > Resource Pools

2. In the right pane, click the Add Resource Pool button to create a Resource Pool

3. In the Create Resource Pool, enter values in the fields are displayed:
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● Name: Enter a name for the resource pool

● Description: Enter some descriptive text for the created resource pool

● Available for Services: Select this option if the resource pool can be used for creating

services.

● Parent Resource Pool: Select a resource pool that should act as the parent for this

resource pool that is being created.

● Location: Select the name of the site or the geographical location where this resource

pool should be created. See the section, "Locations" for more information about

creating Locations and Location types.

● Deploy: Select this option if the resource pool should be deployed or used in services.

Adding Devices to a Resource Pool

1. Click the created resource pool to add the required devices to it.

Select Resource pool > Add Devices
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2. All the devices available in ATOM are displayed in the left pane.

3. Click Add to include the required devices in the resource pool

4. Select the device from the Drag and Drop the devices pane to the right pane All the

selected devices are now part of the resource pool created earlier.
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Locations
Devices & Resources Pools can be attached to a Physical Location. Location tagging allows

devices and resource pools to be visualized on a Geographical Map in the topology view.

1. To Create/Edit a Location - Resource Manager > devices > network >

Resources-Location >click Add Location

2. In the Create Location screen, enter values in the fields described:

● Name: Add the name of for the data center or the site that you want to create.

● Type: Select from the pre-defined location types from the drop-down menu.

(preferably select Site)

● Block: Enter the name of the block where the location is situated

● Building: Enter the name of the Building

● Street Number: Enter the number of the street where the Building is located

● Latitude: Enter the latitude of the site.

● Longitude: Enter the longitude of the site.

● Street: Enter the street name where the building is located.

○ Country: Select a country from a pre-populated list available in ATOM

○ City: Select a specific city contained in the chosen country.

○ State: Enter the name of the State or province to which the city belongs.

○ Zip Code: Enter the zip code of the City where the Site is located.

○ Parent Location: Select one of the predefined locations (of the type,

Region, or Country) defined earlier.
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For assigning the created Location to a Resource pool, refer to the section, "Creating a

Resource Pool".

After the successful allocation of the Resource Pool to the given Location, you can view it on the

map. Select the created Resource Pool and click View on Map

Location Types

Add the types of the location that should be associated with a Location.

Navigate to Resource Manager > > Devices > Tree View > Network > Location Types
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The default location types available in ATOM are Region, Country, and Data Center

IPAM

IP Address Pool Group

For effective management of IP addresses, you can arrange IP addresses as an ordered

collection and use them while instantiating a service.

1. Navigate to Resource Manager > IPAM > IP Address Pool Groups

2. Click Add IP Address Pool Group in the right pane

3. In the Create IP Address Pool Group screen, enter values in the fields:

a. Name: Enter the name of the IP address pool group

b. Label: Enter the name of the label that describes the IP address pool group

c. Click Add to add IP Address Pools to be included in the IP Address Pool Group

IP Address Pools

A range of IP addresses can be assigned to a pool and associated with a resourcepool.All these

IP addresses will be used during the instantiation of the service.

1. Navigate to Resource Manager > IPAM > IP4- Address Pools

2. Click Add IP Address Pool on the right pane and enter values in the following fields:

● Name: Enter a unique name for the IP address pool
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● CIDR: Enter the CIDR (IP address followed by a slash and number)

● Description: Enter the description for the created IP Address Pool

● Reuse: Select this option if the IP addresses contained in this pool should be reused

across different services.

● Start IP: Enter the start IP address of the range of IP addresses

● End IP: Enter the last IP address in the IP address range.

● Resource Pool: Select the Resource pool to which these IP addresses should be assigned.

All the services that are created in these Resource Pools will use these IP addresses.

Creating IP address entries

IP Address entries are the IP Address Pools that have been reserved for a service.

• Click IP address pool > Action > IP address entries > IPV4

Creating Sub Chunks of the IP Address Pools:

The network contained in an IP address pool can be divided into two or more networks within

it. The resulting sub chunks can be used for different services to be configured on a resource

pool tied with the parent IP address pool.
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IPV6:

Resource Manager > IPAM > IP6- Address Pools

Address-pool-Groups
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VLAN Groups

You can define VLAN groups and VLAN pools and define them as resource boundaries for a

tenant in such a way that these VLAN Pools can be used during service instantiation on a

resource pool.

Adding VLAN Groups

1. Navigate to Resources > IPAM > VLAN Groups

2. In the right pane, click Add VLAN Pool Group

3. In the Create VLAN Pool Group screen, enter values in the following fields:

● Name: Enter a name for VLAN Group

● Description:

4. Click Actions > VLAN pools > VLAN pool to create VLAN pools in the VLAN group:

5. Enter values in the following fields:

● Start VLAN: Enter a number from the valid VLAN range. (1-4096)

● End VLAN: Enter a number from the valid range (1-4096)

● Click Add to add the required resource pools to the VLAN Pools

● Click the VLAN pool > click Actions to add allocated VLAN.
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Configuration Compliance
Configuration Compliance feature allows users to Define & Enforce Configuration Compliance
Standards. This is realized within ATOM using the following primitives.

1. Policies - Define Configuration standards & Remediation Policy by Device Family, Device
Type, OS Type, etc,

2. Profiles - Group multiple policies and apply configuration standards on one or more
devices

3. Reports - Comprehensive compliance reporting view at device level
4. Remediation - Fix Policy Violations on one or more devices

Following diagram summarizes the overall flow.

Configuration Compliance Can address the following scenarios:

1. Check If a particular configuration is present

2. Check If a particular configuration contains a given pattern / should NOT contain a given

pattern.

3. Check If a particular configuration contains a stale/unwanted configuration.

4. Check for User-defined parameterized values (Dynamic inputs) in configuration.

5. Arithmetic checks to enforce thresholds on resource usage and capacity planning.

Example:- Per device Max 100 vrfs to be configured or 20 Vlans to be enabled or 10 BGP

sessions per vrf

6. Group parameterized values to apply the policy. Example valid Values: 'Any',

'AnyEthernet', 'FastEthernet0/.*' etc.
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7. Regex and Jinja2 Parsers In & Between conditions

8. Apply filters on the configuration to categorize config blocks. Ex:- Access vs trunk based

on link speed, Ports description satisfying regex classifiers, Ports which are admin up and

contain IP.

9. Inventory checks for NETCONF/YANG parameters using XPath-based expressions.

10. Parse as Blocks to split the entire running configuration into blocks and search for the

condition match criteria value within each block.

11. Custom Block split definitions based on the start and end expressions you provide in the

Block Start Expression and Block End Expression text boxes.

12. Evaluate each block against a set of conditions with individual actions/severities by using

the Condition Scope as Previously Matched Blocks to parse.

13. Raise single violations for condition violation by any block or multiple violations per

block of violation with individual remediation actions defined.

ATOM supports Configuration Compliance for the following Vendors:

● Cisco Systems

● Juniper Networks

● Fortinet

● Force10 Networks

● Brocade

● PaloAlto Networks

● Riverbed Technology

● F5 Networks

Policies

Compliance policy allows configuration standards to be defined in CLI format and YANG
format(x-path or XML). The following provides a high-level overview of a Policy:

● Policy is a collection of Rules
● A Rule contains one or more Conditions
● Condition describes

○ Expected Configuration. Configuration can be parameterized through Rule
Variables.

○ Action to be taken on a condition evaluation includes CLI commands or Netconf
XML RPC format to be used to remediate a violation.

● A Rule can be attached to one or More device platforms - Vendor, OS Type, Device
Family, Device Type, and OS Version
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Use Cases

#
Configuration
Standard Style

Example Reference

1

Static
Configuration

Example: All Devices in Target Network should Contain

a specific Domain Name

Expected Configuration:

ip domain-name anutacorp.com

Fix Configuration:

<<If missing, configure the above command>>

Scenario1

XPath
Expression

Xpath Expression:

Cisco-IOS-XR-native:native/ip/domain/name=`anutacor

p.com’
Scenario6

XML Template
Payload

Template Payload:

<native

xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native"

>

<ip>

<domain>

<name>net.disney.com</name>

</domain>

</ip>

</native>

Scenario11

2

Dynamic
Configuration
with User
provided
values

Example: Devices in Target Network should have a

specific Loopback interface - Loopback0 or Loopback1

based on user input.

Expected Configuration:

interface {{ interface_name }}

Fix Configuration:

<<If missing, Configure the specific Loopback

interfaces>>

Scenario3

X-path Xpath Expression: Scenario9
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Expression Cisco-IOS-XE-native:native/interface/Loopback/name='

0' and

Cisco-IOS-XE-native:native/interface/Loopback[name=0

]/ip/address/primary/address='{{ lo0_ipv4addr }}' and

Cisco-IOS-XE-native:native/interface/Loopback[name=0

]/ip/address/primary/mask='255.255.255.255' and

Cisco-IOS-XE-native:native/interface/Loopback[name=0

]/ipv6/address/prefix-list/prefix='{{ lo0_ipv6addr }}'

XML Template
Payload

Template Payload:

<native

xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native"

>

<interface>

<Loopback>

<ip>

<address>

<primary>

<address>10.100.99.98</address>

<mask>255.255.255.255</mask>

</primary>

</address>

</ip>

<ipv6>

<address>

<prefix-list>

<prefix>2605:30C0::3B/128</prefix>

</prefix-list>

</address>

</ipv6>

<name>0</name>

</Loopback>

</interface>

</native>

Scenario13

3

Configuration
with Patterns,
Wildcards,
etc.that
require Regular
expressions

Example: All the VTY lines should have specific

exec-timeout and session-timeout configured.

Expected Configuration:

line vty (.*)
session-timeout 10

Scenario4
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exec-timeout 10 0

Fix Configuration:

<<If missing, Configure the timeouts under all matching

VTY lines>>

4
Configuration
with
sub-modes

Example: The physical Interface should not be shut

down and show be in auto-negotiation mode

Expected Configuration:

interface {{ interface_name }}
no shutdown
negotiation auto

Fix Configuration:

<<If missing, Configure the above commands for one or

more interfaces>>

Scenario3

5

Removing
unwanted
extra
configuration

Example: Finding the Devices having extra NTP-server

addresses configured and removing those other than

expected server addresses.

Expected Configuration:

ntp-server 10.1.1.1

Fix Configuration:

<< Configure above ntp-server if not found. Remove any

ntp server other than 10.1.1.1 >>

Scenario2

6

Advanced:
Presence of an
entity value
from one block
in another

Example: Finding the devices in the network which

doesn’t contain the OSPF router-id configured as per

loopback0 IP address.

Expected Configuration:

interface Loopback0

ip address 45.45.45.5 255.255.255.255

!

router ospf 100

router-id 45.45.45.5

Fix Configuration:

router ospf 100

Scenario5
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router-id 45.45.45.5

Scenario 1: IP Domain Name

Scenario: Network Devices must have domain name configured. In this example, we are looking

for the domain name anutacorp.com across all devices in the lab.

Platform:
Cisco IOS-XE

Expected Configuration:
ip domain-name anutacorp.com

Fix-CLI Configuration:
ip domain-name anutacorp.com

Follow the steps below to configure Compliance Policy for the above scenario.

1. Configure Policy

Steps:

● Navigate to Resource Manager > Config Compliance -> Policies
● Click ‘+’ to create new Policy and provide the following information

○ Policy Name
○ Description

66



ATOM User Guide

2. Configure Rules

One or more rules can be configured to express configuration standards. Based on the

complexity of the scenario, configuration standards can be broken up into more than one

condition.

Steps:

● Navigate to Resource Manager > Config Compliance -> Policies
● Create/Select a Policy
● Click ‘+’ to create a new Rule
● ATOM opens up a new wizard as shown below

● Rule has four components
○ Basic Information
○ Platform Selection
○ Rule Variables
○ Conditions & Actions

Basic Information

Provide basic information as described below. The information provided here is for
documentation purposes only.

Rule Name: Provide any Name

Description: Brief explanation of the configuration evaluation that the rule is going to perform.

Impact: If the device configuration does not meet the rule or rules in the policy, type it in the
Impact field.

Suggested Fix: Using which non-compliance can be corrected and the device returns to a state
of
Compliance.
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Platform Selection

Rules contain configuration standards expressed in CLI Configuration format. Configuration

standard can be at the Vendor level, Device Type, Device Platform, OS Type or OS Version.

Steps:

● Navigate to Config Manager > Config Compliance -> Policies -> Rules
● Create/Select a Rule & Provide the following information

○ Vendor
○ OS type
○ Device Family
○ Device Type
○ OS Version
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Note: Platform Selection will be used during Policy execution. Devices that don’t match
the above criteria are skipped.

Note: It’s not common to have more than one Platform

Rule Variables

Rule variables allow configuration to be parameterized.

Steps:

● Navigate to Resource Manager > Config Compliance -> Policies -> Rules
● Create/Select a Rule Variables

○ Key - Provide unique name to identify rule variable
○ Description - Describe rule-input configuration
○ Default Value - Default value. Can be overridden during Policy execution time

Conditions and Actions

Expected configuration & actions to be taken when violations are detected are specified in the
Conditions & Actions section.

Based on the complexity of the scenario, configuration standards can be broken up into more

than one condition.

Steps:

● Navigate to Resource Manager > Config Compliance -> Policies -> Rules
● Create/Select Conditions & Actions

○ Condition Details - Described Below
○ Action Details - Described Below

Condition Details
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Condition section provides users to specify the expected configuration and various options on

how to match the expected configuration including the option to identify sub mode

configuration blocks.

Condition Name: Name of the Condition

Sequence Number: Order of the condition execution.

Scope Details
Condition scope details: Scope could be either a full configuration copy or configuration
matched in prior condition.
● Configuration - Full Configuration
● Previously_Matched_Blocks - Subset of configuration matched by prior condition

Block Options
Start Expression - Regular expression indicating the start of the sub-block.
End Expression - Regular expression indicating the end of the sub-block.

Condition Match Criteria
Operator:
MATCHES_THE_EXPRESSION - Checks whether the condition value exactly matches with
device configuration or not.
DOESNOT_MATCHES_THE_EXPRESSION - Checks whether the condition value does not
match with the device configuration or not.
CONTAINS_STRING - Checks whether the device configuration contains condition value
config or not.
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Rule-Pass-Criteria:
All_SubBlocks - Checks whether the condition value matches in all the blocks or not.
Any_SubBlock - Checks whether the condition value matches in any of the blocks or not.

Value: Value field accepts Configuration Standard as CLI Configuration. Following types of
configuration can be provided:

● Static Configuration
● Dynamic/Parameterized Configuration
● Configuration with Regular Expressions
● Configuration coupled with Jinja2 Templating

Note: For some Vendor Configurations like Cisco IOS-Style, whitespace in command
prefix is mandatory to identify commands at the sub-mode level.

For Scenario 1 - Provide the value as ip domain-name anutacorp.com to search for a given
domain name in the running configuration.

Test Config

Based on the complexity of the configuration standard, the value may be complex and may
need to build up iteratively. Test Config utility helps the CLI configuration condition to be
validated against Test Configuration.

Steps:

● Navigate to Resource Manager > Config Compliance -> Policies -> Rules ->
● Create/Select Conditions & Actions
● Click “Launch Test Config” will launch a form to Test Condition
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Condition Match Operator:
MATCHES_THE_EXPRESSION
DOESNOT_MATCHES_THE_EXPRESSION
CONTAINS_STRING

Value: Sample configuration to be tested. The value will be shown from the Condition Details.
Value can be further refined

Note: Any Edits to Value will reflect in the Condition Details -> Value and Vice-versa.

Test Configuration: Sample device configuration

Rule Variables: The rule variables created in the rule will be shown here with default values.
Values can be modified.

Note: Any Edits to Values will not be reflected in the Rule Variable default values
provided in Rule Variables Section.

Test Results: Based on the Condition Match Operator test results will be shown on the
right-hand side

Action Details

Action can be taken after Condition evaluation. Condition can result in either a “Match” or
“Non-Match”. Depending on the scenario one or both criteria may apply.
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Select Match Action - This option is applicable when Condition evaluates to a Match
Select action:
Continue  - continue execution to next condition
Donot_raise_violation - skip execution and don’t raise violation
Raise_violation_and_continue - raise violation and continue execution to next conditions
Raise_violation - raise violation and skip execution

For Scenario 1, no action needs to be taken during a match condition, so select continue
as action.

Violation severity:
LOW
MEDIUM
HIGH
CRITICAL

Violation message type:
Default_violation_message
User_defined_violation_message

Derive fix CLI commands:
Use_unmatched_block - unmatched config from the block
Use_matched_block - matched config from the block
Use_complete_block - total block config

Select Non-Match Action
Select action:
Continue
Don’t raise violation
Raise violation and continue
Raise violation

For Scenario 1, Action is required when Condition is not matched. Select Raise violation
and continue.

Violation severity:
LOW
MEDIUM
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HIGH
CRITICAL

Violation message type:
Default_violation_message
User_defined_violation_message

Fix CLI: Provide the CLI Configuration to be used for remediation. Fix CLI can be either
provided here or derived.

Option - 1 - Explicit Remediation / Fix CLI
For Scenario 1, Provide “ip domain-name anutacorp.com” in Fix CLI.

Option - 2 - Remediation Commands can be derived from Condition evaluation.

Derive fix CLI commands:
Options below:

Use_unmatched_block
Use_matched_block
Use_complete_block

For Scenario 1, Select “Use_unmatched_block”. Since this is non-match Action,
unmatched_block will be Condition Details->Value and can be used as Fix CLI.
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Scenario 2: NTP Server configuration check

Scenario:

1. All devices in the network should contain the designated ntp server.

2. Remove all other NTP servers

3. In this example

a. Expected ntp-server = 10.0.0.1

Platform:

Cisco IOS-XE

Expected Configuration:
ntp server 10.0.0.1

Fix-CLI Configuration:
ntp server 10.0.0.1
<<Remove Any Other ntp server other than 10.0.0.1>>

This use case uses regular expressions and contains two conditions.

1. Condition-1 - Check for expected config & if not found remediate using Fix CLI.
Fix-cli Configuration :
ntp server 10.0.0.1

2. Condition 2- Check for unwanted ntp-servers and remove them.
Fix-cli Configuration :
no ntp server 10.0.0.2 //Derived
no ntp server 10.0.0.3 //Derived

Steps:
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● Navigate to Resource Manager > Config Compliance -> Policies
● Click ‘+’ to create new Policy and provide the following information

○ Policy Name - NTP_Common_Peer_Configuration
○ Description

● Select the Policy and Click ‘+’ to create new Rule
○ Rule Name - Check_NTP_Common_Peer_Configuration

● Navigate to Config Manager > Config Compliance -> Policies -> Rules
● Select a Rule & Provide the following information

○ Vendor - Cisco Systems
○ OS type - IOSXE
○ Device Family - ALL
○ Device Type - ALL
○ OS Version - ALL

● Rule variables are not required for this scenario.
● Now fill the Conditions and Actions

Condition1

The Verify_NTP condition will check if the NTP server config is present in the device or not.

Here Non-Match Action can be done either using the commands in Fix CLI or using the Derive fix
cli commands.
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● Using the Fix CLI user needs to provide the configuration commands manually.
● Using the Derive Fix CLI Commands user needs to select the use_unmatched_block as

shown below.

Here on Match Action, it will Continue and on Non-Match Action the Derive fix CLI commands
uses the use-unmatched-block to remediate the device.

Condition2

Remove_NTP_Extra_Config condition will use the regex to match and capture the extra NTP
server IP configured in the device other than the expected IP.
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The extra NTP server ip captured will be stored in the backend data structure which is shown in
the Test Results tab.

The captured data will be stored in the condition-search-output
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On Match Action write a jinja2 configuration template to remove the extra ip’s captured using
the above test-result data structure.
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Finally if different NTP servers are present on the device, for Non-Compliant device Fix CLI will
show up as below

Scenario 3: Interface configuration check

Scenario: All devices in the network should have a specific interface in no shutdown state with

auto-negotiation enabled.  The interface block can have extra configuration commands under it

but should be in no shutdown state and auto-negotiation enabled.

Platform:

Cisco IOS-XE

Expected Configuration:
interface {{ interface_name }}
no shutdown
negotiation auto
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Fix-CLI Configuration:
interface {{ interface_name }}
no shutdown
negotiation auto

This use case is an interface block configuration having rule variables. In this use case, as no
shutdown is generally not visible on a device running-config, we will check whether the
interface is in shutdown or not. If shutdown it will remediate to no shutdown.

Steps:
● Navigate to Resource Manager > Config Compliance -> Policies
● Click ‘+’ to create a new Policy and provide the following information

○ Policy Name - Interfaces
○ Description

● Select the Policy and Click ‘+’ to create a new Rule
○ Rule Name - Check_Interfaces

● Navigate to Config Manager > Config Compliance -> Policies -> Rules
● Select a Rule & Provide the following information

○ Vendor - Cisco Systems
○ OS type - IOSXE
○ Device Family - ALL
○ Device Type - ALL
○ OS Version - ALL

● Now create the Rule variables for this scenario.
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In the policy, we will have a jinja rule variable interface_name. Here Verify_Interfaces condition
will check if the interface block config is present in the device or not and under that interface if
no shutdown and negotiation auto is present.

For Scenario3 Condition Match Operator as CONTAINS_STRING will check whether the device
configuration contains condition value or not. If the device configuration contains value, the
result will be Compliant, else Non-Compliant.
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Here on Non-Match Action select Continue and on Match Action add Fix CLI commands to
remediate the device

For Non-Compliant devices Fix CLI will show up later-on as below.
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Scenario 4: Enforce VTY Session Timeouts

Scenario: All devices in the network should contain the network admin preferred VTY session

timeout and exec-timeout on all vty lines. If VTY session-timeout and exec-timeout is not

configured on the device or mismatch with the network admin preferred timeouts, ATOM CLI

compliance can configure the devices with the user preferred VTY timeouts on all the vty lines.

In this example we are considering the VTY session-timeout and exec-timeout as 10 sec.

Platform:

Cisco IOS-XE

Expected Configuration:

line vty (.*)

session-timeout 10

exec-timeout 10 10

Fix-CLI Configuration:

line vty <>

session-timeout 10

exec-timeout 10 10

This use case is using the regex and rule variables and uses jinja2 template for fix-CLI

configuration.

Steps:
● Navigate to Resource Manager > Config Compliance -> Policies
● Click ‘+’ to create a new Policy and provide the following information

○ Policy Name - Enforce_VTY_Session_Timeouts
○ Description

● Select the Policy and Click ‘+’ to create new Rule
○ Rule Name - Check_Enforce_VTY_Session_Timeouts

● Navigate to Resource Manager > Config Compliance -> Policies -> Rules
● Select a Rule & Provide the following information

○ Vendor - Cisco Systems
○ OS type - IOSXE
○ Device Family - ALL
○ Device Type - ALL
○ OS Version - ALL

● Now create the Rule variables for this scenario.
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Here created user-defined rule variables vty_exec_timeout and vty_session_timeout with

default timeout as 10. These rule variables will be used in the condition value.

The verify_session_exec_timeouts condition will check whether the device in the network is

configured with user-preferred VTY timeouts or not.

Here under Condition Match Criteria the Operator used was CONTAINS_STRING to check for

session-timeout and exec-timeout in line vty config.

Here Rule-pass-criteria used All_SubBlocks to check the condition config in all line vty

configurations of the device. If all the line vty is matching with the condition then compliant. If

any of the line vty is not matching then non-compliant.
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The launch Test Config will check values with the Test configuration and gives the Test Result

whether compliant or not.

Here the unmatched line vty will be captured and stored in the backend data structure. The

captured data structure maximizes the view shown below.
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On Match action will continue and on Non-Match Action fix-CLI will use the jinja2 template

configuration written based on the above-captured data structure.
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The Non-compliant device fix-cli configurations derived from the above jinja2 snippet will look

like below.

Scenario 5: Enforce OSPF Router Id as Loopback0

Scenario: All devices in the network should contain the OSPF router-id configured with

loopback0 IP address. If the OSPF router-id is not configured on the device it will configure the

OSPF router-id with the value of loopback0 IP address on the devices.

Platform:

Cisco IOS-XE
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Expected Configuration:

interface Loopback0

ip address 45.45.45.5 255.255.255.255

!

router ospf 100

router-id 45.45.45.5

Fix-CLI Configuration:

router ospf 100

router-id 45.45.45.5

This use case is using the regex and contains two conditions.

1. First condition is to capture and store loopback0 ip address. It will not have a fix-cli

configuration as the intention of the condition is to capture loopback0 ip address.

Fix-cli Configuration :

<< no fix cli configuration >>

2. The second condition will check whether the OSPF router id is the same as the first

condition's captured loopback0 ip address or not. if not matching then it will configure

the OSPF router id with loopback0.

Fix-cli Configuration :

router ospf 100

router-id 45.45.45.5

Steps:
● Navigate to Resource Manager > Config Compliance -> Policies
● Click ‘+’ to create new Policy and provide the following information

○ Policy Name - Enforce_OSPF_Router_Id_as_Loopback
○ Description

● Select the Policy and Click ‘+’ to create new Rule
○ Rule Name - Check_OSPF_Router_Id_Cisco

● Navigate to Resource Manager > Config Compliance -> Policies -> Rules
● Select a Rule & Provide the following information

○ Vendor - Cisco Systems
○ OS type - IOSXE
○ Device Family - ALL
○ Device Type - ALL
○ OS Version - ALL

● Rule variables are not required for this scenario.
● Now fill the Conditions and Actions
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Condition1

Another way of writing the above block configuration using the Block Options Start Expression

is shown below.
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The first line “interface Loopback0” can be written in the start Expression with regex symbol ^

to indicate the block starts with interface Loopback0. The remaining configuration lines can be

written in value.

The launch test config will check the condition value with the Test configuration and will give

the Test Result. Here the captured loopback0 ip address will be stored in the backend data

structure as shown below.
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The Test result in maximize view is shown below. This output will be used in condition2.
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For Non-Match Action violation is being raised and fix-cli is having no commands as this

condition is to capture the loopback0 ip.
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Condition2

The Verify_OSPF_Router_Id_as_Loopback condition will check whether the OSPF router-id is

the same as the first condtion's captured loopback0 IP address or not. if not matching then in

fix-CLI it will configure the OSPF router-id with loopback0.
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On Match Action it will continue. On Non-Match Action it will use the jinja2 template

configuration in fix-cli to configure the OSPF router id with loopback0 ip.
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The Non-compliant device fix-CLI configurations from the jinja2 template configuration is given

below.

Scenario 6: BGP TTL Hop-count

Scenario: All devices in the network should contain the network admin preferred BGP

ttl-security hops. If hops is not configured on the device or mis-match with the network admin

preferred ttl-security hops, ATOM CLI compliance can configure the devices with the user

preferred hops.

In this example, we are considering the ttl-security hops as 5.

Platform:

Cisco IOS-XE

Expected Configuration:

router bgp 65535

bgp log-neighbor-changes

neighbor 2.3.2.6 ttl-security hops 5

Fix-CLI Configuration:

router bgp 65535

bgp log-neighbor-changes

neighbor 2.3.2.6 ttl-security hops 5

This use case is using the regex and rule variables and contains two conditions.

1. First condition is to match the block. It will not have a fix-cli configuration as the

intention of the condition is to match the block.

Fix-cli Configuration :

<< no fix cli configuration >>
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2. Second condition will check whether the BGP ttl-security hops is in the first condition's

matched block or not. if not matching in the block then it will configure the BGP hops.

Fix-cli Configuration :

router bgp 65535

neighbor 2.3.2.6 ttl-security hops 5

Steps:

● Navigate to Resource Manager > Config Compliance -> Policies
● Click ‘+’ to create new Policy and provide the following information

○ Policy Name - BGP_TTL_Hop_Count
○ Description

● Select the Policy and Click ‘+’ to create new Rule
○ Rule Name - Check_BGP_TTL

● Navigate to Resource Manager > Config Compliance -> Policies -> Rules
● Select a Rule & Provide the following information

○ Vendor - Cisco Systems
○ OS type - IOSXE
○ Device Family - ALL
○ Device Type - ALL
○ OS Version - ALL

● Now create the Rule variables for this scenario.

Condition1

The first line “router bgp (.*)” to be written in the start Expression with regex to indicate the

block starts with router bgp. The remaining configuration lines can be written in value.
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On Match Action execution continues to the next condition. On Non-Match Action it will raise a

violation and continue the next condition. The “Fix-CLI” for the condition was written based on

the test results obtained from “Launch Test Config”.

When the start Expression is used the regex captured data will be stored in

“condition_contents” of “aggregated-condition-ouput” in test results.
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Condition2

The Verify_BGP_TTL condition will check whether the router bgp block config matched in the

previous condition has the ttl-security hops or not. if not matching then in fix-cli it will configure

the ttl-security hops.

This condition uses the condition scope details as Previously_Matched_Blocks to check on the

previous condition matched block.

Scenario 7 : NTP_Server_Check

Scenario:

1. All devices in the network should contain the designated ntp servers.

2. Also remove any other NTP Servers if found.

3. In this example

Expected NTP_Servers

server 192.168.20.1

server 192.168.20.2

server 192.168.20.3

Platform:

Junos

Expected Configuration:
system {
ntp {
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server 192.168.20.1;
server 192.168.20.2;
server 192.168.20.3;

}
}

Fix-CLI Configuration:
set system ntp server 192.168.20.1
set system ntp server 192.168.20.2
set system ntp server 192.168.20.3

<<Remove Any Other ntp server other than 192.168.20.1,192.168.20.2,192.168.20.3>>

This use case uses regular expressions and contains two conditions.

3. Condition-1 - Check for expected configuration & if not found, remediate using Fix CLI.
Fix-cli Configuration :
set system ntp server 192.168.20.1
set system ntp server 192.168.20.2
set system ntp server 192.168.20.3

Condition 2- Check for unwanted ntp-servers and remove them.
Fix-cli Configuration :
delete system ntp server 192.168.20.4 //Derived
delete system ntp server 192.168.20.5 //Derived

Steps:
● Navigate to Resource Manager > Config Compliance -> Policies
● Click ‘+’ to create new Policy and provide the following information

○ Policy Name - NTP_Server_Check
○ Description

● Select the Policy and Click ‘+’ to create new Rule
○ Rule Name - Juniper_NTP_server_check

● Navigate to Config Manager > Config Compliance -> Policies -> Rules
● Select a Rule & Provide the following information

○ Vendor - Juniper Networks
○ OS type - ALL
○ Device Family - ALL
○ Device Type - ALL
○ OS Version - ALL

● Rule variables are not required for this scenario.
● Now fill the Conditions and Actions

Condition1

The Verify_NTP condition will check if the NTP server config is present in the device or not.
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Here, Non-Match Action can be done either using the commands in the Fix CLI or using the
Derive fix cli commands.

● Using the Fix CLI user needs to provide the configuration commands manually.

Here on Match Action, it will Continue and on Non-Match Action to remediate the device.
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Condition2

Remove_NTP_Extra_Config condition will use the regex to match and capture the extra NTP
server IP configured in the device other than the expected IP.

On Match Action, write a jinja2 configuration template to remove the extra ip’s captured using
the above test-result data structure.
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Now run the profile then below  report is generated..

Now will perform Fix_Job to push the configuration on device
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Once the fix job is completed commands will be pushed to the device. Then it will run the

profile to update the device status under the report.
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YANG Compliance

Note: In order to use Yang Compliance make sure that the config-snapshot is provided in the

Credential profile, which lets ATOM parse the configuration and store it. For more information

on Credential profile please refer to the credential profile section in the ATOM User guide.

For Yang-based Configuration Compliance, make sure to select the option of Inventory_Data for

Condition scope during Compliance Policy creation. This gives two ways of defining the

Condition Match Criteria

● Xpath Expressions

● XML Template Payload

Policy creation with Xpath Expressions

● Within Condition Match Criteria select “Matches_the_Xpath_Expression”

/”Doesn’t_Matches_the_Xpath_Expression” option for Inventory Operator field

● The Fix Mutation Payload is in Netconf XML RPC format written using the XML template

details for the yang parsed entities.
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Navigate to Resource Manager > Config Compliance > Policy > + (Add Policies)

Few examples

Scenario 7: IP Domain Name

In this example we are looking for the domain name as anutacorp.com across all devices in

the lab using an X-path expression.

Xpath Expression:

Cisco-IOS-XR-native:native/ip/domain/name=`anutacorp.com’

Fix Mutation Payload:

Note: we can use ATOM_DEVICE_ID or inputDeviceId for substituting the deviceId.

<config>

<devices xmlns="http://anutanetworks.com/controller">

<device>

<id>{{ inputDeviceId }}</id>

<native  xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">

<ip>

<domain nc:operation='create'>

<name>anutacorp.com</name>

</domain>

</ip>

</native>
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</device>

</devices>

</config>

Defining Xpath Expression

Defining Fix Payload

Fix Configuration Display in Remediation
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Scenario 8: IP Name-server check

Xpath Expression:

Cisco-IOS-XE-native:native/ip/name-server/no-vrf='192.168.20.1' and

Cisco-IOS-XE-native:native/ip/name-server/no-vrf='192.168.20.2'

Fix Mutation Payload:

<config>

<devices xmlns="http://anutanetworks.com/controller">

<device>

<id>{{ inputDeviceId }}</id>

<native xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">

<ip>

<name-server nc:operation='create'>

<no-vrf>192.168.20.1</no-vrf>

<no-vrf>192.168.20.2</no-vrf>

</name-server>

</ip>

</native>

</device>

</devices>

</config>

Defining Xpath Expression
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Defining Fix Payload

Scenario 9 : NTP server Check

Xpath Expression:

Cisco-IOS-XE-native:native/ntp/Cisco-IOS-XE-ntp:server/server-list/ip-address='192.16

8.20.3' and

Cisco-IOS-XE-native:native/ntp/Cisco-IOS-XE-ntp:server/server-list/ip-address='192.16

8.20.4' and

Cisco-IOS-XE-native:native/ntp/Cisco-IOS-XE-ntp:server/server-list/ip-address='192.16

8.20.5' and
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Cisco-IOS-XE-native:native/ntp/Cisco-IOS-XE-ntp:server/server-list/ip-address='192.16

8.20.6'

Fix Mutation Payload:

<config>

<devices xmlns="http://anutanetworks.com/controller">

<device>

<id>{{ inputDeviceId }}</id>

<native xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">

<ntp>

<server nc:operation="create">

<server-list>

<ip-address>192.168.20.3</ip-address>

</server-list>

<server-list>

<ip-address>192.168.20.4</ip-address>

</server-list>

<server-list>

<ip-address>192.168.20.5</ip-address>

</server-list>

<server-list>

<ip-address>192.168.20.6</ip-address>

</server-list>

</server>

</ntp>

</native>

</device>

</devices>

</config>

Defining Xpath Expression
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Defining Fix Payload

Scenario 10 : Interface Check with rule_variable

Xpath Expression:

Cisco-IOS-XE-native:native/interface/Loopback/name='0' and

Cisco-IOS-XE-native:native/interface/Loopback[name=0]/ip/address/primary/address=

'{{ lo0_ipv4addr }}' and
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Cisco-IOS-XE-native:native/interface/Loopback[name=0]/ip/address/primary/mask='2

55.255.255.255' and

Cisco-IOS-XE-native:native/interface/Loopback[name=0]/ipv6/address/prefix-list/prefi

x='{{ lo0_ipv6addr }}'

Fix Mutation Payload:

<config>

<devices xmlns="http://anutanetworks.com/controller">

<device>

<id>{{ inputDeviceId }}</id>

<native xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">

<interface>

<Loopback nc:operation="create">

<ip>

<address>

<primary>

<address>10.100.99.98</address>

<mask>255.255.255.255</mask>

</primary>

</address>

</ip>

<ipv6>

<address>

<prefix-list>

<prefix>2605:30C0::3B/128</prefix>

</prefix-list>

</address>

</ipv6>

<name>0</name>

</Loopback>

</interface>

</native>

</device>

</devices>

</config>

Defining Rule Variables
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Defining Xpath Expression
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Defining Fix Payload

Scenario 11 : VRF Check with rule_variable

Xpath Expression:

Cisco-IOS-XE-native:native/vrf/definition/name='LON2001' and

Cisco-IOS-XE-native:native/vrf/definition/rd='{{ rd_2001 }}' and

Cisco-IOS-XE-native:native/vrf/definition/address-family/ipv4/mdt/default/address=23

9.232.0.1' and

Cisco-IOS-XE-native:native/vrf/definition/address-family/ipv4/mdt/data/multicast/add

ress='239.232.1.0' and

Cisco-IOS-XE-native:native/vrf/definition/address-family/ipv4/mdt/data/multicast/wil

dcard='0.0.0.255' and

Cisco-IOS-XE-native:native/vrf/definition/address-family/ipv4/route-target/export/asn

-ip='2:2001' and

Cisco-IOS-XE-native:native/vrf/definition/address-family/ipv4/route-target/import/asn

-ip='2:2001'

Fix Mutation Payload:

<config>

<devices xmlns="http://anutanetworks.com/controller">

<device>

<id>{{ inputDeviceId }}</id>

<native xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">
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<vrf>

<definition nc:operation="create">

<rd>2:2001</rd>

<name>LON2001</name>

<address-family>

<ipv4>

<route-target>

<export>

<asn-ip>2:2001</asn-ip>

</export>

<import>

<asn-ip>2:2001</asn-ip>

</import>

</route-target>

<mdt>

<default>

<address>239.232.0.1</address>

</default>

<data>

<multicast>

<address>239.232.1.0</address>

<wildcard>0.0.0.255</wildcard>

</multicast>

</data>

</mdt>

</ipv4>

</address-family>

</definition>

</vrf>

</native>

</device>

</devices>

</config>
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Defining Rule Variables

Defining Xpath Expression

Defining Fix Payload
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● Snmp-string with rule_variable :

basicDeviceConfigs:snmp/snmp-community-list/snmp-string = "{{ community }}"

● Logical A|B : starts-with(vendor-string,'Cisco') or contains(device-family-string,'Cisco

800')

● Logical A&B : starts-with(vendor-string,'Cisco') and contains(device-family-string,'Cisco

800')

● Logical A&(B|C) : contains(vendor-string,'Cisco Systems') and

(contains(device-family-string,'Cisco 800') or contains(device-family-string,'Cisco CSR

1000V'))

● Logical A&(B|(C&D)) :

contains(interface:interfaces/interface/if-name,'GigabitEthernet1') and

(contains(os-version,'15.6(1)S') or (contains(vendor-string,'Cisco Systems') and

contains(device-family-string,'Cisco CSR 1000V')))

● Logical not(A&B) :

not(contains(basicDeviceConfigs:local-credentials/local-credential/name , 'admin') and

contains(basicDeviceConfigs:local-credentials/local-credential/name , 'Cisco'))

How to derive the X-path expressions

There can be two ways by which you can derive the X-path expressions

● Navigate to the Device profile page to get the X-path Expression Details for the yang

parsed entities

Resource Manager → Devices → Select a Device → Configuration → Config Data →
Entities → Select Entity

For Example: If we want to write xpath expression for VRF name to match as “anuta”,

then below is how condition needs to be written

l3features:vrfs/vrf/name = ‘anuta’

l3features:vrfs/vrf : This is x-path derived based on model under device

name : Attribute of vrf name.

● Navigate to Schema Browser to see all yang models under path

/controller:devices/device
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Policy creation with XML Template Payload

● Within Condition Match Criteria select “Matches_the_template_payload”

/”Doesn’t_matches_the_template_payload” option for Inventory Operator field

● The Fix Mutation Payload is a Jinja2 template configuration in Netconf xml RPC format

written using the unmatched content from the test results tab.

Navigate to Resource Manager > Config Compliance > Policy > + (Add Policies)

Few examples

Scenario 12 : IP Domain name check

Template Payload:

<native xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">

<ip>

<domain>

<name>net.disney.com</name>

</domain>

</ip>

</native>

Fix Mutation Payload :

<config>

<devices xmlns="http://anutanetworks.com/controller">

{% for content in unmatched -%}

{% for device in content["controller:devices"]["device"] -%}

<device>

<id>{{ device["id"] }}</id>

<native  xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">

<ip>

<domain nc:operation='create'>

<name>{{ device['Cisco-IOS-XE-native:native']['ip']['domain']['name']

}}</name>

</domain>

</ip>

</native>

</device>

{%- endfor %}
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{%- endfor %}

</devices>

</config>

Defining Template Payload

Here the matched and unmatched data will be stored in the backend data structure which is

shown in the Test Results tab. The matched data will be stored in the condition-search-output.

The unmatched data will be stored in unmatched-content.
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The Fix Mutation Payload is a Jinja2 template configuration in Netconf xml RPC format written

using the unmatched content from the test results tab.

Defining Fix Payload

Fix Configuration Display in Remediation
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Scenario 13 : IP Name Server check

Template Payload:

<native xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">

<ip>

<name-server>

<no-vrf>192.168.20.1</no-vrf>

<no-vrf>192.168.20.2</no-vrf>

</name-server>

</ip>

</native>

Fix Mutation Payload :

<config>

<devices xmlns="http://anutanetworks.com/controller">

{% for content in unmatched -%}

{% for device in content["controller:devices"]["device"] -%}

<device>

<id>{{ device["id"] }}</id>

<native  xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">

<ip>

<name-server nc:operation='create'>

{% for name_server in

device['Cisco-IOS-XE-native:native']['ip']['name-server']['no-vrf'] -%}
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<no-vrf>{{ name_server }}</no-vrf>

{%- endfor %}

</name-server>

</ip>

</native>

</device>

{%- endfor %}

{%- endfor %}

</devices>

</config>
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Defining Fix Payload

Fix Configuration Display in Remediation

Scenario 14 : Interface check

Template Payload:

<native xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">

<interface>

<Loopback>

<ip>
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<address>

<primary>

<address>10.100.99.98</address>

<mask>255.255.255.255</mask>

</primary>

</address>

</ip>

<ipv6>

<address>

<prefix-list>

<prefix>2605:30C0::3B/128</prefix>

</prefix-list>

</address>

</ipv6>

<name>0</name>

</Loopback>

</interface>

</native>

Fix Mutation Payload :

<config>

<devices xmlns="http://anutanetworks.com/controller">

{% for content in unmatched -%}

{% for device in content["controller:devices"]["device"] -%}

<device>

<id>{{ device["id"] }}</id>

<native  xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">

<interface>

{% for loopback in

device['Cisco-IOS-XE-native:native']['interface']['Loopback'] -%}

<Loopback nc:operation="create">

{% if loopback['ip'] -%}

<ip>

<address>

<primary>

<address>{{ loopback['ip']['address']['primary']['address']

}}</address>

<mask>{{ loopback['ip']['address']['primary']['mask'] }}</mask>

</primary>

</address>

</ip>
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{%- endif %}

{% if loopback['ipv6'] -%}

<ipv6>

<address>

<prefix-list>

{% for prefix in loopback['ipv6']['address']['prefix-list'] -%}

<prefix>{{ prefix['prefix'] }}</prefix>

{%- endfor %}

</prefix-list>

</address>

</ipv6>

{%- endif %}

<name>{{ loopback['name'] }}</name>

</Loopback>

{%- endfor %}

</interface>

</native>

</device>

{%- endfor %}

{%- endfor %}

</devices>

</config>

Defining Template Payload
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Defining Template Payload

Scenario 15 : VRF check

Template Payload:

<native xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">

<vrf>

<definition>

<address-family>

<ipv4>

<mdt>

<default>

<address>239.232.0.1</address>

</default>

<data>

<multicast>

<address>239.232.1.0</address>

<wildcard>0.0.0.255</wildcard>

</multicast>

</data>

</mdt>

<route-target>

<export>

<asn-ip>2:2001</asn-ip>

</export>

<import>

<asn-ip>2:2001</asn-ip>
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</import>

</route-target>

</ipv4>

</address-family>

<name>LON2001</name>

<rd>2:2001</rd>

</definition>

</vrf>

</native>

Fix Mutation Payload :

<config>

<devices xmlns="http://anutanetworks.com/controller">

{% for content in unmatched -%}

{% for device in content["controller:devices"]["device"] -%}

<device>

<id>{{ device["id"] }}</id>

<native  xmlns="http://Cisco.com/ns/yang/Cisco-IOS-XE-native">

<vrf>

{% for vrf_def in device['Cisco-IOS-XE-native:native']['vrf']['definition']

-%}

{% if vrf_def['name'] == 'LON2001' -%}

<definition nc:operation="create">

{% if vrf_def['rd'] -%}

<rd>{{ rd_2001 }}</rd>

{%- endif %}

<name>{{ vrf_def['name'] }}</name>

{% if vrf_def['address-family'] -%}

<address-family>

<ipv4>

{% if vrf_def['address-family']['ipv4']['route-target'] -%}

<route-target>

{% for export in

vrf_def['address-family']['ipv4']['route-target']['export'] -%}

<export>

<asn-ip>{{ export['asn-ip'] }}</asn-ip>

</export>

{%- endfor %}

{% for import in

vrf_def['address-family']['ipv4']['route-target']['import'] -%}

<import>
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<asn-ip>{{ import['asn-ip'] }}</asn-ip>

</import>

{%- endfor %}

</route-target>

{%- endif %}

{% if vrf_def['address-family']['ipv4']['import'] -%}

<import>

<map>{{

vrf_def['address-family']['ipv4']['import']['map'] }}</map>

</import>

{%- endif %}

{% if vrf_def['address-family']['ipv4']['mdt'] -%}

<mdt>

{% if

vrf_def['address-family']['ipv4']['mdt']['default'] -%}

<default>

<address>{{

vrf_def['address-family']['ipv4']['mdt']['default']['address'] }}</address>

</default>

{%- endif %}

{% if vrf_def['address-family']['ipv4']['mdt']['data']

-%}

<data>

{% for multicast in

vrf_def['address-family']['ipv4']['mdt']['data']['multicast'] -%}

<multicast>

<address>{{ multicast['address']

}}</address>

<wildcard>{{ multicast['wildcard']

}}</wildcard>

</multicast>

{%- endfor %}

</data>

{%- endif %}

</mdt>

{%- endif %}

</ipv4>

</address-family>

{%- endif %}

</definition>
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{%- endif %}

{%- endfor %}

</vrf>

</native>

</device>

{%- endfor %}

{%- endfor %}

</devices>

</config>

Defining Template Payload
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Defining Fix Payload

How to derive the XML Template payload

● Navigate to the Device profile page and export the XML template details for the yang

parsed entities

Resource Manager → Devices → Select a Device → Configuration →Config Data →
Entities → Select Abstract entity → Use the Download button to export/copy the XML

payload

Example: Let's derive domain-name XML Template payload

Navigate to Devices → select a device→ configuration -> Config Data → Entities →
DNS-server → Export XML payload using download button.
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Profiles

A profile allows one or more Policies to be grouped and executed on one or more devices either
on-demand or as per Schedule. Profile execution results in a per-device compliance report
included in the execution.

Steps:

a.  Navigate to Resource Manager > Config Compliance -> Profiles

● Select “+” to Create a Profile
● ATOM opens up a new wizard and displays 2 sections.

○ Policies - Select one/more policies
○ Devices & Schedule - Select one/more devices or Device groups

b. Create a profile by providing a name, description, and select policy which was created
previously

IP_Domain_Name.
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c. Navigate to the next tab, Select devices, and schedule. We can select either device(s) from the
Devices or Device Groups tab

d. After device(s) are selected, choose if the compliance checks need to be run against an
archived config or the current running configuration of the device. By default Latest From Config
Archive is selected.

Schedule: The profile job can be scheduled in Hours or Minutes. Alternatively, a job can be
started right away by enabling Start now option.

Configuration:
- Current Config: This will pull the current device configuration and evaluate it against the

polices.
- Latest From Config Archive: This will use the latest configuration that is stored in the

ATOM. Optionally you can add a check to skip the compliance check when the
configuration is older than n hrs
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Or the profile job can triggered at a later point of time using run job icon on the profiles view
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Report

Navigate to Resource Manager > Config Compliance -> reports

Compliance report is generated upon completion of Profile run. For each device, the report lists
the compliant and non-compliant policies, rules, and conditions .

After the profile job is run, audit details can be viewed in Report View

Since the IP_Domain_Name policy has a condition named Verify_IP_Domain_name, where it
didn’t meet the required criteria. The condition is marked as Non_compliant.

Severity: Severity is the condition where the condition Match Action or Non-Match Action is of
type Raise_violation or Raise_violation_and_continue.

Upon checking the row you can see the expected and the fix commands for that condition along
with action-severity, action-type, and other metadata related to device & condition.
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The reports section also facilitates users to filter the results of what user is interested in.  The
dropdown will display all the possible values for the filters. Users can try out any combination
and see the results. By clicking on the apply button.

In order to revert the filter that is applied, you can click on the clear button.

Tired of filtering the results every time for more frequent data. We got you covered ATOM
provides an option to save the filter that you applied again with a single click.

● Select filters that you are interested in and click on the save button
● This will show a new pop-up box prompting for the filter name and the dashboard where

the user wants to pin it.
● Click on the save and apply button will save this filter and the resulting data will be

populated.
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We can pin it to the dashboard, upon saving the  filter using the drop down. we are able to see
the filter under the dashboard.

From where I can access these saved filters?

● They are easily accessible. All the filters that are saved are listed under the dropdown on
the top.

● Click on the interested filter and you see the data getting filtered.
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ATOM also provides an option to view the statistics based on Pivot by Device, Device Type,
Policy, Location, and Device Group.

Users can opt for any view that they are interested in.

Pivot by device

Severity: The aggregated severity of that particular device.
Compliant Policies: The number of policies that are compliant against the device.
Non-Compliant Policies: The number of policies that are non-compliant against the device.
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Compliant Conditions: The number of Conditions that are complaint against the device
Non-Compliant Conditions: The number of Condition that is non-compliant against the device
Device ID: Displays all Device Ids for which compliance has run. This is the context column for
pivot by the device.
Execution status: Based on execution on the device it is updated as Successful, errors, stale
config, empty config, config pull failed, offline device.
Hostname: Hostname of a device is displayed here.
Device compliance status: Based on compliance run, for a device, it is updated as Compliant,
non-compliant, or Not applicable.
Device Type: The device type of a device is displayed (like Cisco CSR 1000v , Cisco 891).
Vendor: vendors of device are displayed here (like Cisco, juniper)

On clicking on the Device ID,  Device ID filter gets applied and the user will be navigated to CRV.

Pivot By Policy

Severity: The aggregated severity of that particular policy.
Compliant Devices: The number of devices that are compliant with the policy.
Non-Compliant Devices: The number of devices that are non-compliant with the policy.
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Non-Compliant Conditions: The number of conditions that are non-compliant against the
policy.
Policy Name: Displays all policies for which compliance is run. This is the context column for pivot
by the policy.
Compliance status: Based on policy, it is updated as compliant or non-compliant.

On clicking on the policy,  the policy filter gets applied and the user will be navigated to CRV.

Pivot By Device Type:

Severity: The aggregated severity of that particular device type.
Device type: Displays all device types available in compliance. This is the context column for pivot by

device type.

Vendor: Displays the vendors available in compliance .

Compliant Device: The number of devices that are compliant against the device type

Non-compliant device: The number of devices that are non-compliant against the device type.

Compliant policies: The number of policies that are compliant against the device type

Non-Compliant policies: The number of policies that are non-compliant against the device type

Compliant Condition: The number of conditions that are compliant against the device type.

Non-compliant Condition: The number of conditions that are non-compliant against the device

type.
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Click on device type> Cisco CSR 1000v here

On clicking on the Device Type,  the Device Type filter gets applied and the user will be navigated to

CRV.
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Pivot By Location:

Severity: The aggregated severity of that particular locations
Location Name: Displays all available locations over which compliance is run. This is the context
column for pivot by location.

Compliant Devices: The number of devices that are compliant against  locations
Non-Compliant Devices: The number of devices that are non-compliant against locations
Compliant Policies: The number of policies that are compliant against locations
Non-compliant Policies: The number of policies that are non-compliant against locations
Compliant Condition: The number of conditions that are compliant against locations
Non-Compliant Condition: The number of conditions that are non- compliant against locations
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Click on any of location name

on clicking on the location name,  the location filter gets applied and the user will be navigated to

CRV.

Adding the same device in multiple resource pools and each RP associated with a different location,

all locations will be listed in pivot views.

Adding the same device in two resource pools and associating one RP with location and another RP

with no location, only the location associated with RP will be listed.

143



ATOM User Guide

Pivot By Device Group:

Severity: The aggregated severity of that particular Device group
Device Group: Displays all available device groups over which compliance is run. This is the
context column for pivot by device group.
Devices in the group: This gives the number of devices in a group

Compliant Devices: The number of devices that are compliant against device groups
Non-Compliant Devices: The number of devices that are non-compliant against device groups
Compliant Policies: The number of policies that are compliant against device groups
Non-compliant Policies: The number of policies that are non-compliant against device groups
Compliant Condition: The number of conditions that are compliant against device groups
Non-Compliant Condition: The number of conditions that are non- compliant against device
groups.

Click on any of the device groups

On clicking on the device group,  the device group filter gets applied and the user will be navigated

to CRV.
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pivot view :

● Single pivot view can be selected. (no multi-pivot view selection)

● Upon selecting a pivot view, further filters like device id, device type, vendor, compliance

status, condition status, location, resource pool, device groups, severity ,execution status,

policy, rule name, condition and name can be applied.

● Just with the pivot views, a filter can’t be saved, Based on further filters applied, a filter can

be saved. The saved filter can be deleted.

● Bulk delete is not supported in pivot views

● Remediation is not supported

● Sorting is not supported on any column in pivot view.

● Searching is not supported in pivot view.

● The counts on top are related to the non- pivot views and labels are from condition status

● Export: based on pivot views, the records can be exported.

CRV(conditional report view) :
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● The available columns are: Hostname, Severity, Execution, Device Type, Device

compliance status, condition status, Device id, Vendor, Policy name, Rulename,

Condition name, Configuration retrieved at, Expected pattern, Enforcement time.

● The data can be filtered by applying filters on a device id, device type, vendor, compliance

status,condition-status, location, resourcepool, device groups,severity, execution status,

policy, rule name and condition name.

● Time-based filtering : For timing-based, user can use value and units(Days, weeks, months,

hours, minutes) fields.

Date-wise filter: User can choose the date from the calendar symbol and click on ‘apply’ in

the calendar.

● Count band -  Represents counts for skipped, compliant, and non-compliant conditions

● Skipped conditions - Platform mismatch and Execution Status (Stale Config,

Empty Config, Erros, Config Pull Failed, Offline Device) fall into this category.

● Complaint conditions - Based on conditions meeting the criteria

● Non- compliant conditions -Based on conditions meeting the criteria and

violations chosen

● Multi-selection on filters is supported - More than one entry for a given filter can be

selected.

● Sorting is enabled on all columns.

● Searching is enabled for all columns.

● The record details are listed when the checkbox for a given entry is selected. Device ID,

Device hostname, Device type, Vendor, Device compliance status, Execution status, Config

time, Policy name, Rule name, Condition ID, Condition status, Expected pattern, Action

Details, Remediation commands( if it’s non-compliant) are shown as part of details.

Remediation

Navigate to Resource Manager > Config Compliance -> Remediation

Fix CLI Action will generate the remediation CLI to be applied for each non-compliant device.
Users can schedule remediation on one or more devices or execute it right away. For each
device selected, ATOM will push remediation CLI to the device.
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a. Select a Report and click on the highlighted arrow for navigating to the Remediation
screen.
Only if it is non- compliant, the user will be taken to the remediation screen.

b. Fix Violations by providing a Job name and verifying rule-input values and fix CLI commands
under Fix Configurations. Click on the tick button to complete the fix-job.
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c. Fix Job can be scheduled using the Schedule option or can be initiated immediately by

enabling Start now. And click on the Tick button to initiate a fix-job.

1. Fix job can be initiated from the Remediation tab as well at a later point of time.

d. After remediation, trigger profile job and validate the report to see if the device came back as

a complaint.

e. Below we can see the device is now back to complaint after fixing violations.
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Remediation is not supported when the user is in pivot view.

Bulk delete:

Navigate to Resource Manager > Config Compliance -> reports(CRV)

In order to delete the records at shot bulk delete is used.

Based on filters applied, records can be deleted

● If the filter is on Device(device id/ device group/ device Type)  And invoke  Bulk delete, all

the records related to devices are deleted.

● If the filter is on  Policy and Bulk delete is invoked,all the records Related to policies across

all devices are deleted.(columns like Policy, rule, condition, expected pattern, enforcement

time- empty)

● If the filter is on device + policy and bulk delete is invoked, all the records related to

policies across all devices are deleted but  the Device is not deleted.(columns like Policy,

rule, condition, expected pattern, enforcement time- empty)

● If the filter is policy+rule+condition, where  there are many rules or many conditions,

records are deleted at the policy level only.(records having the selected policies are deleted

irrespective of rule or condition)
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Purge compliance history:

In order to delete history details, we can use purge compliance history under
Monitoring--> jobs→ Maintenance→ purge compliance history..

Say, the threshold is 60 and it is set for days. When this job is run, it deletes all the record
history details that are older than 60 days.

It can be set in hours too.
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Export:
Navigate to Resource Manager > Config Compliance -> reports(CRV/Pivot)

Using export will get a report for all the records in one shot

Upon applying filters and the user does export, then the user can get only those records.
Without applying filters, if the user does export,  all records are exported.

Provide a name to export file to be saved

Export file will be saved in the archive tab.
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Archive

Navigate to Resource Manager > Config Compliance -> Archive

From here we can download the report and delete as well. File download format is CSV.

The headers of the downloaded CSV report are according to the filter applied.
If pivot views are applied, the headers are according to it.

Golden Configuration:

Navigate to->Resource manager->Config compliance->Golden configuration

This is the tree view for policies which has rules, platforms & conditions details.
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Click + and create policies
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Try to create rules,platforms

Try to create conditions
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You can edit policy and underlying conditions etc
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Launch test config can be done as well
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Now create profiles. Select the policies and do a drag-drop. Also, select devices/device groups from the

drop-down. Select configuration and use the start now option.

You can edit the profiles as well
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Here run the profiles.

Below is delete profile option
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Under configuration it will show condition details
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Vulnerability

Anuta ATOM has its Vulnerability feature.

It collects the readily known vulnerabilities from the network device vendors such as Cisco and
presents the top 10 vulnerabilities along with device inventory as well as lists of vulnerabilities.

To check the vulnerability of any Cisco network element which is onboarded on ANUTA ATOM
click on Resource management> Devices > Summary > there is a widget that can be included in
the dashboard which lists out the top 5 vulnerabilities of Cisco's product that can be checked
against device inventory.

Also by navigating to Devices> Compliance> Vulnerabilities the page lists out the most recent
vulnerabilities. Once you click on any of the vulnerability advisory IDs it redirects to Cisco's
vulnerability page. Where CVSS (common vulnerability scoring system), CVE (common
vulnerability exposure), and CWE (common weakness enumeration) information of any Cisco
device is mentioned.
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.

This feature of ANUTA ATOM helps the network and security ops to cut the time and efforts
spent on network security assessment and VAPT but readily available information will be helpful
to implement the recommended workarounds. The network monitoring and surveillance can be
customized by taking those vulnerabilities into account.
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Dashboard
There are 5 Dashboards that gives quick information about compliance status

● Config compliance -devices: Representing the number of devices participated

in compliance v/s all the available devices in ATOM.

● Config compliance- execution status: A pie chart representing the percentage

of execution status in terms of successful, config_empty, config_stale, errors,

config_pull_failed, offline_device.
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● Config compliance- compliance status: A pie chart representing the

percentage of compliance in terms of Complaint, Non- compliant,

Not_applicable.

● Compliance status by group: A bar graph representing compliance status

such as complaint, non-compliant, not_applicable for each and every device

group on which compliance profile jobs are run.

● Execution status by device group: A bar graph representing execution status

such as config pull failed, not applicable, config_stale, errors, offline device,

successful, config_empty  for each and every device group on which

compliance profile jobs are run.

Upon clicking on any of the dashboards, the user is navigated to CRV.
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Upon clicking on any of the dashboards, the user is navigated to CRV.
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FAQ’s

● We have a multi-vendor network, can ATOM help ensure compliance in my

environment?

ATOM supports compliance management for Cisco, Juniper and Fortigate at this point in

time.

● We want to standardize the network configs even before introducing automation, can

ATOM help?

The standard configurations can be defined explicitly in ATOM's compliance framework.

ATOM will perform compliance checks against the network and perform remediation in

case of non-compliance to standardize the network configurations.

● We already have a platform that checks for compliance, but the remediation is manual,

can ATOM help ?

Yes, ATOM is capable of performing remediation on non-compliant devices. The Fix-CLI

or derived CLIs can be scheduled or executed immediately to fix all non-compliance

issues in the network.

● Can we schedule compliance checks periodically using ATOM ?

Yes, the profiling section in ATOM's compliance framework supports scheduling of

compliance checks against a device or a group of devices

● Can ATOM's compliance help in achieving regulatory compliance ?

Yes, based on the policies that regulatory authorities specify, ATOM's compliance

management framework can be configured to meet these requirements.

● We have multiple checks that need to be run on the network, can ATOM help handle this

scenario ?

ATOM’s profiling section supports the grouping of multiple policies
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Appendix

● Writing Jinja template configurations based on Test Result output

Below is sample output from the test result obtained in Launching Test Config. This helps writing

jinja2 templates as required in use case requirements.

{

"compliance-policies": {

"highest-severity": "",

"rule-violation-count": 0,

"compliance-status": "compliant",

"compliant-rules-output": {

"violated-conditions": "",

"device-compliance-condition-output": {

"block-start-unmatched-content": "<![CDATA[]]>",

"block-start-condition-search-output": "<![CDATA[{

"block_start_matched_contents" : []

}]]>",

"condition-search-output": "<![CDATA[{

"matched_contents" : [ {

"groups" : [ {

"index" : 1,

"grep_content" : "1.1.1.1",

"grep_group" : 1

} ]

}, {

"groups" : [ {

"index" : 1,

"grep_content" : "2.2.2.2",

"grep_group" : 1

} ]

} ]

}]]>",

"total-block-count": 2,

"aggregated-condition-ouput": "<![CDATA[{

"condition_contents" : [ {
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"condition_id" : null,

"block_start_matched_content" : null,

"block_start_unmatched_content" : null,

"unmatched_content" : null,

"matched_content" : null

} ]

}]]>",

"template-substituted-content": "<![CDATA[ntp server (?!10.0.0.1)(\d+.\d+.\d+.\d+)]]>",

"block-unmatch-count": 0,

"cli-match-output": "<![CDATA[ntp server 1.1.1.1

ntp server 2.2.2.2

]]>",

"condition-status": true,

"unmatched-content": "<![CDATA[]]>",

"id": "Remove_NTP_Extra_Config",

"block-match-count": 2,

"cli-unmatch-output": "<![CDATA[]]>"

},

"name": "test-condition",

"failed-conditions": ""

}

}

}

Keys Condition value Jinja2 template

matched_contents -

when matched with

regex in the condition

value with the test

configuration.

ntp server
(?!10.0.0.1)(\d+.\d+.\d+.\d+)

{% for content in
matched_contents -%}
{% for group in content["groups"]
-%}
no ntp server {{
group["grep_content"] }}
{%- endfor %}
{% endfor %}

unmatched_contents -
when matches with the
regex and does not
match with the block
config in the condition
value with the test
configuration.

line vty (.*)
session-timeout {{
session_timeout }}
exec-timeout {{ exec_timeout
}} 0

{% for content in
unmatched_contents %}
{% for group in content["groups"]
%}
line vty {{ group["grep_content"] }}
session-timeout {{
session_timeout }}
exec-timeout {{ exec_timeout }} 0
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exit
{% endfor %}
{% endfor %}

condition_contents -
condition1 captured
data will be accessible
to condition2 using
condition_contents.

condition1:
interface Loopback0
ip address
(\d+.\d+.\d+.\d+)
(\d+.\d+.\d+.\d+)

condition2:
router ospf (.*)
router-id {{
condition_contents[0]["ma
tched_content"]["matched
_contents"][0]["groups"][0
]["grep_content"] }}

{% for content in
unmatched_contents %}
{% for group in content["groups"]
%}
router ospf {{
group["grep_content"] }}
router-id {{
condition_contents[0]["matched_c
ontent"]["matched_contents"][0]["
groups"][0]["grep_content"] }}
exit
{% endfor %}
{% endfor %}
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Collections in ATOM
ATOM collects network operational & performance data from multiple data sources such as

SNMP, Streaming Telemetry, SNMP Traps and Syslog.

Appropriate data source and data stream can be chosen based on device capabilities, and

throughput and latency requirements. Model-Driven Telemetry uses a push model and provides

near real-time access to operational & performance statistics.

The collected Operational and Performance data can be visualized using Grafana (available as

part of the ATOM package) or in ATOM UI (by using various built-in reports available in Report

section or under the device view). Users can build additional dashboards customized to their

interests. (See ATOM Platform Guide to know more on how to create custom dashboards).

Jobs
A Job is a configurable task on a device that can be managed by ATOM. A job thus created can

be a piece of work that can be created, executed and tracked in ATOM. Depending on the need,

the administrator can schedule and manually run various Jobs to collect data about the device

state.

Jobs are classified into the following types:

● Collection Job

● Configuration Job

● Diagnostics Job

● Discovery Job

● Inventory Job

● Maintenance  Job

● Batch-reports Job

● SNMP-collections Job

● Syslog-collection Job

● Telemetry-Collections Job

● Telemetry-measurement Job

● Report Collection
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Collection Job

ATOM collects or retrieves the status of the device (OFFLINE or ONLINE). By default, this job is

scheduled to run every 6 hours.  Starting with the 6.0 release, you can model the collection job

to collect information about the device using the SNMP OIDs. For more information, refer to

section,  “Modelling of Collection Job” in the “ATOM Platform Guide.”

Configuration Job

Configuration job retrieves the running configurations from the device, or is triggered in the

event of configuration discrepancies (either at the device or the service level)  between the

device and ATOM.

Creating a Configuration Job

1. Navigate to Monitoring > Jobs > Configuration

2. Select the Configuration folder > Add Configuration (+)

3. In the Create configuration screen, enter the values in the following fields:

● Name: Enter the name of the Job

● Description: Enter an appropriate description for the Job

● Configuration Type: Select the type of Configuration Job from the menu:

○ CONFIG_RETRIEVAL - Retrieves the basic device configuration. This option is the

default value.
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○ CLI_DEVICE_COMPLIANCE - The device compliance job is triggered when there is

a violation of configuration policy on the device or a set of devices. For

information about the Device Compliance Policies, refer to "Creating Compliance

Templates"

○ SERVICE_COMPLIANCE - The service compliance job is triggered when there is a

discrepancy in the service configurations available on ATOM and the device.

By default, the ‘ServiceInventory’ Job of type Service Compliance is triggered every 5

minutes.

● Resource Type: Select one of the following resource entities where the job should be

triggered:

○ DEVICE: If the selected resource type is a Device, click Add to enter the IP

address of the device for ATOM to communicate with it.

○ DEVICE GROUP: If the selected resource type is Device Group, click Add to enter

the device group for which the configuration jobs should be triggered.

○ RESOURCE POOL: Click Add to select from the available resource pools where

the job should be run.

● Config Pull type: If the selected configuration type is Config Retrieval, you can opt for

one of the following methods to be used while retrieving the configurations from the

device:

○ TFTP_EXPORT - Select this option when ATOM should retrieve configs from the

TFTP server

○ SHOW_COMMAND - Select this option if ATOM should retrieve configs from the

running configuration of the device. This will be useful when in some customer

environments where the TFTP port is disabled.

● Parse Config: Select this option if the parsing of the configurations should be enabled on

the device/devices after the successful run of the config retrieval job.

Note: Use this option if you want to override the value set in the global parameters

of ATOM. By default, at the global level config parsing is enabled for all devices

However, using this option you can disable config parsing at the device level.

● Schedule: Select the checkbox and schedule the job to be run at intervals

● Interval: Enter the time period for which the job should be scheduled

● Interval Type: Select the units of time when the job should be scheduled (HOUR or

MINUTE)

Click the Task viewer to check for the status of the executed job.
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Option 1: A successful run of the Config Retrieval job, where  ‘TFTP Export’ is enabled,

fetches the following details from the device:

Case 2: A successful run of the Config Retrieval Job, with ‘show run config’,  is shown as below:

Diagnostics Job

Diagnostics job collects various CPU, memory utilization and interface performance data that is

used to provision the service. By creating a Diagnostics Job, you can run the basic Telnet or

SNMP connections to the device and also perform module-level diagnostics.

Creating a Diagnostics Job
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1. Navigate to Monitoring > Jobs > Diagnostic

2. Select Diagnostic and click Actions > Add Job(+)

3. In the Add Diagnostic screen, enter values in the following fields:

● Name: Enter a name not exceeding 64 characters

● Description: Type an appropriate description for the job.

● Resource Type: Select one of the entities where the job should be run

○ Device: Enter the IP address of the device

○ Device Group: Select a device group from the drop-down list.

○ Resource Pool: Select the resource pool from the available resource pools

in ATOM.

● Schedule: Select this option to run the job in specific intervals of time

○ Interval: Enter a number representing a span of time.

○ Interval Type: Select the units of time (minute or hour)

Click the Task Viewer pane and search for the Diagnostics job. A successful run of the

Diagnostic Job displays the following information in the task details:
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Discovery Job

Discovery job is used in the discovery of devices falling within a range of IP addresses.

The first step in provisioning a network is discovering the devices in the network. ATOM

discovers the devices in the pod using either CDP or LLDP. Based on this discovery, ATOM

automatically draws a network topology diagram.

If only SNMP is enabled, the topology diagram cannot be drawn as SNMP does just the sweep,

which is not a methodical way of discovering device hierarchy. Therefore, it should be ensured

that either CDP or LLDP is enabled on all the devices managed by ATOM.

A SEED device is the starting point from which ATOM discovers the network and its peers or

neighbor devices. SEED discovery type should be selected when devices in a smaller range are

required in the topology. This method of discovery is quicker, but a fewer number of devices are

discovered.

If the selected discovery type is SWEEP, the devices within a range of IP addresses are

discovered.

Creating a Discovery Job
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1. Navigate to Monitoring > Jobs > Discovery > Add Discovery

2. In the Create Discovery screen, enter values for the mandatory fields:

● Name: Enter an alphanumeric string to identify the created discovery job

● Description: Enter some text that describes the Job

● Discovery Type: Select one of the discovery types that will be used for

discovering devices:

○ SEED - By default, the discovery type is SEED.

○ SWEEP -  Change the value to SWEEP, if you want more devices to be

discovered.

● Seed Type: Select the type of the seed protocol, either CDP or LLDP. In case the

Discovery type is selected as SWEEP, enter the SWEEP IP range in the field.

NOTE: This IP range should be the same or a subset of the range of IP

addresses defined in the Credential Map. IP addresses can be expressed in

CIDR notation as well.

● Hop Count: Enter the number of hops (devices)that ATOM should discover from

the seed device while using CDP.

● Seed IP Address: Enter the IP Address of the seed device from which the

discovery of the neighboring devices should be initiated.

● Auto manage: Select this option to add the discovered devices to ATOM

automatically.
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If this option is selected, a Managed Task is generated after the successful run of

the discovery job.

● Schedule: Select this option if this job should be scheduled at prescribed time

intervals.

○ Interval: Enter the period of time within which the job should be

scheduled

○ Interval Type: Enter the units of time (HOUR or MINUTE)

A successful run of the Discovery Job with the SWEEP protocol is shown below:

Details of the Executed Job along with the devices that are discovered by ATOM in this job are

displayed as follows:
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Managed Task

This task will be triggered in ATOM after the successful run of the discovery job. All the

discovered devices added to the device table maintained in the ATOM inventory and are marked

as “Managed” devices.
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Inventory Job

Inventory job is used for detecting and adding device Interfaces, interface capabilities, and

interface addresses.

Extended Inventory: Retrieves the lost network connections, establishes the new network

connections between the devices, and retrieves the configurations from the device, By default,

this job is scheduled to run every 12 hours and can be updated.

Maintenance Job

You can configure the maintenance jobs to remove unwanted records of the tasks or the alarms

in ATOM. The maintenance jobs can be scheduled on a one-time basis or run periodically.

Purge Older Alarm Records (You can remove unwanted, older records of the Alarms generated

in ATOM.)

Creating a Purge Older Alarm Records Job

1. Navigate to Resource Manager > Jobs

2. In the left pane, navigate to the MAINTENANCE folder

3. Click the MAINTENANCE folder > Actions > Add Job

4. In the Create MAINTENANCE screen, enter the values for each field described below:

● Maintenance Job Name:  Enter a name for the maintenance job to be created.

● Description: Enter a suitable description for the job

● Maintenance Type: Select the type as " PURGE_OLDER_ALARM_RECORDS" to

create a job to clean all the old Alarms from ATOM

● Threshold (in days): Enter a number of days, of which the records for which

history should be maintained. All the records before the prescribed days will be

deleted.
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● Schedule: In order to schedule the job to run periodically at specified intervals of

time, select the Schedule option.

● Interval: Enter the number for the interval

● Interval Type: Select either Hour or Minute as units of time.

Example:

If we enable Scheduling with Interval equal to 24, Interval Type equal to HOUR and

Threshold equal to 30 respectively,

, a maintenance job is executed every 24 hours that will remove all the Alarm records

older than 30 days.  That is, all the records of the previous month before the 30th day

will be deleted.

Purge Older Task Details Records

You can schedule a maintenance job that can be run to remove all the details of the tasks run

before a specified period in time.

Creating a Purge Older Task Details Records

1. Navigate to Monitoring> Jobs

2. In the left pane, navigate to the maintenance folder

3. Click the maintenance folder > Actions > Add Job

4. In the Create maintenance screen, enter the values for each field described below:

● Maintenance Job Name:  Enter a name for the maintenance job to be created.

● Description: Enter a suitable description for the job

● Maintenance Type: Select the type as " PURGE_OLDER_TASK_RECORDS" to

create a job to clean all the details of the tasks

● Threshold (in days): Enter a number of days, of which the records for which

history should be maintained. All the records before the prescribed days will be

deleted.

● Schedule: In order to schedule the job to run periodically at specified intervals of

time, select the Schedule option.

● Interval: Enter the number for the interval

● Interval Type: Select either Hour or Minute as units of time.

Example

If  30, 24, and HOUR are entered as values in the fields - Threshold, Interval, and Interval

Type respectively, a maintenance job is executed every 24 hours that will remove all the

details of the tasks older than 30 days.  That is, all those task details of the previous

month before the 30th day will be deleted.
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Report Collection Job
This Job is to fetch the inventory data like Interfaces,Chassis-Info,Software and License

information which are present on device.

There are some prerequisites for report collection job to work with

1. You need the Inventory_Reports package in order to view all reports all available for

retrieving the data from the device.

2. In order to run the report collection job, the device should add the netconf protocol.
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After creating and running this job, collected data will be shown in the Resource Manager>

Devices tree view under the Inventory tab.
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Device Inventory (SNMP-COLLECTION)
All Device inventory collected through SNMP Collection jobs are shown in the Entities view. The
following provides guidance on

1. To view Device Configuration - Navigate to Resource Manager> Devices > select a device

2. Click on the “Monitoring” Tab

3. Collected data will be shown under MIB-name
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Monitoring
ATOM enables you to create Assurance profiles to facilitate 24x7 uptime of your network.
Closed loop automation (CLA) framework allows you to define policies and remediation actions
in violation of those policies.

ATOM collects operational & performance metrics from multiple data sources such as SNMP,

SNMP traps, Syslog, and Streaming Telemetry and stores them in a time-series database.

Following are the different activities on the metrics:

● Visualize Data Using Charts & Reports

● Alerts against thresholds defined on the Metrics

● Alert Dashboards - Collection of Predefined & User Defined Dashlets

● Alert Routing to Email, Slack, etc.

● Actions on Alerts

● Closed Loop Automation Actions on the Alerts

Please refer to “ATOM User Guide - Performance Management & Alerting” for further details.]]]

ATOM enables you to create Assurance profiles to facilitate 24x7 uptime of your network. The
closed loop automation (CLA) framework allows you to define policies and remediation actions
in violation of those policies.

ATOM collects operational & performance metrics from multiple data sources such as SNMP,
SNMP traps, Syslog, and Streaming Telemetry and stores them in a time-series database.

Following are the different activities on the metrics:

● Visualize Data Using Charts & Reports

● Alerts against thresholds defined on the Metrics

● Alert Dashboards - Collection of Predefined & User Defined Dashlets

● Alert Routing to Email, Slack, etc.

● Actions on Alerts

● Closed Loop Automation Actions on the Alerts

Import SNMP MIBs
ATOM allows users to import any SNMP MIBs. Use the Object identifiers (OIDs) which are part
of the uploaded MIB need to be compiled by activating them.

During activation, it compiles all the dependent MIBs automatically if they are already available
on the system. Otherwise, the user has to upload the dependent MIBs to compile properly.

Navigate to Administration -> Plugins and Extensions -> SNMP -> SNMP MIBs and upload a mib
file
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The below snapshot shows IFMIB along with its dependencies after uploading. All of them are
still inactive. To activate a MIB, select a MIB entry and click on the activate button.

Once the MIB is activated, automatically its dependencies get activated as shown in the
snapshot below.
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After compilation (activation), it will extract all the OIDs from each MIB and can be seen on
Administration -> Plugins and Extensions -> SNMP -> SNMP OID Map.

For each OID, it will extract the following properties:

1. Fetch Type:  Identifies the SNMP fetch type such as GET or WALK
2. Is Accessible : Is it actual OID or the tabular header
3. Key OID’s : Lists out all key OIDs for each OID

By Default, ATOM uses the MIB name as the default in device monitoring trees. To provide an
alias, specify the entity name.

Note:: Navigate->Administration->Plugin & Extension->Packages:: We have other option to
upload the mib packages are IF-MIB, Host -resource-mib,Cisco Process-Mib, bgp4 mib are etc.
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To activate a MIB, select a MIB entry and click on the activate button.

SNMP
SNMP Collections can be created for collecting Inventory information from the devices, checking
the health of the devices, measuring the performance of Network Objects, and discovering the
neighbours of the device.

1. From the left pane, navigate to Monitoring > SNMP

2. Click Add (+)  to create a new SNMP collection profile

3. In the New Inventory Collection screen, enter the following details in the Collection
package tab
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● Name: Enter the appropriate name for the collection.

● Synchronized: It makes the scheduled collection at regular tight intervals when it
is set to true.

eg: if we are polling the device every 1min to collect Interface counters
but the device hasn’t responded to previous requests as it has too many
objects to gather. So, when we set the synchronized flag to true, it waits
until the previous request is completed by the device. Otherwise, it
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makes continuous requests at regular intervals irrespective of the time
spent on the device.

● Save to Policy DB: By default, all the metrics data will be stored in a time series
database. To store anything as inventory with overridden policy, this has to be
enabled. It stores the data on the ATOM policy database and it requires the YANG
mappings to OIDs which can be defined as part of the device package. Refer to
the ATOM SDK to generate the YANG mappings for MIB.

● Collection Packages: Choose one or more Object identifiers that can be spread
across the MIBs. ATOM will automatically let the users know about mandatory
key OIDs for selected Objects. For example, if a user wants to collect
InterfaceInErrors then they must require the interface names to map the values
correctly.

● Schedule frequency: Choose the SNMP polling frequency

NOTE:

1. Don’t select all the OIDs in each MIB with less frequency, choose what
is useful. Otherwise, it leads to HIGH CPU UTILIZATION on devices.

4. In the Resources type tab, choose the devices, device groups, or resource pools to which
the profile has to be applied

5. Click✓ to save the collection profile
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6. Navigate to Monitoring > SNMP to view/modify the collection profile.

For each new collection, ATOM creates the metric schema for each MIB on every Device to
showcase the metrics in the logical hierarchy in device-explorer. Refer to the Metric schema
customization.

Telemetry
ATOM can act as a Telemetry receiver. ATOM Supports Model driven Telemetry, various
Transport options, encoding, and frequency of collection.

● Telemetry configuration in ATOM is optional if Telemetry is enabled manually on the
devices

● ATOM can enable Telemetry subscription on the device. The section below discusses the
steps to be followed.

Configure Telemetry Collection
1. Ensure that the dry run option is unchecked in Administration >  General Settings tab.

2. For configuring the sensors on the device, navigate to Monitoring >  Telemetry.
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3. Click Add (+) to create a new streaming telemetry collection profile

4. In the Create Telemetry Collection > Platform tab, enter the following information

● Name: Enter a name for the collection profile

● Platform: Select the device platform that supports Telemetry

● Transport type: Select the mode of transmission of telemetry data between the
sender (device) and the receiver (ATOM’s Agent), depending on your
requirement

i. gRPC

ii. TCP

● Dial Mode: Select Dial Out if the session establishment between the destination
and the device should be initiated by the device itself.

NOTE: By default, the Dial-In option is enabled.

● Packet Encoding: Select the encoding format for the streamed data between
the sender (device) and the receiver (ATOM’s Agent)

i. Compact GBP

ii. Self-describing GBP

● Owner: Select the owner/tenant who owns the telemetry data

● Shared-With: Add the tenant names to share the data or alternatively leave it
as “all” to make it globally available
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5. In the Create Telemetry Collection > Sensors tab, enter the following information

● Sensors: Select the sensor paths for the device platform selected

NOTE: All the Xpaths of the entities described in the YANG model that the
receiver (ATOM) has subscribed to in the sender (device) are displayed here.

The sensors are the abstract paths defined in YANG mapped to device model
paths published by the vendor. To view all the available device model paths or
sensors published by the vendor and imported into ATOM, navigate to the
Administration  >  Plugins & Extensions  >  Device Support  >  Edit  >
Telemetry seed data
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● Depth of collection: In the selected sensor paths, enter the level in the
container hierarchy at which the data should be streamed from the device.

For example, a depth of collection of 0 returns only the leaf entities in the
specified container, and a depth of 1 returns the data from depth 0, and depth 1
levels the data from the container specified in the sensor path.

Example:

Sensor path: Cisco-IOS-XR-pfi-im-cmd-oper:interfaces/interface-xr/interface

Depth of collection = -1

Result:

Cisco-IOS-XR-pfi-im-cmd-oper:interfaces/interface-xr/interface/arp-information/arp-is-learning
-disabled  (boolean)

Cisco-IOS-XR-pfi-im-cmd-oper:interfaces/interface-xr/interface/arp-information/arp-timeout
(float)

Cisco-IOS-XR-pfi-im-cmd-oper:interfaces/interface-xr/interface/arp-information/arp-type-nam
e (string)

Depth of collection = 0

Result:

Cisco-IOS-XR-pfi-im-cmd-oper:interfaces/interface-xr/interface/bandwidth  (float)

Cisco-IOS-XR-pfi-im-cmd-oper:interfaces/interface-xr/interface/crc-length  (float)

Cisco-IOS-XR-pfi-im-cmd-oper:interfaces/interface-xr/interface/description  (string)
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● Collect only interested data: Check this box to collect the data selectively only
for the required sensors.

● Data filtering: In the global filtering policy, permit or deny the collected data
from the device to the Time-series database.

● Frequency: Enter the rate at which sensor data needs to be collected from the
device to be saved into a Time-series database.

6. In the Create Telemetry Collection > Filtering tab, enter the following information

● Click Add (+) to create Telemetry collection data filtering

● In the Xpath field, choose the sensor path to be filtered from the drop-down list

● In the Subtree field, check or uncheck the value of subtree

● In the Filter type, select Permit or Deny

NOTE: You can exercise the filtering options(either permit or deny) at the
granular level. The filtering option set here overrides the global filtering policy
described in step 5

7. In the Create Telemetry Collection > Devices tab, select the Device (multiple devices
can be selected), where the subscription services are running and the data should be
pushed to the device.

198



ATOM User Guide

8. Click✓ to save the streaming telemetry collection profile.

9. After successful creation of the collection, provision collection and deploy if it is dial-in
mode. If it is dial-out mode then provision the collection only.

10. After the successful deployment of the collection make sure that the status of the
collection will be shown as DEPLOYED in the UI.

11. Navigate to Monitoring > Telemetry to view/modify the collection profile

SNMP Traps
Navigate->Administration->Plugins & Extension->Packages::

Upload the mib dependencies package & load it.

Navigate->Monitoring->SNMP::

Add SNMP collection with if-mib & CSR devices and schedule it every two minutes & ran job it

checks SNMP collection data is shown in the monitoring tab.

SNMP traps generated by the device can be collected and visualized in ATOM

1. Navigate to Monitoring > SNMP trap on the main menu

2. Click Add (+) to create a new SNMP trap collection profile
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3. In the Platform and devices tab, enter the following information

● Name: Enter a name for the SNMP trap profile

● Platform: Select the device platform from the drop-down list

● Devices: Select one or more devices from which SNMP traps need to be collected

Click on create alert immediately & enter link is up and down in mib oids
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4.   In the OIDs tab, enter the following information

● In the list provided, select the OIDs to be enabled for SNMP trap collection to
enter link is up & link is down as above screenshot.

● Owner: Choose the owner/tenant who owns the SNMP trap data

● Shared-With: Add the tenant names to share the data or alternatively leave it as
“all” to make it globally available

5.   Click✓ to save the collection profile
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6.   Navigate to Monitoring > SNMP Trap to view/modify the collection profile

7.    Click the Subscribe button to provision the SNMP traps configured on the devices

8.    The subscription of SNMP trap can be seen as shown below commands
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9. Check the login device to shut down the interface & check the alerts can be generated for
SNMP trap

SNMP Trap Forwarding
SNMP trap collection can be provisioned with a receiver, which will be the external monitoring
system that will receive the trap message whenever the device in the collection generates a
trap.

To facilitate the same,

Navigate to the TRAP Forwarding Settings tab.
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Add the external monitoring system(trap receiver) details after clicking on the + button.

Enter the Name, IP-Address, port number(receiver) of the external nms and click on save
button.

Once the trap receiver is added, create the SNMP Trap collection with Forward Trap enabled.
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● Create an SNMP trap collection and select the checkbox with the label Forward Trap.
● Select the device to monitor.

● Select the respective OIDs, in this case linkUp and linkDown.
● Click✓ to save the collection profile.

This will provision Atom to forward the trap that is generated on the device under collection, to
the external nms or the trap receiver.

Syslogs
Syslogs generated by the device can be collected and visualized in ATOM

1. Navigate to Monitoring> Syslog on the main menu

2. Click Add (+) to create a new Syslog collection profile
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3. In the Platform and devices tab, enter the following information

● Name: Enter a name for the Syslog collection profile

● Platform: From the drop-down list, select the device platform from which Syslog
messages need to be collected

● Devices: select one or more devices from which Syslog need to be collected

4. In the Event specs tab, enter the following information

● In the list provided, select the Event specs to be enabled for Syslog collection

● Owner: Choose the owner/tenant who owns the Syslog data

● Shared-With: Add the tenant names to share the data or alternatively leave it as
“all” to make it globally available
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5. Click✓ to save the collection profile

6. Navigate to Monitoring > Syslog to view/modify the collection profile

7. Click the Subscribe button to provision the Syslog collection on the devices

Navigate->Assurance->Closed loop automation:

Create an alert definition for Syslog is link is up and down & activate it.

8. Check the login device to make the interface is up/down

9. Syslog alerts can be generated after the interface is up/down.
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Charts & Templates
ATOM provides various customisations to visualise the collected metrics efficiently. Users can
customise the mib names, metric names, logical grouping with human-understandable keys,
unified view of metric in single chart, context selection, multiple views through templates, and
also via dashboards.

Key Customization for each metric :

To change the keys in the device monitoring tree. By default, key-OIDs will be shown as parents
in a logical hierarchy. Most of the MIBs have Index numbers as the keys, so we can’t keep track
of them while looking at each metric. It is always required to keep well-known objects to map
the rest of the metrics.

eg: Interface Counters collected through the IFMIB will result below the tree by default. Here, it
will have ifindex as the key by default which sits on top in the hierarchy.

Below is the snapshot without any customisations which has default key-OIDs at a  higher level
in the tree. Here, Ifindex is the default key for IFMIB entries.
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To change the keys to represent this data more human understandable, navigate to the
Administration -> Plugins & Extensions -> SNMP -> SNMP OID Map

Here, choose each metric, and add/modify the metric-tag-OIDs to reflect them in the tree.
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We can add multiple metric tag OIDs, after each entry press ENTER to add another. To choose
which property has to be primary for tree representation among multiple metric-tag-OIDs, we
have to change the field settings. To change this, select the OID entry as shown in snapshots and
select the entities -> fields on the right-hand side.

Here, add the fields by providing the OID name and select the label-field checkbox to true to
make this primary.

If we add multiple fields, only one of the fields will become the primary.

All the remaining fields will be shown on mouse-over the key on the device monitoring tree.
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Metric Visualization on Device Explorer:

Navigate to Resource Manager -> Devices -> select the device -> Monitoring tab on the right
hand side.

Refer Chart Actions section for various interactions.

Chart Creation
Create Simple Custom Chart:
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Simple custom chart to shows multiple metrics in a single chart without further filtering. It will
create a corresponding PromQL and retrieve the data.

eg: create a chart to show interface traffic which includes an interface in & out packet counters,
use preview option to see the data before saving.

Once the chart is created at any node level, it will be applicable to all other siblings
automatically. In the above snapshot, we have created an Interface Traffic chart at Gi1 Interface
and it will be shown under all other interfaces automatically with the right context selected.
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Create an Advanced Custom Chart

Advanced custom charts can have any valid promQL expression with/without variables. To use
any variables, we need to define them beforehand.

Create the Variables for Charts

Variables are useful to move across instances or context easily with the dropdown selection.
Variables can be used across the charts or templates.

To check the predefined variables or to create a new global variable navigate to the
Administration -> UI Customizations -> Chart Variables

Below are system-defined variables.

Provide the below fields to create a variable.

1. Name: Provide the name of the variable
2. Description: Specify the description for variable
3. Default-value: provide the default value for the variable. It is used when the given

expression or query doesn’t result in any value.
4. Variable Type: Variable value can be derived using the following ways:

a. data-type : It can be selected when the variable is known
b. query: it is used to fetch the variable value by executing the query on a metric

instance database.
c. top-n: it is to get the current top n result and use those labels to plot a graph

through selections.
5. Metric: to specify the key/column which is of interest to store in a variable.
6. Filter: It is equivalent to the where condition while fetching the metric value
7. TSDB-query: To execute the top N query on TSDB and use the top n keys in the graph to

render for any metric.
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eg: To get the Top N Interface utilisation, we need to get the interface names that
are utilizing high bandwidth in specified time periods.

Variable creation example:
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Create Chart Templates:

Chart templates are used to combine one or more charts with/without variables and save them
as a view. Templates can be restricted to specific platforms or Groups. Any one of the templates
can be set as default, to render automatically when we move to a particular logical level. The
applies-to function determines where the template has to show in the device monitoring tree.

Templates can be created from the Admin screen or from the device explorer view.

To create a template from device explorer, select one more chart and click on create template
bottom left side. The user has to provide the name for each template and optionally we can
restrict the scope of the template to the platform or device group.

Select any template as the default template which will be shown at each device or group level
without any further selection.
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To create a template from Admin Screen, Navigate to the Administration -> UI Customizations ->
Chart Templates
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Chart Actions:

Each chart can be seen in full screen, downloaded in PNG, JPEG, SVG formats, export Time
series data in CSV or XLS format, min/max/avg can be seen for each time series and also a latest
snapshot of time series data can be in a table below the graph. Currently, time selection is
global which is applicable to all the charts or templates which are selected.

To see available actions for each chart. Click on three vertical lines as shown below.
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min/max/avg:
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Latest data in table format:

Chart pinning to a dashboard
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Note: To have the static values for the variables in monitoring charts, create the Advanced
charts by following the below steps.

1. Create an advanced chart
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2. Provide the variables as follows in the queries.

3. Charts can be viewed with static values as below.
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Alert, Actions & Closed Loop Automation
ATOM enables you to create Assurance profiles to facilitate 24x7 uptime of your network. The
Closed loop automation (CLA) framework allows you to define policies and remediation actions
in violation of those policies.

ATOM collects operational & performance metrics from multiple data sources such as SNMP,
SNMP traps, Syslog, and Streaming Telemetry and stores them in a time-series database.

Following are the different activities on the metrics:

● Visualize Data Using Charts & Reports - To be covered in Monitoring

● Alerts against thresholds defined on the Metrics

● Alert Dashboards - Collection of Predefined & User Defined Dashlets

● Alert Routing to Email, Slack etc.

● Actions on Alerts

● Closed Loop Automation Actions on the Alerts - Alerts can be routed to ATOM CLA
framework where further correlation can be done against the defined behavior and
remediation steps to resolve issues in the network. The actions to be taken for any
breach in threshold values range from sending an email alert, a slack notification, or

raising the alarm in the system. For more advanced use cases, you can define
auto-remediation actions such as executing a workflow to shut down an interface due to
excessive BGP neighbor flaps or seek approvals by sending requests to ITSM tools such
as Service Now. Each action can be triggered automatically or on demand by the user
after analyzing the event. Actions can be attached as generic (all events) or restricted
scope by using alert filters.

Follow the below steps to get the event-driven closed-loop automation work.
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1. Define the Alert Rule - When to trigger an alert

a. Each alert rule consists of a set of conditions, severity and duration to raise or
clear an alert

2. Create the Alert Filter to Alert definition - Who gets affected

a. It defines the scope for actions such as node level, severity based, location or
hybrid, etc. These are reusable entities.

3. Attach the action with a suitable filter and type - What needs to be done after the
event

a. Attach the actions such as email, remediation, RCA/Diagnostics on the set of
alerts

Below are some of the use cases:

1. Generate an alert for the interface packet drop events & diagnose the issue (by
performing a set of operational checks on the device through workflow) and perform
the right action such as upgrading the link or changing the QoS policy, etc.

2. Notify the management team on all critical events which need immediate attention.

3. Send location-specific alerts to corresponding slack channels and email groups.

4. Raise a ServiceNow incident for the hardware issues

5. Alert BGP adjacency state stuck issues and diagnose & perform the available actions
(check & change BGP port issues and AS Numbers, Peer IP, update source etc.) on
demand with manual triggers.

6. Create a dashboard with long-standing issues on specific resource pools which are
triggered from Cisco IOS XR streaming telemetry sources.

Define Alert Rules
1. Navigate to Assurance > Closed Loop Automation to define the alert rules

2. Click Add and provide values for Name, Description, Message, Resource Path

a. Name : Name of the alert definition which will contain the set of rules and
associated actions

b. Description : Provide the description of what the rule is about

c. Message : Define the message template which you would want to see as part of
notification with variables replaced with corresponding values. It is based on
Prometheus Go Templating.
https://prometheus.io/docs/prometheus/latest/configuration/template_exampl
es/

d. Resource Path: Provide the unique XPATH using alert resulted in variables.
Resource Path and Name are the composite key to define the alert ingestion,
maintain the history and resolve events appropriately. To use variables in the
resource path, keep key names inside curly braces.check the following example:
Device={device}/Interface_name={ifDescr}. Here, device and ifDescr are the
variables
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Eg: Notifying each Interface Flap

i. Name : InterfaceDown and Resource Path : /device/interfacename ,

1. all the interface alerts will be treated as similar. If Gi1 Interface
goes down on 10.0.0.1 and Gi2 comes to operationally UP on
10.0.0.2 then it will clear the Gi1 Active alert on other devices.

ii. Name : InterfaceDown and Resource Path : /device={device} then all the
interface alerts will be aggregated by device

1. Every InterfaceDown alert of the same device will become the
history of other alerts and clear the events raised by other
interfaces on that device.

In both (i) & (ii) cases,  manual action can be performed only on the latest
instance of that since they are grouped by upper level or ad hoc entities.

iii. Name : InterfaceDown and Resource Path :
/device={device}/Interface_name={ifDescr} then all the interface alerts
will be aggregated by device & Interface
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1. It makes every event independent and manual actions can be
performed at any time since we have the right set of affected
object information available instead of just the latest event from
that group.

2. Auto clearing of events will happen properly. If Gi1 goes down on
device  10.0.0.1 will raise an alert and it gets cleared only when it
comes operationally on the same Interface on the correct device.

e. Type: By Default, it is of type NETWORK. Please, don’t switch this flag for
device-related alert rules as it defines which database query for metrics and
alerts.

f. Tags: Provide a new tag name or choose the existing ones. it will be useful to
create or apply the filter efficiently in an aggregated way.

3. Configure the condition for each rule with the required thresholds.

a. Metric/Expression: Provide the metric or expression in the condition

i. If the condition has the expression with boundaries then no need to
change the operator and value. It should be == true in that case.
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ii. If the condition has only the metric or expression which doesn’t have any
logical boundaries then the operator and value will be useful. Refer the
below snapshot for more details.

b. Severity: A severity level can be attached to the alerts if the sensors being monitored
breach the threshold values.

c. Duration: Alerts will be fired once they have been returned for this long

4. ‘Live Preview’ shows the generated Prometheus rule with the defined thresholds and its
metadata.

5. Enable Sound Alerts

1. Go to Administration > System > General Settings->Emit Sound
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Once Enabling Emit Sound we can see the below options to enable
Critical,Major,All Transitions,All-Raised Conditions,Acknowledge Alerts

System admin user/User need to enable Enable Alert sound alert to hear the Alert Sounds
based on severity.
Sound Alerts shouldn't play With out Enabling Emit sound option in User level/General Settings
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Define Alert Filter
Alert filters are to define the scope for any action to be performed or group them together based on
certain criteria. We have the following attributes to create the filters : Name, Acknowledge State,
Resolved State, Alert Name, Severity, Device-Groups, Resource Pools, Locations, Tags, and Relative or
Absolute times.

Follow the below steps to create and view filters:

1. Navigate to Assurance -> Alerts

2. Click on the top left corner icon to see the available attributes to define the alert filter

3. Choose the values from the dropdowns and apply the filter to see existing alerts.

4. If step #3 provides the desired filtered result then go ahead and save the filter by providing the
name and optionally save it as a dashlet in the dashboard. Refer to the Dashboards section for
more details.

Navigate to the top left corner and click on the filter icon to see possible filter attributes.
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Choose the filter attributes and click on the Save button to ‘Save Filter’.

Save filter will provide an option to provide a name and to attach to the dashboard.

To clear selected filter attributes, click on the Clear button in left down corner
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Navigate Dashboard> select alert-Dashboard in the right corner and click on it to view the saved filter
dashboard

Attach Remediation Actions
Once you define the baseline behavior by specifying the sensors to be monitored, the next step is to
define the actions to be automated. The actions range from simple notifications to complex remediation
actions. Here, we will bridge the alert to action behavior by using alert filters.

The steps below will help you define the necessary actions for the rules defined

1. Navigate to the Assurance -> Closed Loop Automation

2. Click on the Alert Actions tab

3. Click the Add (+) button to create the action template and provide the Name, Description.

a. Name : provide a unique name to for the action template

b. Description : provide the description of the action and what is does
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c. Trigger For : It is used to define the scope of action. All Filters will enable this action for
all the alerts and Alert filters will restrict the scope to defined criteria as per selected
named filters.

d. Alert Filters: Select the name of the alert filter to attach an action

e. Type: choose the type of action such as slack, email, and workflow or RPC

f. Trigger: Auto Trigger is used to perform closed-loop automation use cases and Manual
trigger is used to perform on-demand diagnostics and notifications. However, any type
of trigger can be used based on the use case and the criticality of the effect.

g. Is Action Enabled: It is to make sure the defined Action template is ready to attach for
an alert or not. If we disable this, this particular action template won’t be shown or get
triggered when the event happens.

Below is the snapshot to send an email notification for every alert
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If Action is enabled then all enabled actions will show in the Alerts action window as shown below
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Actions

Slack

1. Slack Channel: Provide the channel name

2. Webhook: Provide the slack channel webhook, Refer below link to create an incoming webhook
in slack https://api.slack.com/messaging/webhooks#posting_with_webhooks

3. Body: Provide the template to format the message while notifying via slack, here you can use
the keys from the alert
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Below is the slack notification

Email
1. Email to: Provide the email address

2. Subject: Provide the subject for an email
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Currently, templatization for the email body is not supported in ATOM.

Workflow
Workflow: Choose the available workflow by its name to diagnose or remediate the issue or
refer to the workflow section to create a new workflow and packaging

236



ATOM User Guide

RPC
1. RPC: choose the available RPCs or refer to the developer guide to create a new RPC

2. Inputs: Choose input method key-value or JSON, XML to provide the payload
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Alerts Summary

Below is the snapshot for the alert summary

To see the alert history, click on the entry.
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Manual actions will be shown on click of alert record with vertical ellipsis on top

Filter objects can be seen on click on the action in the top left
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Alert Dashboard

241



ATOM User Guide

Inventory
Anuta ATOM shows Device inventory and extended device inventory as a part of device
summary as well as extensive information of software and hardware is captured and displayed
in the inventory tab.

Once a device is onboarded in ATOM, its device inventory , extended inventory, device
diagnostics, and config pull is done by default.

To see the device information which is extracted from device inventory navigate to Resource
Manager> Devices and then click on the Summary tab. A widget that depicts device information
is displayed as a part of the device summary.

To check the extensive details of the inventory information fetched by ATOM, navigate to
Resource manager> Devices and then click the inventory tab. The inventory tab will in turn
expand the subsections of inventory that is Interfaces, chassis, license and software.
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The interface inventory mentions the device ID, interface, interface name, description, IP
address, MAC address, operational and admin status, duplex type, speed, MTU, VLAN ID, and
encapsulation type.

The Chassis Inventory shows detailed chassis and the hardware information of the device like its
serial number, revision number, module name and other information related to the chassis.
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The license inventory covers, the device ID, name of the device, its description, no of licenses
the device holds, validity information of the license, and rest other details.

The software inventory covers the hostname of the device ID, product model, OS version, and
the package comment.
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Personalization
Personalization support in ATOM helps to save any user modifications like rearrangement of
columns or sorting on a particular column as per desired interest.

For e.g Navigate to Resource manager -> Devices ->Inventory

Rearrange a few columns and do any sorting to create/save personalization with the option
available at right-hand side middle.
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One can make this to be default after the creation of a personalization:
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Software Image Management

Image Upgrade Workflow
Upload an Image and work through a Business process to take a device from V1 to V2 with
pre-checks and Post-checks to ensure the device is working as expected after the upgrade.

Image Repository
ATOM acts as a Network Element Image Repository (Image Server) as well as Config Repository.

Devices can boot an Image from ATOM Image Server manually or through ATOM Network Element

Software Image Upgrade Workflow. Image Manager is a replica of the Minio repository. All the

images are saved to a minio bucket named ‘atom.device.images’ and all the configs are saved to

‘atom.device.configs’. The supported protocols are HTTP, anonymous FTP, TFTP.

.

Following steps on ATOM & Upload Images:

1. To upload a file to the Image Manager navigate to Resource Manager >  Image Manager
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2. To upload an image file, click on the upload option after selecting the

‘atom.device.images’ option
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3. To upload the config file, click on the upload file option after selecting the

‘atom.device.configs’ option
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Once files are uploaded to the image manager then login to the client device, then

transfer the files to a particular location on the device by using SCP protocol.

Syntax : file copy

scp://{user-name}@{agent-node-ip}/{path}/{file-name} {Destination path}/{file-name}

Example :

scp://admin@10.113.10.44/pub/images/junos-vmhost-install-mx-x86-64-18.3R1.9.tgz

re0:/var/tmp/junos-vmhost-install-mx-x86-64-18.3R1.9.tgz
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Software Version Compliance
Software Version Compliance feature enables defining policies and enforcing software currency
checks for network devices. The policies support defining N-1 (previous), N (current), N+1 (next)
compliant versions for vendor and device models. Reports are generated for the software
version checks. Summary reports by device model and vendor are available. The
out-of-compliance devices can then be upgraded using Software Upgrade workflows available in
ATOM.

Network Automation
ATOM provides a stateful or Service and stateless (MOP) automation framework.

Stateless Low Code or MOP automation - Low Code Workflow automation enables network

administrators to perform method-of-procedures involving different actions configuration,

operations including show & exec commands on the device. Multiple actions can be stitched

together to form a flow. Such flow is executed on one more device with appropriate user inputs.

Example:

1. Device Software Image Upgrade
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2. Protocol Migration [IPV4 TO V6, OSPF to ISIS]

3. Hardware RMA/ Refresh [Moving from one vendor to another]

MOP Automation can be a combination of Stateless Action and Staful actions as well. In such

scenarios MOP will contain stateless actions like pre-checks while performing API invocations

against Device or Service Models to perform stateful transactional action.

Such tasks have no requirement for statefulness and can be best developed using Workflow

Automation.

Example:

1. Application Deployment in Data Center with Pre-checks and Post-Checks

2. Branch Config Deployment with Pre-Checks & Post-Checks

Stateful Service Automation - ATOM Service automation helps administrators develop stateful

and atomic transactions. Admins can create service models that enable Create, Update and

Delete operations (CRUD). Such operations can be carried out throughout the life of the service.

Brownfield service discovery is also supported.

Example:

1. Application Deployment in Data Center

2. Layer-3 VPN

3. Layer-2 VPN

4. Private Cloud to Public Cloud Interconnect

Network Workflow & Low Code Automation
Workflow breaks down an activity into subtasks and ties them together with network events,

provisioning actions, show-commands, pre-checks, post-checks, user forms and approvals,

timed background tasks, inventory checks, etc.

Workflow Automation offers an intuitive graphical designer to automate network provisioning

and maintenance activities.

Administrators can create simple or complex flows using ATOM Workflow’s drag and drop

interface. ATOM Workflow has prebuilt adaptors to enable integration with ticketing, billing,

OSS, BSS, and many other network elements. Workflow can also automate multi-level approval

sequences. Use workflows for a one-time project or for repetitive tasks. Workflow development

is covered in the “Workflow Modelling” section in the ATOM Platform Guide guide.  For

automation of tasks that require stateful and atomic transactions, it is advised to use ATOM

Service Models discussed in ATOM Platform Guide.
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Uploading Workflow Package

Navigate to Administration > Plugins & Extensions > Packages

1. Click on Add at the top bar to upload the packages.

2. Upload the workflow package and click on the tick mark
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3. Select the package and click on Activate

Workflow Lifecycle Management

A workflow definition defines the structure of a workflow. A workflow instance is an individual

execution of a workflow definition. The relation of the workflow instance to the workflow

definition is the same as the relation between Object and Class in Object Oriented

Programming. The workflow engine is responsible for creating workflow instances and

managing their state.

Workflow Instances traverse different states as they progress from start to end. The various

states are as listed below:

● Active : Once the workflow is started it gets into an active state. Through-out the

different tasks , the workflow continues to be in an active state and indicates an

error-free execution.

● Error State : If there are unhandled exceptions in the scripts and programmatic/syntactic

errors in inline scripts the workflow execution goes to an error state.

● Internally Terminated : If there are any errors in communication with the device or any

custom  RPCs throw exceptions which don't have explicit error handling defined in the

workflow they are internally terminated by ATOM and the state is updated accordingly.

● Externally Terminated: If the Network Administrator finds any unexpected behavior

during any point in the workflow execution he has an option of manually terminating the

workflow instance. This is the only state that the end user can manually state to

terminate the flow.

● Completed: Once the workflow is terminated and has reached the stop event, the

workflow goes to a completed stage and indicates a successful positive flow execution.

254



ATOM User Guide

Start Workflows :

To start a workflow instance follow the steps below.

1. Navigate to Automation > Workflows > Workflows

2. Select the workflow package from list

3. Click on Start to start an instance of the workflow and provide a valid Instance Name
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Inspecting Workflows:

To view the current running stage of the workflow

1. Navigate to Workflows > Instances

2. Click on Inspect

This opens a window with the workflow elements. Green indicates successfully completed tasks.

Yellow indicates the current task being executed
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Suspend/Pause Workflows:

In the workflow definition view and in the workflow instance view, can suspend the selected

workflow definition or workflow instance by using the suspend button on the panel.

Workflow Definition Suspension

If you suspend the workflow definition, you prevent the workflow definition from being

instantiated. No further operations can be done while the workflow definition is in the

suspended state. You can simply re-activate the workflow definition .

Workflow Instance Suspension:

If you suspend the workflow instance, you can prevent the workflow instance from being

executed any further. This includes suspending all tasks included in the process instance. You

can re-activate the process instance at any later point in time.
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Workflow Instance Error:

Unresolved programmatic/syntactic errors of a process instance or a sub-process instance are

indicated by the Atom workflow engine as errors.  The Errors tab in the workflow instance view

lists the failed activities with additional information.

Retry a Failed Job

To resolve an error you can use the  Retry button on the top panel. Select the corresponding

instance,  so the atom-engine will re-trigger this job and increment its retry value in the

database.
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Workflow Variables

Workflow Instance Variables can be used to add data to the workflow runtime state. Various API

methods/Service Tasks that change the state of these entities allow updating of the attached

variables. In general, a variable consists of a name and a value. The name is used for

identification across workflow constructs. For example, if one activity sets a variable named var,

a follow-up activity can access it by using this name. The value of a variable is the value held by

that particular named variable in the Atom engine for that particular workflow instance context.

To view the workflow variables

1. Select the particular workflow instance that is active.
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2. View the workflow variables in the bottom panel.

3. Users can also edit the variable values during runtime.

4. Alternatively User can compare two variable values and see the difference on the

screen.
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User Inputs:

Some workflows may require the administrator to enter some values at particular stages.

Workflow execution will be stalled until the values are entered.

To view if any Action items are pending against a particular workflow instance we can view it

under the specific workflow instance view :

For viewing such tasks:

1. Select the particular workflow instance that is active.

2. Once Selected navigate to the action tabs to view all pending action items against this

particular workflow instance.
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For completing such tasks

1. Navigate to Workflows > Actions

2. Select the workflow task and click on Claim to claim the task

3. Navigate to Workflow > My Actions

4. Select the task claimed at step 2 and click on Complete

5. Enter values and click on the tick mark
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Network Service Automation
Stateful services are developed using ATOM SDK and involve a Service model developed in YANG

and optional business logic in Python. Such services have a continuous life cycle and undergo

multiple changes over a period.

Services can be deployed in two modes -

Greenfield Mode - A user can instantiate the service, a set of network configurations, using the

service template. These service templates are rendered from schema files that have been

developed as a part of the Service package. ATOM automatically generates and applies relevant

configurations to the devices.

Brownfield Mode - ATOM automatically discovers services running on the device and maps

them to the service template. For detailed information about service packages and how to write

your own service models, and usage of the “maps-to” extension, refer to the “ATOM Platform

Guide”.

Ordering Greenfield Services in ATOM:

To order a service, that was modeled earlier, do the following:

1. Navigate to Automation > Services

2. In the right pane, click Add

3. In the ensuing form, enter values for the fields that are displayed.

4. Click OK

ATOM automatically generates relevant network configurations.

Note: If “Dry Run” is enabled in the Administration tab, the generated configurations will not be

applied to the devices.

Let us take an example of creating an instance of the the “L3 Services” in ATOM. The schematic

representation of the service is defined in the .yang file (in this case, l3service.yang file). This file

is contained in the model folder of the corresponding service package (l3 service package)

uploaded as a plugin to ATOM.

1. Navigate to Administration > Plugins & Extensions

2. Navigate to Automation > Services > l3-services and click on Add
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Deploying BSD services in ATOM:

Let us take an example of deploying “Application Profiles” service in Brownfield deployment

mode:

1. Obtain the appropriate service package from Anuta Networks

2. Upload the service package into ATOM.

3. Navigate to Administration > Deprecated > Services to view the uploaded service

package.
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4. In the Add Application Profiles pane, select the Brownfield Mode as shown below:

5. In the Create Application Services form, all the values discovered from the device are

populated in the parameters shown below:

Enter values in the fields that have been marked mandatory.
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Note: The borders of the fields that contain the auto-discovered values are coloured in

brown color.

6. Click OK after selecting the requisite values in each of the fields.

The commands that are generated in ATOM are not pushed to the device because of the

mode of Brownfield deployment.

Transactional control at the Service level

For every service, the admin can control whether the corresponding configurations, generated

by ATOM, should be pushed to the device. This gives an admin a granular level of control

wherein some services can be sent to the device and a few can be retained on ATOM.

1. Navigate to Automation > Services

2. Click the service that you want to configure the transaction policies.

3. You can either enter the values of the fields or import the values from a template to fill

the form.

4. In the Create service template, click Transaction Policies > Transaction Policy Configs

screen to set the control at the transaction level as shown:
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Option Type Description

do-not- send-commands- to

-devices

boolean Controls whether commands can be sent

to the device. devices

Select this option to commit the data to

the ATOM datastore, but no configuration

changes will be applied to the device.

Useful for testing or in the case of a

brown-field environment to create

services.

Note: The value set for this option at the

transaction policy overrides the value at

the global level (in the General Settings)

fail-fast boolean Controls whether the reference validation

should be done immediately.

False: Defers the validation to after the

‘commit-task’ state of the transaction

validation-scope-type enum Controls whether data validation scope is

across transactions. This flag is similar to
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● COMMITTED_DATA

● UNCOMMITTED_DATA

isolation control in traditional RDBMS,

but limited to just data validation.

Allowed values are "COMMITTED_DATA"

and "UNCOMMITTED_DATA".

Validation will be done only using the

committed data. The current transaction

will not see changes done by other

parallel transactions

Data validation will be done using the

uncommitted data. Current transaction

will see changes done by other parallel

transactions

● Command-sequence-policy

● DEPENDENCY_ BASED

● NONE

enum Controls whether the generated

commands need to be ordered according

to the dependencies specified in the

model.

Generated commands will be re-ordered

based on the dependencies specified in

the data model.

Generated commands reflect the order of

the requests sent from the client, no

re-ordering is done

The values for the following options can be cross-verified before the creation of each

service

● Fail Fast

● Validation Scope

● Command Sequence Policy

5. Click the task created for the created service to view the commands generated by ATOM

in the Task Details.
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In the Task details, click Commands to view the the generated commands by ATOM.  As

the  commands should not be sent to the device, (if do-not-send-commands-to-device

option is selected), the status of the commands is set to “TO_BE_PROVISIONED” as

shown below:

The generated commands can be downloaded and verified with the expected configurations for

that service.

Canceling an ordered Service:

1. Select the service and click Delete.

2. In the Confirmation window, before selecting the Yes button, click the Transaction

Policies.

3. Select the option, “Do-not-send-commands-to-devices” in the policy
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In the corresponding task generated, in the Task Details pane,  click Commands to view

the generated commands by ATOM. As the commands should not be sent to the device

(if the “do not send commands to the device” option is selected in the transaction policy

config), the status of the command is set to “TO_BE_PROVISIONED”.

IMPORTANT:  If this option is not selected properly as per create behavior, the service

deletion might fail.

Service Approvals
You can create policies for approving the creation, deletion,  or updating of the service

configurations on devices. In addition, you can add approvers who must approve the operations

defined in the service approval policy. Apart from seeking approvals for services, you can set

approvers for any of the operations for any entity in ATOM.

1. Navigate to Automation ->Services-> Approvals

2. In the right pane, click Add Policy to create the details as shown below:

3. Navigate to the right pane to add details as described below:

i. Policy Name: Enter a name for the approval policy

ii. Service Target: Enter the path for the object in the data model tree for which

approval is required.

For example:  If the object of interest is a service, enter the path of the service.
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/controller:services/l3service:l3-services, which means that the operation of

interest on this managed-CPE -service will be sent to the approver or approvers

for their perusal before being pushed to the device.

iii. Provision Approval Needed: Check this option if the user selected as the

approver should approve the configurations before they are pushed to the

respective device or devices.

iv. Delete Approval Needed: Check this option if the approver should approve the

configurations that are required for deletion of the service configurations from

the device or devices.

v. Update Approval Needed: Check this option if the admin should approve the

configurations that are required to update the service configurations on the

device or devices.

vi. Policy Type: This option enables you to set if approvals are required from a single

approver or multiple approvers.

● ALL: The task that is generated as a result of a service operation awaits the approval of

all the approvers who have been added for that service.

In the following example, the operation of creating a ‘customer’ needs the approval of two

approvers, ‘admin’ and ‘User1’. The task is completed successfully after receiving the approval

of all the approvers as shown below

● ANY_ONE: The task generated as a result of a service operation awaits the approval of

any of the multiple approvers added for that service.

NOTE: All changes made in the service approval policy will come into effect only for the

subsequent service instantiations and will not affect the ongoing service operations.
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4. Navigate to the left pane to add the tenant users who should approve the configurations

generated by ATOM for any of the service operations (create, delete or update ).

NOTE: Do not edit the name of the user (UserName) who has been added as an

approver in the service policy.

Configuration Drift (Network Services)
Whenever there is a configuration change in the device that does not match with the generated

configuration on ATOM, a reconciliation task is generated in ATOM. After viewing the config diff

generated, the administrator can decide how to reconcile these config differences so that the

device and ATOM are always in sync with respect to the configuration states.

● Navigate to Automation->Services->Reconciliation in the left pane

● In the right pane, click Reconciliation > Entities to view all the reconciliation entities

that are generated at the device level and service level.

272



ATOM User Guide

● Double click the reconciliation entity of your choice, to view the Reconciliation details:

The configuration difference between ATOM and the device is shown on the left pane whereas

the right pane displays the configurations that should be pushed to the device to reconcile with

the state of ATOM.

● Click the Reconciliation Policy to create the policies for reconciling the config differences

either with the state of ATOM or with that of the device.

● OVERWRITE SERVER - The generated config diff is pushed to the database of

ATOM to reconcile with the state of the device

● OVERWRITE DEVICE - The generated config diff is pushed to the device to

reconcile with the state of ATOM.

● WAIT FOR APPROVAL - Select this option if the generated reconciliation entities

require a review by an administrator.  The generated config diff is sent to an

approver who can take the decision of either pushing the configurations to the

device or overwriting the ATOM database.
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Setting the Global Policy :

The policy configured in this setting will have an impact on all the reconciliation entities

generated for all devices.

Setting the Device Policy:

You can set granular control of what needs to be done with the config diff generated by ATOM

for a specific device or a set of devices. The policy configured at the global level can be

overridden by the device level.

For example, if the global level the policy is set as WAIT FOR  APPROVAL but at the device level,

it is set to OVERWRITE DEVICE, all the reconciliation entities generated in ATOM for that device

will be reconciled with the state of ATOM.

Example

Let us understand how service compliance and reconciliation work by taking the service, L3

service” as follows:

1. Create a service instance in ATOM
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2. Login to the device console and delete the “test VRF”  from the device
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3. As there is a config difference between the device and ATOM, a Reconciliation task is

triggered in ATOM.

As the config change in the device is related to the created service in ATOM, a Service

Inventory task is created.

The Service is marked as “Non Compliant” service as shown in the “Compliance”

Dashboard.

You can either resolve the service violation or look at the Reconciliation entities created.

Service Compliance

ATOM helps to detect any configuration deviations in the network at the service level. ATOM

detects the missing, deleted or violated configurations of the services that have been

instantiated in ATOM and sends the reconciliation report.

When a service is instantiated on a device, all the necessary configurations are generated by

ATOM and pushed to the device. After the successful creation of the service on the device,

ATOM compares the running configuration on the device, compares this with the services that

were generated, flags the violations, and marks the service as non-compliant.

If there is any service that is non-compliant, navigate to Automation ->

Services->Reconciliation->Services
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Click Non-Compliant Services to view those services

Resolving Service Violations

ATOM generates the config diff, in the service created through ATOM.  and pushes the deleted

configurations (that were either removed intentionally or accidentally) to the device, thus

enabling the administrator to maintain the same state of configuration in both.

1. Select Non-Compliant Services > Click Resolve Violations
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2. Click the Task Viewer and look for the task named “RPC Operation:

Compliance:fix-service-violations”
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Command Templates
Command templates help to quickly design, build, and visualize end-to-end network

automation. Users can build and execute automated operational and configuration activities
that provide the ability to run network health checks by collecting and evaluating operational
data from the network in an intuitive no-code development interface and built-in network
intelligence.

Features:-

● Perform pre-checks prior to making any device changes to ensure an incident, or outage
or conflicting maintenance event is not active. Conducted post-checks such as pass/fail
evaluations, rule severities, and variable processing, to ensure device changes took
effect as intended.

● We can specify the commands to be executed on the canvas. The parameters in the
command can be substituted from the user input values provided by the user. For eg:
“show interface {{interface_name}}” here interface_name is the variable and can be
provided by the user while executing the template. And this makes the command
template reusable.

● Evaluate and compare results of command template pre- and post-check executions
with Command Templates. Ensure your automations have achieved their desired result
by collecting responses from the command at the beginning of the automation
execution so that it can be compared against the same command at the end of the
automation after a procedure has been performed against it.

Constructs used in command templates:- Constructs used in building command template are
User input variable, Jinja template, Text FSM, regex pattern.

● create a set of commands and can latch a rule with each command. The set of
commands inside the template is executed sequentially.

● Both operational and configuration levels of commands can be executed. The flow can
be terminated if any rule associated with the command is violated.

● This helps to check the output of a show command is as expected and make the decision
to proceed with the execution of the rest of the commands in the template or to abort
the flow.

● A Regex pattern can be used to match certain expressions, or an exact string can be
looked up in the output of certain commands using the associated rule.

● Text FSM can be used to parse the output of a command and parsed output can be used
by consecutive commands.

● Jinja2 templates can be used to provision the config and make decisions on the basis of
conditions.
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The templates created in Configlets are reusable because the template is capable of taking user
input variables. The configuration parameters such as IP address can be taken as user input
variables and the template can be reused.

To navigate the command template feature, click on Automation and then choose the
Command Templates option.

Scenario1: Provision HSRP

Let's take a look at a simple use case to provision HSRP on the CISCO IOS XE router. In this use
case, a precheck is performed if the HSRP is already configured and if not then configure it or
else abort the flow. Post-check is done if the HSRP service is provisioned or not.
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Define Command Template
Click the “Add” button to create a new template

To create the template below is the process that needs to be followed:

1. Name the template.
2. Select the tenant
3. Add the vendor
4. select the platform of the device against which the commands need to be executed.

● Click on commands and rules to create a template,
● Click on the “Add” button to proceed, and add details of each command and associated

rule.
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● Click on Add Template to create a new command. You can select the criteria that all
commands must pass from the template or any command must pass from the template.

● Name the command with a suitable identifier as per the nomenclature.
● Add the command.
● Select if a command needs to be executed in config mode or exec mode.
● Select rule if the rule needs to be associated with the command.
● Define a user input variable.
● Specify the criteria if all rules must pass or any rule must pass.
● Save the template.

A condition can also be defined for the template if all the commands from the command
template need to pass or any command must pass. Note: A command is passed when the
associated rule with the command is not violated.

282



ATOM User Guide

.

● Give a name to the command, and specify the command to be executed on canvas.
● Select exec or config mode.
● add the rule if required
● Specify the rule criteria if all rule must pass (if all rule must pass is selected and the

condition specified in the rule has not been met the flow of execution of commands
inside the template will be aborted).

Here we are checking if the output of the command “show standby” contains the output string
Interface “Grp  Pri P State Active  Standby Virtual IP”. If at all the HSRP config exists then the
flow will be aborted.

Now if the above conditions are met we can proceed and provision the service.

Similarly, define a set of commands using the Jinja2 template, select config mode, name the
input variables and select the format of the variables.
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Name the command. Select text FSM to check if the configuration is done on the router and the
configured parameters are seen in the parsed output.
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Once all the commands inside the template are ready click the “save” button

Execute Command Template
To run the template select the template and click on the “run” button

Check the device against which the template needs to be run, fill in input variables and click run
to initiate the execution of the template.

285



ATOM User Guide

Finally check the status of the command.

In the below snapshot mentioned in the input section, the commands which are pushed onto
the device are seen as input payload.

In the output, we can see what commands are executed and what are not. Which can be
compared against the actual device if needed.
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Scenario2: Provision L3 service (VRF)

Similarly, a complex use case can be created such as provisioning of L3 service VRF on the NX-OS
CISCO router.

Define Command Template
A command template is created with the show version, attach rule with criteria - all rules must
pass, mentions that the output of the command contains a string with NX-OS.

The next command executes “show ip interface brief” and the associated rule with text FSM parses
the output of the command

The next command-template has a Jinja2 template which specifies if the interface is configured
and then set the flag to true else flag remains false. If the interface is configured, ignore the
configuration step and proceed with the next step.

If for loop is top be created, then we need to iterate over the rule name and command name
whereas the command name is get_interfaces and the attached rule name is rules
parse_interfaces
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“

{% set foundInt = { 'flag': false } %}

{%- for item in get_interfaces['rules']['parse_interfaces'] -%}

{%- if  item['INTF'] == sub_interface -%}

{%- if foundInt.update({'flag':true}) -%}

{%- endif -%}

{%- endif -%}

{%- endfor -%}

{%- if foundInt.flag -%}

!

{%- else -%}

interface {{interface}}!-!no shut!-!interface {{sub_interface}}!-!encapsulation dot1Q
{{vlan_id}}!-!ip address {{ip_address_sm}}!-!no shut

{%- endif -%}

”

Similar to the interface check, the pre-existence of VRF can be checked, if already configured,
then the configuration step can be ignored If not then configure it, this condition and
decision-making are done through the Jinja2 template as mentioned in the previous command
and rule pair. As stated previously we can get the reusable parameters in the configuration as
user inputs to make the command reusable.

288



ATOM User Guide

Precheck can be performed using the show route vrf <vrf name> command and ping the far end
IP from the VRF.
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Execute Command Template

After running the template it can be observed that the output of the get interface command is
parsed into JSON format to be consumed by the successor command and can be used by the
jinja2 template for making decisions if the interface is already configured, if not then configure
the interface.
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If the interface is already configured, the configuration of the interface is skipped as per the
Jinja2 template and VRF is configured as it was not configured primarily. Configuration can be
cross-checked manually.
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Agents

ATOM Agent handles all device communication that communicates with Other ATOM

Components either remotely or locally based on deployment mode.

Each ATOM Agent manages multiple network devices. ATOM agents can be assigned multiple

CIDR blocks to manage the devices. It is used to communicate, collect and monitor the

networking devices in your infrastructure using standard protocols. Once the agent collects the

data, it gets encrypted and sent to Anuta ATOM Server over an outgoing SSL connection.

One Agent can typically manage hundreds of devices. However, it depends on many other

factors such as device type, data collection, size of the data, frequency, etc. Check out ATOM

Agent Hardware requirements for further information.

ATOM Agent Deployment is discussed in detail in “ATOM Agent Deployment Guide”.

Administration
As an administrator, you can manage changes in the ATOM that will affect the behavior of the

system and have a global effect on all the components of ATOM.
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● "Tasks" and “Events”

● “Tenants"

● "System"

● “System Manager”

● "Plugins and Extensions"

● “User Management"

● “Tag management"

● “UI Customizations"

● “Troubleshoot"

● “DSL"

● “Deprecated"

● “File Server"

● “About"

Tasks & Events

You can view any activity, “task” that is being executed in ATOM as a result of a user- initiated

action. Tasks are generated during the following operations such as:

● Adding or Deleting Devices

● Executing Jobs

● Validating the resource pool and running the Inventory

● Configuration out -of -sync between the device and ATOM

● Creating or Deleting Networks

1. Select any Task and click Details to view the configurations associated with that task.

2. You can search for any Task by entering a query in the Search field.

3. Select any task and click Cancel to view the task is to be canceled

4. Select any task and click Download Log to view the system-related logs and messages.

For example, enter “Create” in the Search field, if you want to query for all the Create

operations that have been executed so far. All the Create tasks that have been triggered

in various operations are displayed as shown below:

5. Click Retry when the creation of a Service (during instantiation of the Service) fails due

to a deficit in the operational resources or during provisioning. 4. Click Task log to view

the system-related logs and messages
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Events
Events represent an important part of an operation or a change in the state of an object in

ATOM. For example, an event is generated when a user logins to ATOM. In addition, login

attempts to a device using any of the transport types are also displayed.

Select a task and click Details to view the schema of the service and click Commands to view the

configurations associated with the service generated by ATOM.

TraceLogs
Trace Logs enables users to the end-to-end distributed tracing  of a task. User can monitor the

performance of the task and latency optimisation can be done. It actually helps users to

encounter the root cause analysis. The Tracelog option was enabled in tasks UI and also in tasks

and events.

Select any task and click Trace Logs to view the task in distributed tracing.

Trace logs UI can be visualized from jaeger UI, this shows a complete cycle of the task and all the

components involved in it.

To Enable TraceLogs Navigate to Administration > User Management > Users

Here select a User and Entities > DLS-Config

● Disable-Tracing: Set true to disable tracing for the user.

● Logging-Validity: Validity of the limited-time logging in seconds.

● Module-Scope: List of the modules that are supported for tracing.

Any: Enables any of the modules selected.

Selected: Enables only selected modules to tracelogs.
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Disabled: Selected Module will be disabled while tracing.

Note: When you select the trace logs from tasks UI it opens in the new tab as jaeger UI with

SSO URLs. When you select trace logs from Tasks and Events then it opens in the ATOM

application itself as a new window. To enable trace logs from deployment jaeger-tracing pods

should be up.
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System
As an administrator, you may want to configure or modify the system settings or customize

these settings after installing ATOM.

● "Rule Engine"

● "License"

● "General Settings"

● "Look and Feel"

● "Event Summary"

● "Notifications"

● "Message Brokers"

Rule Engine

Rule engine is a functionality in which the user-defined business logic is executed to bring about

changes in the state of the resources managed by ATOM. The logic describes the sequence of

operations that is associated with data in a database to carry out the rule. You can create rules

in the Rule engine for ATOM to handle changes in devices in a maintainable, reusable,

extensible way.  Rule engines support rules, conditions, priority (based on the index), and other

functions. Rules can be constructed to serve various functions, some of which are listed below:

● Resources Validation

● Triggering different actions based on some user-defined conditions

All the system-defined rules available in ATOM as shown in the following snippet:

296



ATOM User Guide

Click on any rule > Entities of your interest and view the Actions and Conditions associated with

that rule.

For example, double click the ‘agent-down-alarm’ rule as shown below:

This rule comes to effect when any of the ATOM Agents goes OFFLINE and the status is

set to INACTIVE.
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In addition to the rules that are available by default, you can create a custom rule as per

your requirement as described in the following section.

Rule

Rules are conditional statements that govern the conduct of business processes. A rule consists

of a condition and a set of actions. If that condition is met, and is evaluated as true then the

rule engine initiates one or more actions.

A rule is composed of three parts:

1. Condition - The condition part is a logical test that, if satisfied or evaluates to true,

causes the action to be carried out

2. Action - The action part consists of one or more actions that need to be performed

when the condition is met.

3. Event - The event part specifies the signal that triggers the invocation of the rule.

Create Rule:

1. Navigate to Administration > System > Rule Engine > Rules

2. Click Add Rule and fill the following fields:

○ Name: Enter a string that will be used to identify the rule.

○ Rule Type: Select the category that the rule should belong to.

There are two types of categories available now:

■ UNCATEGORIZED

■ COMPLIANCE

○ Enable: Select this option if the rule should be enabled.

○ Rule Context:  Enter the context in which the rule has to be triggered:
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■ DATAMODEL: Select this option if the rule should be triggered on a ATOM

managed entity.

● Context path: Example: For this rule to be applied on the devices,

enter the context path as /controller:devices

■ EVENT: Select this option if the rule should be triggered in the case of an

event generated in ATOM.

● Event Spec: Select from the available event specs in ATOM:
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○ Description: Enter descriptive text for the rule

○ Change type The rule engine will check for the conditions defined in the rule

when one of the following scenarios listed below:

Change -Type Description

● CREATE A component is created in ATOM

● UPDATE A component is updated in ATOM

● DELETE A component is deleted from ATOM

• Match-Type The conditions can be evaluated on an ANY or ALL basis.

Match-All:  All the conditions will be matched before executing the action.

• Match-Any: Any condition of the condition-set will be matched before executing the

action.

Create conditions?

Conditions are statements that should be qualified by the system before subsequent actions can

take place. In other words, conditions are what the rule is looking for to trigger an action.

1. Navigate to Administration > System > Rule Engine > Add Rule

2. In the Create Rule > Select Entity > click on + > conditions >click on + > rule-condition

3. In the right pane, enter values in the following fields:

● Index: Enter a unique number as an identifier

● Condition-Expression: Enter an expression that should be checked by the rule

engine for the condition to be true.

Example: To check for a condition when the device is ONLINE, enter an

expression: /controller: devices/device/status == 'ONLINE'

NOTE: Condition expression * means that the rule is triggered on all the conditions as

defined in the context path.

● Description: Enter some text describing the condition.

Create actions?

Actions are operations that will be performed on the entities managed by ATOM once the

condition is evaluated as true by the Rule Engine.

1. Navigate to Administration > System > Rule Engine > Add Rule
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2. In the Create Rule > Select Entity > click on + > Actions

3. In the right pane, enter values in the following fields:

● Index: Enter a unique number that will be used as an identifier and also set the priority

● Type: Select the type of the component that should be acted upon, once the set

condition is true.

● Description: Enter a description for the rule-action

● Event-Name: Select the appropriate event name from the drop-down menu

Licensing & Entitlements
Usage limits in ATOM are enforced through a license file issued by Anuta Networks.

ATOM in Dedicated Mode

License File can be applied at System Level or at Each Tenant. This is applicable to ATOM Cloud

Customers using a Silo/Dedicated Instance or an On-Premises instance. Following are the Admin

& Tenant privileges:

1. Anuta Networks will issue the License

2. For On-Premises Deployment - the customer will apply the License

3. For ATOM Cloud Deployment  - the ATOM Cloud Administrator will apply the License

4. System Admin will have full access (View, Apply & Usage) to System and Tenant License

Files

5. Tenant Admin/User will be able to view Available licenses and Usage for Tenant they are

assigned to

ATOM in Multi-Tenant or Shared Mode

This is applicable only in ATOM Cloud Following are the Admin & Tenant privileges:

1. Anuta Networks will issue the License

2. Anuta Cloud Administrator will issue & Apply the License for each Tenant

3. System Admin will have full (View, Apply & Usage) access to System and Tenant License

Files

4. Tenant Admin/User will be able to view Available licenses and Usage for Tenant they are

assigned to

Uploading a License

We can upload the license using the upload button. Multiple license files can be uploaded to

ATOM. Usage limits are cumulative of all License Files.
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License Summary

To view the License Summary & Details - Navigate to Administration > License

License Summary will show the overall summary across all the License Files.

Total Usage(C1): C1 Category Licenses Used vs Allowed

Total Usage(C2): C2 Category Licenses Used vs Allowed

Total Usage(C3): C3 Category Licenses Used vs Allowed

Total Usage(C4): C4 Category Licenses Used vs Allowed

Active licenses: Number of licenses which are active will be shown under active licenses

Expiry date: Farthest expiry date among all the License Files

Below the License Summary, all available License File details are shown as below:

Tenant admin license
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General Settings
You can edit and save the change the configuration parameters for each module in ATOM  and

these global changes are applicable to all the resources contained in each module.

1. Go to Administration > System > General Settings

2. In the General Settings panel, you can review the default settings of the following

options and modify them.

3. Click Edit to modify the parameters arranged for each module.

URL Management
1. Base URL: This option enables the administrator to set the address (Base URL) for the

third-party clients to make API request calls to the ATOM server. The format of the Base

URL is http[s]://ip|hostname, where IP is the IP address of the ATOM server and the

hostname is the hostname of the ATOM server.

2. Support URL: Enter the URL of the support to log in to the support portal of Anuta

Networks

3. User Session Timeout: This is the time that you can set for the ATOM server to timeout

if no activity takes place in the browser for a specified period of time. The user will be

automatically logged out of the session, after the expiry of the specified time.

Alert Monitoring

1.Unwanted-alertlabel-keys: Each alert consists of multiple labels like alert name, app,

collections_name, etc out of which some may not be persisted in Atom.

Chart-setting

1. Chart-theme: Select the chart theme from drop-down, it should show in the monitoring

custom chart.
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2. Chart-refresh-interval: To set the default refresh interval,it should refresh the chart

based on the given interval time in this global set.

Device Management

1. Configuration Retrieval: This option enables the server to retrieve configurations from

the devices after each operation. By default, this option is selected.

2. Syslog Configuration: This option enables ATOM to configure the device to send Syslog

events. By default, this option is selected.

3. Persist Configuration: This option enables the configurations to persist in the NVRAM of

the device after each provisioning.

4. Dry Run:  This option enables ATOM to push the commands to the device or not. When

selected the commands are pushed to the device..

5. Auto Retry: Select this option to enable ATOM to try establishing the connection with

the device in case the connection is lost initially

a. Number of Retries: Enter the number of times that ATOM should try establishing

the connection with the device in case of failure.

b. Retry Wait Time: Enter the time period that ATOM should wait between

subsequent retries.

6. Configuration Parsing: This option enables ATOM to parse the configuration retrieved

from the device and store the configuration data in the data model maintained in ATOM.

7. Configuration Pull Type: This option determines how the mode of retrieving the running

configuration from the device

● TFTP_EXPORT - The running configurations are obtained from the TFTP server

● SHOW_COMMAND - The current configuration on the device are obtained by

ATOM

8. Log Running Config: This option enables ATOM to dump the retrieved configurations

from the device in the logs obtained for the Config Retrieval Jobs.

9. Run-extended-inventory: Configuration settings on disabling the extended inventory

when a device is added

10. Generate-config-inventory-event: This option allows ATOM to enable or disable the

config inventory event

Service now

1.Snow-instance : To enable service now option to perform the service now workflow

2.Snow-url : To provide the instance id for service-now

3.Snow-username : User name for service now
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4.Snow-password : Password for service now

Service Management

1. Service Auto Retry: Select this option if ATOM should retry pushing the configurations to

the device in the event of a service failure.

a. Service Number of retries: Enter the number of times ATOM should retry

sending the configuration after the initial failure of the service.

b. Service Retry Wait Time: Enter the duration of the time that ATOM should wait

before trying to establish a connection with the device again.

2. Auto Delete Stale Inv Data: Select this option if all the available “stale” entries should be

deleted from ATOM. Stale entries are the configurations that are available in the device

and not seen in ATOM. These differences are not due to the service configurations

created by ATOM and pushed to the device.

3. Delayed Event Buffer Time:

TSDB

1.Retention-period: Retention period of Prometheus DB

2.Retention-size: Retention period of Prometheus DB

3.Namespace: Namespace to get the stateful sets and config map

4.TSDB-url: Url to get metrics

5.Workflow-URL: The url to get workflow

6.TSDB-config-map-name:The name of the tsdb config map

7.TSDB-stats-name:The statefulset name of the tsdb server

8.TSDB-infra-alert-config-map-name:The name of the tsdb config map for system alert

9.Alert-repeat-interval:The repeat interval time of the alerts

10.Tsdb-alert-manager-config-map-name:The name of the alert manager config map

SNMP v2 Configurations

1. Enable Device Audit Trail Mode: Select this option to view all the events generated in

ATOM while communicating with the device using the SNMP protocol. SNMP events

such as SNMP WALK, GET, DEVICE_LOGIN, and DEVICE_COMMAND EXECUTION are

captured in ATOM as Events.

2. Enable Multi-Tenancy: Select this option to enable ownership of the resource. Once this

option is enabled, the fields “Owner & Shared with” are displayed
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3. SNMP Configuration Contact: Enter the mailing ID for contacting the admin (support)

managing the SNMP server.

4. SNMP Configuration Location: Enter the location of the SNMP server

5. SNMP Community string: Enter the community string required for authentication in

SNMPv2 sessions..

SMTP Configurations

You may have to configure an external email server to send email notifications to  the ATOM

users.

SMTP Mail From: You can set up an external SMTP email server to send email notifications to

ATOM users. To do so, enter values in the fields described below:

1. SMTP Host: Enter the name of the server that will send the email.

2. SMTP Port: Enter the number of the port that is used to connect to the SMTP host

3. SMTP Auth Required: Enable this option is authentication is required to connect to the

SMTP Host

4. SMTP User Name: Enter the name of SMTP user

5. SMTP Password: Enter the password to retrieve the email.

6. SMTP Encryption SSL: Select this option if the connection to the SMTP server should use

SSL as the authentication method.

7. SMTP Encryption TLS: Select this option if the connection to the SMTP server should use

TLS as the authentication method

Notification

Email Notifications: Select this option if you wish to be notified via email about changes taking

place in the system.

License Expiry Threshold (days): Set the number of days to notify the user that the license is

about to expire.

Python Remote Debug

Python Remote Debug: Select this option if you want to allow debugging of the logs in ATOM

remotely.

Debug Server Port: Enter the port number of the remote debug server.

Developer Options

Enable Developer Mode: Select this option for the Developer Options to be visible in ATOM.
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Using the Developer Options, the admin can view all the ATOM entities represented in the data

model tree, figure out the xpaths of the objects, all the device, and service ATOM SDK.

System Maintenance

Enable Maintenance Mode: Select this option if the system needs to be suspended for some

time during which no operation can be performed on the ATOM VM.  All the TASKS running in

ATOM should be in “COMPLETE” state before enabling this option.

View Actions

Show Module Prefixes: Enable this option if the module prefixes for child entities on Profile and

Action items should be made visible.

Request Sanitization

As an administrator , you can protect the data entered in ATOM from malicious attacks in the

form of HTML tags. These tags when injected into the application’s HTML code can make ATOM

vulnerable to these attacks and have a large impact as any user of the application can be a

target.

The data entered in ATOM can be sanitized based on the

1. Security Sanitizer Enabled: Select this option if the sanitization filter should be enabled

in ATOM.

2. Sanitizer Exclude URL: Enter the tags that should be excluded from filtering. The

patterns mentioned here are allowed as values in the text fields in any of the HTML

forms used in ATOM.  For example, These tags can be added in the exclusion list

-/login,/initialize,/logout,/*.js,/controller:admin-settings$

3. Sanitizer Patterns: Enter the patterns that will be used to sanitize the data and should

not be allowed as values in any of  the fields in any of the text fields in the HTML forms

of ATOM.

An  appropriate error message is displayed on the webpage when the user inputted data

matches with the sanitizer pattern mentioned above.

Password Profile

The parameters required for a password that is used to authenticate logging into ATOM can be

1. Password Expiry Days: Enter the number of days for which the set password is valid.

2. Password Pattern:

3. Password Min Length: Enter the minimum number of characters that should be

contained in the password used to authenticate the logging into ATOM.
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4. Password Max Length: Enter the maximum number of characters that should be

contained in a password used to authenticate the logging into ATOM.

Primary container load limit

1. Set the range of container load limit

Workflow

1. If true both delete both active and historical instances on package unload,if false, history

will be maintained but unload will fail if active instances are there.

Look and Feel
You can change the "look and feel" of ATOM’s GUI by uploading images of your choice to ATOM.

1. Navigate to Administration > UI Customizations > Look & Feel

● Product Logo: Select the image that you should be displayed as the product logo,

visible on all the screens.

● Login Screen Logo: Select the image that should be displayed on the login screen.

2. Click Update for the uploaded images to come into effect on the UI

or

3. Click Defaults to revert to the default images.

Event Summary
ATOM-generated events are grouped into different categories, (Alarm, Services, and System)

with an assigned severity to each category. ATOM maintains an event catalog and decides how

and when an event is created and whether to associate an alarm with the event. Events are

generated in ATOM through notifications received via the Syslog and trap messages, inventory

changes, the discovery of the devices, changes in the ATOM server itself.

The severity of events can be classified into

● CRITICAL - Events that demand the immediate attention of the system administrator.

They are generally directed at the global (system-wide) level, such as System or

Application. They can also be used to indicate that an application or system has failed or

stopped responding.

● WARNING - A warning indicates that a component or application is not in an ideal state

and that some further actions could result in a critical error. These can be treated as a

forewarning of a problem that might occur.

● ERROR - Events that indicate problems, but in a category that does not require

immediate attention.
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● INFORMATIONAL - Events that pass noncritical information to the administrator.

Not all Events are associated with Alarms. Multiple events can be mapped to the same alarm.

All Alarm Events are associated with an alarm that can be either state, CLEARED or ACTIVE.

Notifications
All the events that are triggered in ATOM due to various reasons such as change in the

component state, device unreachability,  high CPU usage of the system, and so on can be

notified to subscribers. As an administrator, you can create notifications such that users, and

message brokers can be notified when an event is triggered.

Subscribers can be added to the events falling in any of these categories:

● Alarm Events

● Internal Events

● System Events

● Resource Events

● Service Events

Each of these categories contains many Events, pre-defined in ATOM. You can create subscribers

or the recipients of a particular notification.

1. Navigate to Administration > System > Notifications
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2. In the left pane, click a folder (of your choice). All the events are grouped into different

categories

3. In the expanded view of the folder, select an event as shown below:
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4. In the Events Subscribers pane, click Add to the subscriber to the ATOM-generated

event.

5. In the Create Subscriber (s) screen, choose the type of the Subscriber:

○ User

■ These users are the users created in ATOM . See the section, Creating

Users in ATOM

○ AMQP Broker

■ These are the message brokers where the events generated in ATOM are

published. See the section, Creating Message Brokers for more

information.

Message Brokers
As an administrator, you can configure a message broker to publish the events generated by

ATOM. A message broker can be notified of all events or an event belonging to a specific event

type.

In the current implementation of ATOM message brokers, RabbitMQ is the supported AMQP

server where ATOM publishes the events and from where any AMQP listener consumes them.

Prerequisites:

Before creating Message Brokers in ATOM, check whether a virtual host exists in RabbitMQ.
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If there is no existing vHost, create a new virtual host as shown below:

1. Log in to RabbitMQ and go to the Virtual Hosts tab to add a new vHost

2. Add users for the created virtual host

3. Create users with required permissions in the vHost

Creating Message Brokers in ATOM:

1. Navigate to Administration > System > Message Brokers > click Add

2. In the Create message broker screen, enter the following fields as described below:

● Broker Address: Enter the IP address of the message broker (AMQP server which in our

case is RabbitMQ).

● Port Number: This is the port number used to communicate with ATOM. By default, it is

5673.

● Username and Password: Enter the credentials for logging into the message broker.

● vHost: Enter the virtual host name that was created in RabbitMQ. Refer "Prerequisites"

section.

● Exchange: Enter the name of the exchange in the message broker where the events

generated in ATOM should be published. The default name is “ATOMNotifications”.
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● Enable Publishing: This option enables the administrator to enable or disable sending

notifications from ATOM to the exchange. By default, the checkbox is selected, which

means that the events can be sent to the broker.

● Connection Status: After saving the Message Broker, this field will be updated to

True/False based on the success or failure of connectivity to RabbitMQ

● Click Add to select the events that should be sent to the message broker.

AMQP Listeners
You can create AMQP listeners in ATOM so that the messages (events) published in ATOM can

be consumed by them.

In the current implementation of ATOM message brokers, RabbitMQ is the supported AMQP

server where ATOM publishes the events and from where any AMQP listener consumes them.

Prerequisites:

1. Log in to RabbitMQ Message Broker using the appropriate credentials

2. Create Queues in RabbitMQ

a. Login to RabbitMQ and go to the Queues tab.

b. Add a new queue as shown below:
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3. Bind the Queue with the Exchange in RabbitMQ

i. In RabbitMQ, navigate to Exchanges

ii. An Exchange entry is created in RabbitMQ and a connection with ATOM is

established

iii. Select the Exchange, “ATOMNotifications”, created in ATOM and bind the

created Queue to the same as follows:

314



ATOM User Guide

4. Verify the messages in RabbitMQ

i. Go to Queue > Get messages

ii. In the Messages field, enter a number for the messages that you want to be

displayed.

iii. Click Get Messages as shown below:
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To create the AMQP listener in ATOM, do the following:

1. Navigate to Administration > System > AMQP Listeners

2. Click Add AMQP Listener in the right pane to create a listener in ATOM

Enter values in the fields in the Create AMQP Listener screen as described below:
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● Broker Address: Enter the IP address of the AMQP server that will receive the

notifications from ATOM.

● Port Number: This is the port number that needs to be configured on the message

broker to listen into the ATOM notifications.

● Username: Enter the username of the AMQP listener.

● Password: Enter the password to authenticate the AMQP listener.

● vHost: Enter the virtual host name that was created in RabbitMQ

● Queue: Enter the name of the Queue created in the AMQP server (example, RabbitMQ)

● Agent Name: Select the ATOM agent from which the ATOM notifications are generated

on a given set of devices. All the notifications created on the device managed by the

ATOM agent will be published in the queue.

System Manager
To view the components, microservices, and the applications managed by ATOM, navigate to

Administration > System Manager

Dashboard:

View the graphical representation of the connection between the Applications, Components,

and the underlying microservices.

Navigate > Administration > System Manager > Dashboard
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ATOM Components:

Navigate > Administration > System Manager > Atom components > Atom components

The components, of ATOM, along with their dependencies are displayed as follows:

All Components:

Navigate > Administration > System Manager > Atom components > All components

The components of the Kubernetes cluster that are not owned by Anuta are displayed as

follows:
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Component Relations:

Navigate > Administration > System Manager > Atom components > Component Relations

All the dependencies between the components can be visualized as follows:

Applications:

Navigate > Administration > System Manager > Atom components > Applications

All the applications served by the underlying Components are displayed as follows:
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Component Functions:

Navigate > Administration > System Manager > Atom components > Component Functions

The association of the components between the applications can be visualized as follows:

Deployment Functions:

Navigate > Administration > System Manager > Atom components > Deployment Functions

The following deployment summaries to be displayed
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FQDN Agent Settings

Navigate > Administration > System Manager > FQDN Agent Settings

1.No need to restart any pod, it should discover any endpoints.

Command : kubectl edit cm -n kube-system coredns

2.Content added as below:

anutacorp.com:53 {

errors

cache 30

forward . 172.16.100.5

}

Go to Administration/System Manager/FQDN Agent setting for pattern
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Click Add Symbol and Select Default-Domain-Agent and give proper Pattern & Priority

After creating FQDN then go to Entities/Ip-Ranges as shown.
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Provide valid IP Ranges and select agent

Go to Devices and click add a symbol and Provide FQDN-Name to resolve FQDN
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Plugins and Extensions
By utilizing the normalized device abstractions maintained in data stores written in YANG

maintained in ATOM, the customers can write their own device models and applications to

meet their specific operational needs, thereby utilizing the extensibility of ATOM.

The device and service packages are loaded as bundles or plugins to the ATOM container

thereby making them modular. The packages can be installed, updated, or deleted without

disrupting the operation of the device.

In addition to modeling the devices and services, you can model the features or network

functions required to build a network service. These features thus modeled appear as icons in

the feature palette of the Service Designer pane of ATOM. The newly added features along with

the included associated services can now be used to design the service in ATOM.

Packages

ATOM is packaged with many predefined device packages to enable you to work with many

vendor devices. ATOM also provides the capability to update the existing device packages and

the ability to add new device packages

A Device Model contains inventory models, communication models, and notification models

that are packaged and uploaded to ATOM. A device package consists of models, a

vendor-specific configuration data for all the different devices.

For details about what constitutes a device package and how to write it, refer to examples cited

in the guide, “ATOM Platform Guide”.

A Service package contains the services models, service yang files, and metadata information.

For more information about Service Modeling, refer to examples cited in the guide, “ATOM

Platform Guide”.

Package Explorer

Users can manage and get the information on the packages that are currently available in the

system. The packages that were uploaded and loaded can be viewed in minio UI.
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Navigate to Administration > Plugins & Extensions > Package Explorer

SNMP

Navigate > Administration > Plugins & Extensions > Package > SNMP > SNMP Mibs >Upload
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Navigate > Administration > Plugins & Extensions > Package > SNMP > SNMP OID Maps > Add
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Navigate > Administration > Plugins & Extensions > Package > SNMP > SNMP Metric Metadata  >

Add
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Device Support

Device Support view allows users to create a new Vendor, Device Type, Device Family, OS Type,

Device Capabilities, Terminal Handling Properties, etc.

Managing Tenants
The administrator can make use of ATOM’s multi-tenancy capability to share IT resources

cost-efficiently and securely by creating Tenants. The Tenants share a common infrastructure,

yet utilize a defined set of highly secure services, with complete isolation from other tenants.

The resources managed by ATOM can be securely shared among multiple applications and

tenants (businesses, organizations, etc.) that use the resources of the datacenter.

Overview of Multi-Tenancy

● Multi-Tenancy - Supported on ATOM On-Premises & ATOM Silo/Dedicated Deployment

on ATOM Cloud.

○ Tenants (Coke, Pepsi etc.) are completely isolated from each other.

● Sub-Tenancy - Supported on All ATOM Deployments - On-Premises, ATOM Cloud

Silo/Dedicated, and also ATOM Cloud Shared.

○ Data sharing across sub-tenants (Coke.east, Coke.west, Coke.it etc.,) is controlled

by Tenant Admin.

○ By Default Data at a higher Level, Tenant is Visible to the Sub-Tenants.

○ By Default, Data under a sub-tenant is visible to the Tenant

○ By Default, Data under a sub-tenant is not visible to other Sub-tenant

○ Example - Coke.east owns a resource (credential set or device etc.) and wants to

share with sub tenants (Coke.west but not with Coke.it). In this case, ATOM Multi

Tenancy Infrastructure provides a facility to share a resource with particular

sub-tenants. Upon sharing the resources as required, each individual ATOM User
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interface will provide information on Resource sharing as shown below. This

behaviour will be the same across all the resources in ATOM and will not be

discussed specifically across features in the user guide.

Sample View of Resource being shared from Coke.east to Coke.west

Mulltitenancy feature is enabled in the system as a result of which every object managed by

ATOM can be owned by an admin and shared with multiple users (tenants) simultaneously.

Aided by rules and roles that can be created in ATOM, the administrator can either assign or

restrict access to the resources (resource pools, sites, locations, IPAM, devices) managed by

ATOM.

All the created resources in ATOM are allocated to the system, the default admin user who is

the owner of the resources. These resources managed by ATOM are available to all the Tenants

in the system. The administrator can now share the system resources with the required tenant

or tenants. From then on, all the resources that are created in each Tenant (parent) are available

to only the users (child nodes) of a particular parent.

Root Tenant

‘System’ is the root tenant. Every other tenant is a child or in the child hierarchy of this root.

There may be few objects which are kept ‘private’ to the system, meaning, those are not

‘shared’ to child tenants.

Top Level Tenants
Top Level Tenants (referred ‘tenants’ for simplicity) are the immediate children of system nodes.

For ex;

System

Company-1

Company-2

Company-3

In the above example, company-1, 2, 3 are top level tenants.
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Simple Multi-Tenancy
ATOM supports Sub tenancy where a tenant can subdivide their resources into a sub-hierarchy.

But, when there are no subtenants in the deployment, it is referred to as ‘Simple Multi Tenancy’.

For ex;

System

Company-1

Company-2

Company-3

In On-Prem deployment, it is up to the customer how they treat the root tenant.

If they don't create any child tenants to the system, then, system and customer are

synonymous.

Hierarchical Multi-Tenancy

Sub-Tenant

A sub-tenant is a child [directly or indirectly] of a Top Level [Not root] tenant.

System

Company-1

North

South

Campus-1

Company-2

Company-3

In the above example,

‘System’ is the root tenant

Company-1, Company-2, Company-3 are top level tenants

Company-1.north, Company-1.south are sub tenants of Company-1.

Company-1.south.campus-1 is a sub tenant of acme.south
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System users

System is the root tenant. System users are those, whose User.owner = ‘system’.
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Tenant Users

Tenant users are customer users owned by individual tenants. User.owner != ‘system’
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Owner:

Owner is a tenant. And, we use ‘tenant-id’  to identify a tenant.
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Tenant-id uses fully qualified names separated with dots, such as, Company-1.south.campus-1.

Multi-Tenancy is all about keeping data private to a tenant. This means, that data identified by a

key can have one copy for each tenant. Suppose, 2 tenants want to bring in the same device-1 ?

That counts as 2 instances with the same key.  Clearly object id by itself is not sufficient. Hence,

objects are identified by their id and ‘owner’. Object key is formed by object id and owner.

Shared-with:

A resource can be shared with multiple tenants or kept private to the owner.

Sharing of resources applies only when a resource owned by one tenant is to be used by

another tenant.

For example, a device owned by tenant-1 is used by a ‘network service’ created by tenant-2.

Sharing across tenants is not supported. but, within a tenant sub-hierarchy is supported.

For example, no data is ever shared among the 3 companies of the following hierarchy

System

Company-1

Company-2

Company-3

But there is, down the hierarchy sharing allowed. Such as, ‘system’ resources are shared to all

the three [and sub-tenants, if exist].

If Resource is the shared-with system then it is private to the system

If Resource is the shared-with system.* then it is shared with all sub-tenants.

Concept Of Visibility And Usability
Visibility is the same as ‘Readability’; Whether a resource is visible to a user.

Usability of a resource is with respect to another resource and it is about whether a resource-1

can be referred (in relation for example) by another resource.

For example,

device-1.credential-set = ‘cred-1’

# resource Owner

1 device-1 Univ.Engg

2 cred-1 Univ.Phy
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Device-1 wants to use ‘cred-1’ in a ‘device.credential-set’ relation.

Currently, to make cred-1 available (visible, usable) to resources of Univ.Engg, you have to share

it with that tenant.

# resource Owner shared-with

1 device-1 Univ.Engg

2 cred-1 Univ.Phy Univ.Engg

Shared With Variations

System

Company-1

Campus-1

Department-1

Department-2

Campus-2

Owner Resource Shared With Details

Company-1 R1 Company-1 R1 becomes a private

object

Company-1 R1 Company-1,

system

A Tenant Resource

shared with system

[there are a few

scenarios where this is

useful]

Campus-2 R1 company1.Camp

us-1,

company1.Camp

us-2

Sharing with other

tenants [in the sub

hierarchy]

Campus-1 R1 Campus-1.* Using wildcards in

sharing-with. R1 will be

shared with all sub

tenants. Since sub
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tenants can be added or

removed during the life

cycle of a deployment,

sharing is spread to all

the sub tenants

available at the time of

invocation.

User.Owner:

User object has an ‘owner’ property, just like any other resource.

But, there is a special meaning to ‘user.owner’.

Users need to be authenticated in the system.

Authentication is done with an ‘Identity Provider’, such as an LDAP.

Identity Providers are associated with tenants.

So, a user is authenticated against the provider traced via User.owner

User.can-read-data-of And User.can-change-data-of:

A user could be created at a higher level (user.owner) but to limit the user to a subset of tenants

there are two properties.

‘can-read-data-of’ controls which tenant data a user can read.

‘can-change-data-of’ controls which tenant data a user can change.

When a top level tenant does not have sub-tenants, user.can-read-data-of will be fixed to the

tenant. User.can-change-data-of can be used to disable writes [by omitting a value]. If decided

to allow writes , the value will be fixed to the tenant.

338



ATOM User Guide

NOTE: Except Monitoring and Alerts all other components are MT Enabled.
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Creating Tenants

Before instantiating a service, there should be at least a single Tenant created in ATOM.

1. Navigate to Administration > Tenants

2. Select the Tenants folder > click Add

3. In the Create Tenant screen, enter the following:

● Name: Enter an alphanumeric string of not more than 32 characters

● Description: Enter a description for the Tenant

● TenantId: Enter a unique identifier for the Tenant

● Dry Run: This option does not allow ATOM to send the configurations to the

devices while creating services. By default, this option is unselected.

○ Select the checkbox to allow ATOM to push the commands on to the

devices.

Onboarding Tenants through Keycloak scripts
Before creating a tenant admin, We need to create a tenant manually in system admin(Ex:Coke).

Navigate->Administration->Users and tenants->Tenants:

Creating a tenant in Atom UI.
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SSH into Master IP of ATOM to run onboard_tenant_lifecycle.py.

Configure like below in master IP.
sudo python onboard_tenant_lifecycle.py -r <tenant name> -c atom -tenant True -realm

True -vip <tenant ip>

EX : sudo python onboard_tenant_lifecycle.py -r coke -c atom -tenant True -realm True

-vip 172.16.5.65

Note:: tenant ip  which is not pingable.

341



ATOM User Guide

After running the commands, need to copy the Tenant login URL from TENANT HAPROXY URL :
https://172.16.20.95.

After getting the tenant haproxy url , need to connect the keycloak as:

https://172.16.20.90/auth

Login to keycloak using  user/password : admin/Secret@123
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Create tenant admin
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Set the password

Login with tenant admin user
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Upload the tenant license in atom
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Check the tenant admin UI.

User Management
The control of users and groups is a core element of ATOM system administration. Users can

also be grouped (based on the function) to have read permissions, write permissions, execute

permissions, or any combination of read/write/execute permissions for files owned by that

group.
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Managing Users in ATOM not only covers creating users but also configuring or assigning the

privileges for each user or similar group of users to perform tasks in ATOM. Apart from creating

the access or denying permissions in ATOM locally, you can import existing LDAP or AD users

into ATOM and extend the necessary permissions to them too.

User management and Authentication works in ATOM as shown in the diagram below. The user

information is saved in KeyCloak. OAuth Proxy acts as a gatekeeper checking all the incoming

requests and ensuring the requests are coming from an authenticated client. If the proxy sees

an non-authentic call, it redirects the request to a login screen served by the identity provider,

which is KeyCloak.

User management in ATOM includes the following:

● "Roles"

● "Creating Authentication Mode Priority"

● "Managing Users"

● "Configuring Access Control"

● "Managing OpenLDAP Users"

● "Managing Active Directory Users"

● "Managing TACACS Users"
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Roles

A set of system-defined permissions are grouped into roles and are available in ATOM by

default. These roles can be assigned to a user during the creation of users in ATOM.

● ROLE_SYSTEM_ADMIN: Administrator of the root tenant ('system'). Every other tenant

is either a direct child of the system or a subtenant (descendent) of a top-level tenant.

System admin is given permission to onboard tenants and manages 'system' tenant

resources.

● ROLE_TENANT_ADMIN: Is the equivalent of ROLE_SYSTEM_ADMIN (gets blanket

permissions on all resources) but limited to resources of the specific tenant

(‘user.owner)’ .

● ROLE_USER_ADMIN: Gives all access to user mgmt objects (users, Groups, RBAC  rules

[rule list and everything down] etc), but limited to user.owner.

● ROLE_WORKFLOW_ADMIN: Allows a user all permissions on all workflow resources.

This avoids having to create individual workflow permissions.

Note that other permissions (rpc, data node etc) are still needed to be given explicitly,

because this role only covers ‘Workflow resources’ only.

Managing Users

An Administrator can add local users to ATOM and configure their email accounts to receive

notifications from ATOM. Apart from local users, ATOM lets its customers integrate their central

authentication servers to streamline the user login process and automate administrative tasks

such as user creation and role assignment. User data is synchronized from customer

authentication servers into ATOM.

Prerequisite of Adding New User:

Before adding a new user, we need to follow the below required steps

Navigate to Administration->System->General setting->Edit->Smtp configuration:

You have to configure an email server to send email notifications to the ATOM users.

SMTP Mail From: You can set up an external SMTP email server to send email notifications to
the ATOM users. To do so, enter values in the fields described below:

1. SMTP-MAIL-FROM : Sample value like atomdev@anutanetworks.com

2. SMTP Host: Sample value like smtp.gmail.com

3. SMTP Port: Example 587

4. SMTP Auth Required: Enable this option if authentication is required to connect to the
SMTP Host
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5. SMTP User Name: Example atomcloud@anutanetworks.com

6. SMTP Password: xxxxxx

7. SMTP Encryption SSL: Disable/Enable this option according to your SMTP.

8. SMTP Encryption TLS: Select this option if the connection to the SMTP server should use
TLS as the authentication method

9. SMTP-MAIL-TO: Example atom_qa@anutanetworks.com

In Keycloak admin has to update the SMTP settings following the below steps-

1. Navigate to keycloak url https://<ATOM-Master-IP>:32443/auth/:
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2. Click On the administration console and it goes to the login page if not given earlier. Enter the
user name/password

3. Navigate to Keycloak->System->Realm setting->Emails: Configure the below smtp setting in
realm setting and save it.

4. Navigate to keycloak->Master->Users->View All Users->Edit admin user: Provide any dummy
Email if needed, turn on the flag for “User enabled” and save it.
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5. Navigate to Keycloak->System->Realm Settings->Emails: If we click on test connectivity it
should be successful.

352



ATOM User Guide

Adding a New User:

To add Users in ATOM, do the following:

1. Navigate to Administration > Users & Tenants > Users & Roles>Users and click Add.

2. In the User Invitation screen, enter the values in the following fields:

a. External User: Enable this button to create AD, LDAP, or TACACS users in ATOM.

When this button is not enabled, a local user is created in ATOM.

Note: A local user will be required to reset his account password on the first

login attempt. An external user can directly login to ATOM using the link in

their invitation email.

b. Add User: The administrator can invite one or more users to ATOM at once. To

add more than one user, click on the + button.

i. Username: Enter an alphanumeric string of not more than 36 characters.

Note: While creating AD, LDAP, or TACACS users in ATOM, the name

entered in the Username field should be the same as that created in

the respective authentication server.

ii. Email Address: Enter a valid email ID. Invitation emails to join ATOM

Cloud will be sent to this address.
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c. Assign Roles to User: User can be assigned relevant Role(s) from the list of

system-defined Roles. Each Role is a set of system-defined permissions given to

the user.

d. Assign Groups to User: Users can be put into pre-defined Group(s) to apply the

access control privileges on them as a whole.

e. Enable Developer Mode: In developer mode users have access to many tools to

work with Atom platforms.

f. Can-Read-Data-Of: Select the tenants, whose data this user can read.

g. Can-Change-Data-Of: Select the tenants, whose data this user can change.

h. Owner: Select the owner of this user.

i. Shared-With: Select the tenants with whom this user should be shared.

3. If user creation is done, then check the mail sent to the given mail id of the new user

created in ATOM for account update.

4. Clicking on the Link will take you to the ATOM login page and it should show update

password option.
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5. Set the new password.

6. Now new ATOM user login can login to atom UI with username/password
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7. Access  the ATOM UI page after logging in with the new username/password.

Editing an Existing User:

User details can be edited by selecting an user. When a user is edited, the user is taken to the

same form seen for adding a user. However, fields such as Username, Email Address and

External User are non-editable as these form the fundamental identifiers for the user.
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Resend User Invite:

If the invitation to ATOM Cloud needs to be resent to the user’s email address, the

administrator can select the user and click on the resend invite icon. This is right next to the

delete icon.
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Block/Unblock User:

At any instance, the administrator can Enable or Disable a user account by this option. When

blocked, the user will not be allowed to login to ATOM. The Block button is next to Resend

Invite.

Assigning Role to the User

From the drop-down menu, select the role that should be assigned to the user. These roles are

defined earlier in the section, “Creating Roles”.

Creating SNMPv3 users

SNMPv3 users are required when the users or third-party applications require additional

authentication and access control provided by SNMPv3.

1. Navigate to Administration > Users & Tenants > Add User

2. In the user screen, select the user >entities> snmpv3 in the right pane.

3. In the right pane, enter values in the following fields:
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a. Authentication Protocol: Enter the mode of authentication when SNMPv3 is

enabled.

b. Privacy Protocol: Enter the requisite privacy protocol depending on the selected

authentication protocol.

Subscribing to Events

Email notifications can be configured to be sent to the created user when a specific event or

events occurs in ATOM.

1. Navigate to Administration > Users & Tenants > Add User

2. In the Create user screen, click user >entities> event subscription in the right pane.
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3. Fill the values in the fields described below:

4. Click Add to subscribe to a specific event or click Add all to add all the events available in

ATOM.

An email is triggered and sent to the user when any of the events occur in ATOM.

You can configure the mail to be sent immediately after the occurence of the event or

schedule the mail notifications to be sent at periodic intervals as illustrated in the

screenshot below:

Workflow-User-Level-Authorization

If it is decided to have user-level permissions what should be the default permissions? That

question is answered by the global configuration at

/controller:nacm/workflow-policy-for-auto-creation-of-authorization

If it is needed to customize those permissions for a specific user? That question is answered by

this model

Using this model you can use

1. enable the user level permissions

2. choose to use the global default or customize

Here three options are there

DISABLE:: Is the default selection. Using this option you can explicitly disable the auto-creation

of permission for this user.

ENABLE: Enables global defaults for this user.
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READ-ONLY-PERMISSION: Enables the read-only permissions out of the global defaults

OVERRIDE-GLOBAL-CONFIG: Enables user-level permission creation for this user, and, for those

permissions, you're going to specify here, explicitly.

1. Navigate to Administration > Users & Tenants > Add User

2. In the Create user screen, click user >entities>

workflow-user-level-permission-authorization in the right pane.

3. By default workflow-user-level- the authorization is disabled.

Configuring NACM
By implementing NACM developed by NETCONF, ATOM enables administrators to allow or deny

access to protocol operations and data to a set of users. Access Control in ATOM is achieved by

a combination of “Rule-list” and “User Groups”. Rules are grouped into Rule-list and users are

assigned to User Groups to control access to resources managed by ATOM.

To set the global access control settings in ATOM, do the following:

1. Navigate to Administration > Users & Tenants > Users & Roles

2. Click Edit to modify the global settings for access control.

As an administrator, you can set the default access control settings which are applicable

to all entities in ATOM

● Enable NACM: Select this option to set a group of read, write, and execute

options that should be applied by default to all the entities in ATOM.

● Read Default: The default value is “permit” for all the

operations/objects(Controls whether read access is granted if no appropriate

rule is found particular read request)

361



ATOM User Guide

● Write Default: The default value is “deny” for all the operations/objects(Controls

whether create, update or delete access is granted if no appropriate rule is found

particular write request)

● Exec Default: The default value is “permit” for all the

operations/objects(Controls whether exec access is granted if no appropriate rule

is found particular protocol operation request)
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Note: These default settings that are entered in the above screen can be overridden by the

values set by a specific rule created for an entity.

Adding User Groups

You can organize users into groups and apply the access control privileges to them as a whole.

To create a User Group:

1. Navigate to Administration >Users & Tenants >Users & Roles> click NACM

2. In the Details pane, on the right, click Groups > Add Group
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● Name: Enter the name for the User Group

● Select a user to this group.

Creating Rule lists

Rule lists are an aggregated list of rules created in ATOM.

1. Navigate to Administration > Users & Tenants >Users & Roles> click NACM

2. In the Entities pane, on the right, click Rule-list > Add(+)

3. Name: Enter the text that will be used as a name for the rule list.

4. Select a group (user group) to which the created rules in the Rule list should be assigned.

Creating Rule V2:

Rules are the conditions that identify individual objects in the system. Rules also capture

whether a user of a network object should be “granted” or “denied” RPC permission.

RPC : Choose a remote procedure call (RPC) on which the access control needs to be applied.

1. Click the created Rule-list > Entities > Rule V2 > Add(+)

2. In the Create rule screen, enter values in the fields explained below:

Create a Rule v2, “rulev2” to be given the multiple RPCs in drop-down  Permit-RPC-Exec(Ex: Run

device inventory, Extended inventory etc,) and Deny-RPC-Exec(Ex: Topology inventory, run DSL

are etc)
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● Select a rule v2 that will be shown the below permit and deny data node,to grant either

allow or deny access to the rule determined to match a particular request.

○ Permit datanode

○ Deny datanode

Click on rule v2 to add(+) permit data node to fill the below details:

● Id :Enter string or number(Ex:2)
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● Path : Enter the path of the object in the data tree on which the rule should be applied.

This is applicable only for the rule type, ‘data-node’ Select the single or multiple Data

node paths

● Access operations : Select any of the operations on the ATOM entity that needs to be

controlled.

○ *  [This symbol indicates all the operations (Create, Update, Delete, Read) are

included]

○ Create read update delete

○ Read create

○ Read update

○ Read delete

○ Various operation to be tested
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Click on rule v2 to add(+) deny data node to fill the below details:

● Id : Enter string or number(Ex:3)

● Path : Enter the path of the object in the data tree on which the rule should be applied.

This is applicable only for the rule type, ‘data-node’ Select the single or multiple Data

node paths

● Access operations : Select any of the operations on the ATOM entity that needs to be

controlled.

○ *  [This symbol indicates all the operations (Create, Update, Delete, Read) are

included]

○ Create read update delete

○ Read create

○ Read update

○ Read delete

○ Various operation to be tested
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Workflow Authorization under rule v2:

Camunda allows users to authorize access to the data it manages. This makes it possible to

configure which user can access which process instances, tasks, etc…If it is needed to customize

those permissions  for a specific workflow user

Deployment: The option is weather package is upload/load/unload and delete the package

Click on Workflow authorization to add(+) to fill the below details for Deployment:
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● Id : Id is the hardcoded

● Resource type : Select the resource type is Deployment

● Resource id : Select  (*) from resource id drop down to be accessed by all packages or

any specific package resource id.

● Grant type:

● Grant: Ranges over users and groups and grants a set of permissions. Grant

authorizations are commonly used for adding permissions to a user or group that the

global authorization revoked.

● Revoke::Ranges over users and groups and revokes a set of permissions. Revoke

authorizations are commonly used for revoking permissions to a user or group that the

global authorization grants.

● User group: You can select a subset of groups to map it.

● Permissions: A Permission defines the way identity is allowed to interact with a certain

resource. (ALL,Create, Read, Delete)
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Process definition: This option is access the workflow grid with a specific workflow or all based

on the given process definition

Click on Workflow authorization to add(+) to fill the below details for process definition:

● Id :Id is the hardcoded

● Resource type : Select the resource type is process definition

● Resource id : Select  (*) from resource id drop down to be accessed by all workflows or

give any specific workflow of resource id.

● Grant type:

● Grant: Ranges over users and groups and grants a set of permissions. Grant

authorizations are commonly used for adding permissions to a user or group that the

global authorization revoked.

● Revoke::Ranges over users and groups and revokes a set of permissions. Revoke

authorizations are commonly used for revoking permissions to a user or group that the

global authorization grants.

● User group: You can select a subset of groups to map it.

● Permissions: A Permission defines the way identity is allowed to interact with a certain

resource. Choose the various permission (ALL, Create instance, Read, Delete- instance,

Update-instance, update-history, Migrate-instance, Update-task-variable, Update-task)
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Workflow instance: This option is a workflow instance and is a running instance of a workflow

definition.

Click on Workflow authorization to add(+) to fill the below details for Workflow instance

● Id:Id is the hardcoded

● Resource type : Select the resource type is Workflow instance

● Resource id : Select  (*) from resource id drop down to be accessed by all workflow

instances or any specific workflow instance of resource id.

● Grant type:

● Grant:Ranges over users and groups and grants a set of permissions. Grant

authorizations are commonly used for adding permissions to a user or group that the

global authorization revoked.

● Revoke::Ranges over users and groups and revokes a set of permissions. Revoke

authorizations are commonly used for revoking permissions to a user or group that the

global authorization grants.

● User group: You can select a subset of groups to map it.

● Permissions: A Permission defines the way identity is allowed to interact with a certain

resource. Choose the various permission(ALL, Create, Update, Read, Delete)
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Tasks: This option is a user can perform different actions on a task, like assigning the task,

claiming the task, or completing the task. If a user has “Update” permission on a task (or

“Update Task” permission on the corresponding process definition) then the user is authorized

to perform all these task actions

Click on Workflow authorization to add(+) to fill the below details for Task

● Id :Id is the hardcoded

● Resource type : Select the resource type is Task

● Resource id : Select  (*) from resource id drop down to be accessed by all workflow

tasks or any specific workflow task of resource id.

● Grant type:

● Grant: Ranges over users and groups and grants a set of permissions. Grant

authorizations are commonly used for adding permissions to a user or group that the

global authorization revoked.

● Revoke::Ranges over users and groups and revokes a set of permissions. Revoke

authorizations are commonly used for revoking permissions to a user or group that the

global authorization grants.

● User group: You can select a subset of groups to map it.

● Permissions: A Permission defines the way identity is allowed to interact with a certain

resource.Choose the various permission(ALL, Create, Update, Read, Delete,

Read-History, Task-Assign, Task-Work)
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Note:: Need to be given the permit rpc exec in rule v2 based on given workflows & follow the

workflow payload

<output>

<user-summary>

<username>srikanth</username>

<write-default>inherit-from-global</write-default>

<read-default>inherit-from-global</read-default>

<exec-default>inherit-from-global</exec-default>

<roles/>

<user-group>

<name>group_disney</name>

<rule-list>

<name>rulelist_disney</name>

<group>group_disney</group>

<rule-v2>

<permit-rpc-exec>/controller:retrieve-configs</permit-rpc-exec>

<permit-rpc-exec>/controller:run-device-inventory</permit-rpc-exec>

<permit-rpc-exec>/disney_ipv6_api:get-neighbor-devices</permit-rpc-exec>
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<permit-rpc-exec>/disney_ipv6_api:ipv6-junos-routing</permit-rpc-exec>

<permit-rpc-exec>/disney_ipv6_api:isis-routing</permit-rpc-exec>

<permit-rpc-exec>/disney_ipv6_api:servicemodel_update</permit-rpc-exec>

<permit-rpc-exec>/disney_ipv6_config:append-task-details</permit-rpc-exec>

<permit-rpc-exec>/disney_ipv6_config:execute-command</permit-rpc-exec>

<permit-rpc-exec>/disney_ipv6_config:ipv6-addition</permit-rpc-exec>

<permit-rpc-exec>/disney_ipv6_config:ipv6-routing</permit-rpc-exec>

<permit-rpc-exec>/configarchive:config-diff</permit-rpc-exec>

<workflow-authorizations/>

<permit-data-node>

<id>1</id>

<access-operations>read create update delete</access-operations>

<path>/ipam:ipv6-pools</path>

</permit-data-node>

<permit-data-node>

<path>/controller:devices</path>

<id>2</id>

<access-operations>*</access-operations>

</permit-data-node>

</rule-v2>

</rule-list>

<group-level-workflow-authorizations>

<authorization>ID:3585112 GRANT PROCESS_DEFINITION ipv6_configs

[ALL]</authorization>

<authorization>ID:3591653 GRANT PROCESS_DEFINITION

interface_ipv6_configuration [ALL]</authorization>

<authorization>ID:3610357 GRANT PROCESS_DEFINITION

ipv6_routing_configuration [ALL]</authorization>

<authorization>ID:3611232 GRANT PROCESS_DEFINITION bgp_peer_configuration

[ALL]</authorization>

<authorization>ID:3585054 GRANT PROCESS_INSTANCE * [ALL]</authorization>
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</group-level-workflow-authorizations>

</user-group>

<user-level-workflow-authorizations/>

</user-summary>

</output>

Integrating ATOM with Central Authentication Systems
By integrating with central authentication systems such as LDAP, AD or TACACS, the users

created in these servers can login to ATOM using their credentials created in their respective

servers.

Managing Active Directory Users()

You can import users of Active Directory into ATOM and manage them as other users of ATOM.

For secure communication between the AD server and ATOM, import the security certificate

into ATOM.

1. Navigate to Keycloak > System Realm > User Federation >ldap

2. Enter the following:

○ URL: Enter the URL address of the Active Directory(Ex:ldap://172.16.2.223)

○ Domain: Enter the name of the domain(Ex:anutadev.com)

3. After adding the AD in Keycloak, click Test Connection and Test Authentication to check

the connectivity between the ATOM server and AD server and save the configuration
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Once Test Connection and Test Authentication are passed then click on Synchronize All Users

and it will automatically add them into the users Tab.

4. Now login as AD User Via ATOM

Managing OpenLDAP Users
You can import the existing LDAP users and user groups of a tenant, thus enabling the tenant

users to log in to ATOM using their LDAP credentials.

Importing OpenLDAP Users:

1. Navigate to Keycloak > System Realm > User Federation >Ldap
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2. In the Create OpenLDAP screen, enter the values in the following fields:

i. URL: Enter the LDAP URL of the tenant. Include port number and base

distinguished name (DN)

Example: "ldap://localhost:10389/o=nCloud"

ii. Manager Dn: Type the distinguished name (DN) of the LDAP manager. This

manager should have at least read permission.

Example: “uid=admin, ou=system"

iii. Manager Password: Type a password for the entered DN. Example: secret

iv. User Search Filter: Specify a search filter. This field determines the query to be

run to identify the user record. Always include a query in brackets '(' ')'. Example:

“(uid={0})”
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v. User Search Base: Specify a relative DN (from the root/base DN) where users are

located. Example: “ou=users”

NOTE: In LDAP, {0} is a placeholder (token) for the login user ID.

● Group Search Filter: This field determines the query to be run to identify the

user in a group. Always include a query in brackets '(' ')'. Example:

“(uniqueMember={0})”

● Group Search Base: Specify a relative DN (from the root/base DN) where user

groups are located. Example: “ou=groups”

● Group Role Attribute: Specify the attribute name of a role in a group. Example:

“cn”

● User-Lastname Attribute: Attribute that contains the user's last name. Example:

“sn”

● User- Firstname Attribute: Attribute that contains user's first name. Example:

“cn”

● Sync-Freq-in-Hours: Type the interval, in hours, at which ATOM should query the

AD/LDAP directory to schedule an automatic update.

● Last-Syn-Req-Time: The timestamp of the last successful synchronization with

the LDAP server is displayed.

After adding the LDAP in Keycloak, click Test Connection and Test Authentication to check the

connectivity between the ATOM server and LDAP server and save the configuration
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Once Test Connection and Test Authentication are passed then click on Synchronize All Users

and it will automatically add in the user's Tab which was present on the LDAP server.

3. Now login as Ldap User via ATOM
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Managing TACACS Users
By integrating TACACS with ATOM, you can achieve a unified authentication system so that the

same login credentials (username and password) can be used to access not only for managing

network devices but for UNIX and Linux servers too. Therefore, the permissions and privileges

to access the devices can be assigned and delegated through ATOM as systems rights.

To integrate the ATOM with TACACS, do the following:

1. Navigate to Keycloak > System Realm > User Federation >tacacs provider

2.

3. In the Create TACACS screen, enter values in the following fields:

i. Host Name: Enter the IP address of the host, which is hosting the TACACS

server(172.16.4.50)

ii. Auth Key: Enter the key used to specify an encryption key for encrypting and

decrypting all traffic between the ATOM server and the TACACS

server(testing123)
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iii. Port Number: Enter the TCP port number to be used when making connections

to the TACACS+ daemon.  The default port number is 49.

4. Now login as TACACS User Via ATOM.

Customizing the Dashboard using DSL
DSL, Domain Specific Language, developed by Anuta can be used for the representation and

visualization of data derived from the devices managed by ATOM. DSL taps into YANG models,

platforms or third-party APIs to express code for model pre and post-condition specification,

rule expressions, rule logic, and RPC implementation logic. Some of the advantages that you can

enjoy by implementing DSL are no more manual JAVA or Python code to carry out simple

validations, side effect processing, the ability to offer richer expressions than xpath 1.0 used by

YANG, static analysis of business logic, side- effect analysis, advanced user experience, and

ability to change the logic on a live system.

Starting from the 7.x release, Dashboard, the landing page of ATOM, is organized into dashlets.

A dashlet is an individual component that can be added to or removed from a dashboard. Each

dashlet is a reusable unit of functionality, providing a summary of the feature or the function

supported by ATOM and is rendered as a result of the custom queries written in DSL.

You can customize the look of the Dashboard, by adding the dashlets of your choice, and

dragging and dropping (the extreme right corner of the dashlet) to the desired location on the

dashboard.
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Each dashlet contains the summary or the overview of the feature or the functionality

supported by ATOM.

For example, the dashlet “Device” displays the summary of devices managed by ATOM.

Some of the statistics that can be of interest in this dashlet could be as follows:

● Total number of devices

● Number of online devices

● Number of offline devices

These statistics can be gathered by ATOM and displayed in the corresponding dashlet depending

on the DSL query written for each of them. For information about writing DSL queries, refer to

the section, “Writing DSL Queries”

You can save the layout containing the dashlets of your choice and set them in a particular

order.

Writing DSL Queries

1. For writing any new DSL query in the editor, browse to Developer Tools   > DSL  >  DSL

Editor.
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Sample DSL Query

Below is a sample DSL which will display Total/Offline/Online devices in ATOM as a card

layout

(n {:view "number-card", :label "Device", :id "device", :icon "icon-Devices.svg"} "Each-Card"

(n {:label "Total"} "Each-Card"

["count" (get-count-by-schema-path "/controller:devices/device")]

)

(n {:label "Offline", :icon "status-Critical.svg"} "Each-Card"

["count" (get-count-by-schema-path "/controller:devices/device/status" ["OFFLINE"])]

)

(n {:label "Online", :icon "status-Minor.svg"} "Each-Card"

["count" (get-count-by-schema-path "/controller:devices/device/status" ["ONLINE"])]

)

)

2. Click to Run button on the top of the editor to check if DSL is working as expected.
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Go to the right pane to view the result. There are three tabs in the right-side panel Preview,

Result and Logs

● Check the Preview of layout (Card, Grid, Pie Grid,Pie Chart) for the DSL in the

Preview tab.

● XML output of the DSL will be shown in the Result tab

● All errors of the DSL will be listed in the Logs tab in case of any failures.

After the successful execution of a DSL query, you can save and use this as a new Report

or incorporate it into the Dashboard view. All DSL queries will be saved in

Administration  >  DSL Queries.

Customizing the Dashboard

After the successful execution of the DSL query, if you want to incorporate the DSL into

Dashboard, browse to Developer Tools > DSL < DSL Queries to view all the queries as shown

below:
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Click on the view/download option in DSL query, it can be shown as XML/JSON/CSV form

template.

Include your new DSL and click the Save button on the right-side panel of the Editor.
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Now you can browse to Dashboard to view the report that has been included (due to the new

DSL query that was added) in the Dashboard DSL.

DSL Assignment

The define the DSL assignment is associated with the group and DTO is a transfer of the

object(to get the navigation menu items after login user).

Navigate > Developer Tools  >  DSL  >  DSL Assignment  >  Add
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Tag Management
Navigate > Administration > Tag Management

By creating the tags in global, it should show in create alert rule definition

UI Customizations
Customization give control to the user.Customization may involve moving items around an

interface to reflect the users’ priorities

1. Grid column: Grid columns allows us to select which grid columns can be shown for each

entity. Current by default we have one for devices now in the grid column.

Navigate > Administration > UI customization > Grid column >Add
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2. Chart-specs:

A Chart Spec defines the query to be used, variables used in the query, and the intended graph

type. For example, a chart spec can be written for a TopNUtilizedInterfaces report. The query

would use variables for the device and the N.

An admin may decide to create two invocations of this chart spec and make them available

readily; one for the top 5 and one for the top 10. Admin can do so by creating 2 chart-invocation

payloads and giving 25 and 50 for the N value. An end user can run these two different charts

out of the box. In addition, the end user can tweak the parameter values and explore the

graphs.

If a user decides to save the changed chart invocations it is a simple matter of changing the

corresponding chart invocation objects.

Navigate > Administration > UI customization > chart -specs >Add
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3.Chart-Template:

To define the template is a collection of custom charts.create the multiple basic and advanced

custom charts can be grouped into one template.it should show the chart graph in monitoring

Navigate > Administration > UI customization > chart -template >Add
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4. Chart-variables: To define Variables are useful when the user is writing the queries to build a

custom chart. A global variables can be reusable across multiple charts

Here Two types of variables are Constant and Query, Query type is useful to fetch a list of

entities like devices, interfaces etc. and constant is for any static values like bucket interval, etc.

Navigate > Administration > UI customization > chart -variables >Add
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Troubleshoot
From the Troubleshoot tab, the system administrator can perform the following tasks:

● "Services & Metrics"

● "Queue Statistics"

● “Device Comm and Inv”

Services & Metrics :

The administrator can view a summary of the health of the server and the associated agents. All

the services running on the ATOM server are also displayed here.

1. Go to Administration > Troubleshoot > Services and Metrics

2. In the left pane, click Servers > Components to view the different categories of the

servers running in ATOM.

3. Click Servers > System Health in the right pane to view the health of the components of

the server.

The health of the associated services is also displayed in the lower pane.

4. Click the Servers icon to view the Services in the right pane.

5. Select a service that is running and view the Statistics and Events associated with the

service in the bottom panel.

Queue Statistics :
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ATOM uses a bus to communicate various events between the different ATOM modules or

components, thereby providing a view of the activity of the Naas Bus.

● Broker Statistics

● Naas Bus Monitor Statistics

Each row represents a particular event that ATOM components publish or subscribe to, thereby

helping in monitoring the Bus.

Device Comm and Inv

Ping

As an administrator, you can check the reachability of a device from ATOM using Ping Test.

1. Navigate to Administration > Troubleshoot > Device Comm & In > Ping Test

2. To create a Ping Test, fill the fields described below:

● IP Address: Enter the IP address of a device that needs to be verified for its

reachability.

● Packet Count: Enter the number of ICMP Echo request messages to be sent.

● Time Out (Sec): Specify a value for the time for which the ping command should

wait for each reply.

SNMP

SNMP Tests You can test if SNMP devices are responding correctly to SNMP queries. By default,

SNMP v2c is supported.

1. Navigate to Administration > Troubleshoot > Device Comm & In > SNMP

2. To create an SNMP test, fill the following fields:

● Device Name: Enter the name of the device

● SNMP Operation: Choose an appropriate SNMP operation from the drop-down menu:

○ GET

○ GET NEXT

○ GET BULK

○ WALK

● SNMP OID: Enter the OID of the SNMP device
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Config Parser

This utility helps you check the parsed output of any running configuration of any device. By

doing so, you can verify the extent to which ATOM supports the config parsing for a given

running configuration. All the parsed configurations can also be visualized in the supported data

models in ATOM.

1. Navigate to Administration > Troubleshoot > Device Comm & Inv > Config Parse

2. Select the device family details for which the config parsing support needs to be verified

in ATOM:
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i. Vendor: Select the vendor from the supported vendor list in ATOM

ii. OS Type: Select the OS type for the device vendor for which the config parsing

needs to be checked

iii. Device Family: Select the device family that the device belongs to

iv. Device Type: Select the type of the device belonging to the selected device

family

v. OS Version: Select the version of the OS

vi. In the Running Config pane, paste the running configuration of the device for

which config parsing needs to be verified

vii. Click Submit to generate the Config Parsing Report

The results of the Report can be viewed in the right pane as

● Parsed Data: The configuration, which is parsed in ATOM, for which the data model is

available  can be viewed in this tab.

● Parsed Configurations: The running configuration that is parsed into blocks by  ATOM

can be viewed in this tab.

● Parsing Errors: The parsed configuration derived in ATOM but with errors can be viewed

in this tab.

● UnSupported Configurations: The running configuration for which there is no parsing

support available in ATOM can be viewed in this tab

File Server

File server helps users to upload and can also down the packages related to the services or any

workflow if any user wants to save a package in the repository.

Navigate to Administration > File Server and click on the add button.

Name: Enter the name of the package

Choose File: Upload a package or a file that needs to be saved.
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About
Navigate > Administration > About

This will show the current version of ATOM instance, last upgrade time, and support URL.
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